aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2017-08-28 13:02:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2017-08-28 13:02:24 +0000
commit9c44649747774324c8ca3c74c738d35706135992 (patch)
treeda8fedb1bd213e50941c1d1daf9888d1741f3823
parent04e1b6fad4cef254e7f432cd32cc73e10cb95d2f (diff)
Notes
-rw-r--r--UPDATING13
-rw-r--r--security/Makefile1
-rw-r--r--security/gnupg/Makefile2
-rw-r--r--security/gnupg20/Makefile5
-rw-r--r--security/gnupg22/Makefile62
-rw-r--r--security/gnupg22/distinfo3
-rw-r--r--security/gnupg22/files/patch-doc-Makefile.in11
-rw-r--r--security/gnupg22/pkg-descr9
-rw-r--r--security/gnupg22/pkg-plist124
9 files changed, 228 insertions, 2 deletions
diff --git a/UPDATING b/UPDATING
index c7704c4b246e..9f8673632704 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,19 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20170828
+ AFFECTS: users of security/gnupg
+ AUTHOR: adamw@FreeBSD.org
+
+ security/gnupg22 has become the new stable version of GnuPG. This is
+ an LTS branch, and is directly analogous to security/gnupg20. gnupg20
+ will reach EOL at the end of the year, and all gnupg20 users should
+ migrate to gnupg22.
+
+ See https://gnupg.org/faq/whats-new-in-2.1.html for important changes.
+
+ The security/gnupg port will become GnuPG 2.3.x soon.
+
20170820:
AFFECTS: users of www/uwsgi
AUTHOR: ultima@FreeBSD.org
diff --git a/security/Makefile b/security/Makefile
index 8913226236e1..642a05e4a89e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -179,6 +179,7 @@
SUBDIR += gnupg
SUBDIR += gnupg1
SUBDIR += gnupg20
+ SUBDIR += gnupg22
SUBDIR += gnutls
SUBDIR += go.crypto
SUBDIR += go-cve-dictionary
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 86dd1d39ece4..6953cb9ce211 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= libassuan>=2.4.3:security/libassuan \
libgpg-error>=1.16:security/libgpg-error
RUN_DEPENDS= pinentry:security/pinentry
-CONFLICTS= gnupg-2.0.* dirmngr-[0-9]*
+CONFLICTS= gnupg-2.0.* gnupg-2.2.* dirmngr-[0-9]*
CPE_VENDOR= gnupg
USES= compiler:c11 cpe gmake iconv pkgconfig readline sqlite tar:bzip2
diff --git a/security/gnupg20/Makefile b/security/gnupg20/Makefile
index acef1b96805e..142c38161a7f 100644
--- a/security/gnupg20/Makefile
+++ b/security/gnupg20/Makefile
@@ -23,9 +23,12 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
BUILD_DEPENDS= libgpg-error>=1.11:security/libgpg-error
RUN_DEPENDS= pinentry:security/pinentry
-CONFLICTS= gnupg-2.1.*
+CONFLICTS= gnupg-2.1.* gnupg-2.2.*
CPE_VENDOR= gnupg
+DEPRECATED= Will reach EOL upstream on 2017-12-31
+EXPIRATION_DATE=2017-12-31
+
USES= cpe gmake iconv readline tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/security/gnupg22/Makefile b/security/gnupg22/Makefile
new file mode 100644
index 000000000000..fefa2f63a45c
--- /dev/null
+++ b/security/gnupg22/Makefile
@@ -0,0 +1,62 @@
+# $FreeBSD$
+
+PORTNAME= gnupg
+PORTVERSION= 2.2.0
+CATEGORIES= security
+MASTER_SITES= GNUPG
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= The GNU Privacy Guard (modern version)
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL3
+
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libksba.so:security/libksba \
+ libnpth.so:devel/npth
+BUILD_DEPENDS= libassuan>=2.4.3:security/libassuan \
+ libgpg-error>=1.16:security/libgpg-error
+RUN_DEPENDS= pinentry:security/pinentry
+
+CONFLICTS= gnupg-2.0.* gnupg-2.1.* dirmngr-[0-9]*
+CPE_VENDOR= gnupg
+
+USES= compiler:c11 cpe gmake iconv pkgconfig readline sqlite tar:bzip2
+CONFIGURE_ARGS= --disable-ntbtls --disable-wks-tools \
+ --enable-gpg-is-gpg2 --enable-symcryptrun
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INFO= gnupg
+TEST_TARGET= check
+
+OPTIONS_DEFINE= GNUTLS LDAP SCDAEMON NLS DOCS SUID_GPG
+OPTIONS_DEFAULT=GNUTLS SCDAEMON
+NO_OPTIONS_SORT=yes
+OPTIONS_SUB= yes
+
+LDAP_DESC= LDAP keyserver interface
+SCDAEMON_DESC= Enable Smartcard daemon (with libusb)
+SUID_GPG_DESC= Install GPG with suid
+# In jail, SUID is required to avoid warning (security.bsd.unprivileged_mlock sysctl is not used in jail).
+
+GNUTLS_CONFIGURE_ENABLE=gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+
+LDAP_CONFIGURE_WITH= ldap=${LOCALBASE}
+LDAP_LIBS= -L${LOCALBASE}/lib
+LDAP_USE= OPENLDAP=yes
+LDAP_USES= readline
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+
+SCDAEMON_CONFIGURE_ENABLE= scdaemon
+
+post-install:
+ @${MV} ${STAGEDIR}${DATADIR}/help*.txt ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/gnupg22/distinfo b/security/gnupg22/distinfo
new file mode 100644
index 000000000000..e8860e44ae87
--- /dev/null
+++ b/security/gnupg22/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503924513
+SHA256 (gnupg-2.2.0.tar.bz2) = d4514a0be0f7a1ff263193330019eb4b53c82f0f5e230af3c14df371271a45e6
+SIZE (gnupg-2.2.0.tar.bz2) = 6532475
diff --git a/security/gnupg22/files/patch-doc-Makefile.in b/security/gnupg22/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..14a9b786e287
--- /dev/null
+++ b/security/gnupg22/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig 2016-11-18 15:53:57 UTC
++++ doc/Makefile.in
+@@ -522,7 +522,7 @@ CLEANFILES = yat2m mkdefsinc defs.inc
+ DISTCLEANFILES = gnupg.tmp gnupg.ops yat2m-stamp.tmp yat2m-stamp \
+ gnupg-card-architecture.eps \
+ gnupg-module-overview.eps \
+- $(myman_pages) gpg-zip.1 gnupg.7
++ $(myman_pages) gnupg.7
+
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
diff --git a/security/gnupg22/pkg-descr b/security/gnupg22/pkg-descr
new file mode 100644
index 000000000000..4e3878aed42f
--- /dev/null
+++ b/security/gnupg22/pkg-descr
@@ -0,0 +1,9 @@
+GnuPG is a complete and free replacement for PGP. This is the "stable"
+version.
+
+GnuPG allows encrypting and signing your data and communication, and
+features a versatile key management system as well as access modules
+for many public key directories. GnuPG, also known as GPG, is a command
+line tool with features for easy integration with other applications.
+
+WWW: https://www.gnupg.org/
diff --git a/security/gnupg22/pkg-plist b/security/gnupg22/pkg-plist
new file mode 100644
index 000000000000..0d0e14e44540
--- /dev/null
+++ b/security/gnupg22/pkg-plist
@@ -0,0 +1,124 @@
+bin/gpg-agent
+bin/dirmngr
+bin/dirmngr-client
+bin/gpgscm
+bin/gpgsm
+bin/gpgtar
+bin/gpg-connect-agent
+bin/kbxutil
+%%SUID_GPG%%@(,,4555) bin/gpg2
+%%NO_SUID_GPG%%bin/gpg2
+bin/gpgconf
+bin/gpgparsemail
+bin/gpgv2
+bin/symcryptrun
+bin/watchgnupg
+%%LDAP%%libexec/dirmngr_ldap
+libexec/gpg-check-pattern
+libexec/gpg-preset-passphrase
+libexec/gpg-protect-tool
+libexec/gpg-wks-client
+%%SCDAEMON%%libexec/scdaemon
+man/man1/dirmngr-client.1.gz
+man/man1/gpg-agent.1.gz
+man/man1/gpg-connect-agent.1.gz
+man/man1/gpg-preset-passphrase.1.gz
+man/man1/gpg-wks-client.1.gz
+man/man1/gpg-wks-server.1.gz
+man/man1/gpg2.1.gz
+man/man1/gpgconf.1.gz
+man/man1/gpgparsemail.1.gz
+man/man1/gpgsm.1.gz
+man/man1/gpgv2.1.gz
+man/man1/scdaemon.1.gz
+man/man1/symcryptrun.1.gz
+man/man1/watchgnupg.1.gz
+man/man7/gnupg.7.gz
+man/man8/addgnupghome.8.gz
+man/man8/applygnupgdefaults.8.gz
+man/man8/dirmngr.8.gz
+sbin/addgnupghome
+sbin/applygnupgdefaults
+%%PORTDOCS%%%%DOCSDIR%%/DCO
+%%PORTDOCS%%%%DOCSDIR%%/DETAILS
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
+%%PORTDOCS%%%%DOCSDIR%%/KEYSERVER
+%%PORTDOCS%%%%DOCSDIR%%/OpenPGP
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TRANSLATE
+%%PORTDOCS%%%%DOCSDIR%%/examples/README
+%%PORTDOCS%%%%DOCSDIR%%/examples/debug.prf
+%%PORTDOCS%%%%DOCSDIR%%/examples/gpgconf.conf
+%%PORTDOCS%%%%DOCSDIR%%/examples/pwpattern.list
+%%PORTDOCS%%%%DOCSDIR%%/examples/scd-event
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/README
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/dirmngr.service
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/dirmngr.socket
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/gpg-agent-browser.socket
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/gpg-agent-extra.socket
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/gpg-agent-ssh.socket
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/gpg-agent.service
+%%PORTDOCS%%%%DOCSDIR%%/examples/systemd-user/gpg-agent.socket
+%%PORTDOCS%%%%DOCSDIR%%/examples/trustlist.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/vsnfd.prf
+%%PORTDOCS%%%%DOCSDIR%%/help.be.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.ca.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.cs.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.da.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.de.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.el.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.eo.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.es.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.et.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.fi.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.fr.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.gl.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.hu.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.id.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.it.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.ja.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.nb.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.pl.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.pt.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.pt_BR.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.ro.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.ru.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.sk.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.sv.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.tr.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.zh_CN.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.zh_TW.txt
+%%DATADIR%%/distsigkey.gpg
+%%DATADIR%%/sks-keyservers.netCA.pem
+%%NLS%%share/locale/ca/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/et/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnupg2.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gnupg2.mo
+@postexec [ -e %D/bin/gpg ] || ln -sf gpg2 %D/bin/gpg
+@postunexec [ -e %D/bin/gpg ] || rm -f %D/bin/gpg