aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2020-06-26 08:44:32 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2020-06-26 08:44:32 +0000
commitad22e35120d06c623ea0d3b910405045739efbac (patch)
treec04db7c76ea384598e3d05697faf0b767d799b6f
parentc22697154fb3c053ea43e996fbf60fea238427cf (diff)
downloadports-ad22e35120d06c623ea0d3b910405045739efbac.tar.gz
ports-ad22e35120d06c623ea0d3b910405045739efbac.zip
MFH: r540411
www/chromium: Update to 83.0.4103.106 and fix synchronization PR: 244185, 246387 Reported by: bourne.identity@hotmail.com Approved by: ports-secteam (implicit), chromium@ (rene), cem Obtained from: Robert Nagy via OpenBSD port Security: https://www.vuxml.org/freebsd/6a5d15b6-b661-11ea-8015-e09467587c17.html Differential Revision: https://reviews.freebsd.org/D25449
Notes
Notes: svn path=/branches/2020Q2/; revision=540450
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/distinfo10
-rw-r--r--www/chromium/files/patch-base_system_sys__info.cc11
-rw-r--r--www/chromium/files/patch-base_system_sys__info__freebsd.cc22
-rw-r--r--www/chromium/files/patch-components_sync__device__info_device__info__sync__bridge.cc16
5 files changed, 36 insertions, 25 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index ea5d3c34ecf4..367cb7ea65fe 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 83.0.4103.97
+PORTVERSION= 83.0.4103.106
CATEGORIES?= www java
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/cpm/chromium/:fonts
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index ec1088a754b9..62baeea6f09e 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1591262286
-SHA256 (chromium-83.0.4103.97.tar.xz) = 12c405f61284cfc78f8c2b6600f3c1ae61a83b639c41087bb4f74fcaab036f83
-SIZE (chromium-83.0.4103.97.tar.xz) = 802603824
-SHA256 (chromium-83.0.4103.97-testdata.tar.xz) = b8787a82efe64d12b0ca7ee0af9eb0e27aa1a85bc75649ab6aef1f5e9ea9f6f4
-SIZE (chromium-83.0.4103.97-testdata.tar.xz) = 257142948
+TIMESTAMP = 1593091518
+SHA256 (chromium-83.0.4103.106.tar.xz) = cfd153a2e10b0bb0fb3b7e6be543aef0915181f5fbdbea893d08465afd097e2f
+SIZE (chromium-83.0.4103.106.tar.xz) = 802630620
+SHA256 (chromium-83.0.4103.106-testdata.tar.xz) = bf0c38e3d59fc346788eb25487956ae40490a88dfd6b1d4c8edacb075873678e
+SIZE (chromium-83.0.4103.106-testdata.tar.xz) = 257157012
SHA256 (test_fonts.tar.xz) = cf9cbe3b7f1c4c42d426bddc65ec178d333ad7e205a36fe0a606a3c0c545ece1
SIZE (test_fonts.tar.xz) = 200040
diff --git a/www/chromium/files/patch-base_system_sys__info.cc b/www/chromium/files/patch-base_system_sys__info.cc
new file mode 100644
index 000000000000..acf115c95c91
--- /dev/null
+++ b/www/chromium/files/patch-base_system_sys__info.cc
@@ -0,0 +1,11 @@
+--- base/system/sys_info.cc.orig 2020-06-25 12:19:57 UTC
++++ base/system/sys_info.cc
+@@ -102,7 +102,7 @@ void SysInfo::GetHardwareInfo(base::OnceCallback<void(
+ #elif defined(OS_ANDROID) || defined(OS_MACOSX)
+ base::ThreadPool::PostTaskAndReplyWithResult(
+ FROM_HERE, {}, base::BindOnce(&GetHardwareInfoSync), std::move(callback));
+-#elif defined(OS_LINUX)
++#elif defined(OS_LINUX) || defined(OS_BSD)
+ base::ThreadPool::PostTaskAndReplyWithResult(
+ FROM_HERE, {base::MayBlock()}, base::BindOnce(&GetHardwareInfoSync),
+ std::move(callback));
diff --git a/www/chromium/files/patch-base_system_sys__info__freebsd.cc b/www/chromium/files/patch-base_system_sys__info__freebsd.cc
index 12994422dc08..9a5dd310f92a 100644
--- a/www/chromium/files/patch-base_system_sys__info__freebsd.cc
+++ b/www/chromium/files/patch-base_system_sys__info__freebsd.cc
@@ -1,6 +1,11 @@
---- base/system/sys_info_freebsd.cc.orig 2019-12-16 21:50:40 UTC
+--- base/system/sys_info_freebsd.cc.orig 2020-06-15 18:59:42 UTC
+++ base/system/sys_info_freebsd.cc
-@@ -13,26 +13,59 @@
+@@ -9,30 +9,76 @@
+ #include <sys/sysctl.h>
+
+ #include "base/logging.h"
++#include "base/strings/string_util.h"
+
namespace base {
int64_t SysInfo::AmountOfPhysicalMemoryImpl() {
@@ -62,6 +67,17 @@
}
+
return static_cast<uint64_t>(limit);
++}
++
++SysInfo::HardwareInfo SysInfo::GetHardwareInfoSync() {
++ HardwareInfo info;
++ // Set the manufacturer to "FreeBSD" and the model to
++ // an empty string.
++ info.manufacturer = "FreeBSD";
++ info.model = HardwareModelName();
++ DCHECK(IsStringUTF8(info.manufacturer));
++ DCHECK(IsStringUTF8(info.model));
++ return info;
}
--
+
} // namespace base
diff --git a/www/chromium/files/patch-components_sync__device__info_device__info__sync__bridge.cc b/www/chromium/files/patch-components_sync__device__info_device__info__sync__bridge.cc
deleted file mode 100644
index c075e1c2a99c..000000000000
--- a/www/chromium/files/patch-components_sync__device__info_device__info__sync__bridge.cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- components/sync_device_info/device_info_sync_bridge.cc.orig 2020-03-16 18:40:31 UTC
-+++ components/sync_device_info/device_info_sync_bridge.cc
-@@ -456,11 +456,13 @@ void DeviceInfoSyncBridge::OnStoreCreated(
- return;
- }
-
-+#if !defined(OS_BSD)
- store_ = std::move(store);
-
- base::SysInfo::GetHardwareInfo(
- base::BindOnce(&DeviceInfoSyncBridge::OnHardwareInfoRetrieved,
- weak_ptr_factory_.GetWeakPtr()));
-+#endif
- }
-
- void DeviceInfoSyncBridge::OnHardwareInfoRetrieved(