aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-02-12 16:46:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-02-12 16:46:23 +0000
commitaf13aa1d5ade82c77983431447fe548a4a2a8b03 (patch)
tree67d9a52057aeec6fe5dea083c10d121698bcf41e
parent7ada5affed049fa6c975d47ea65bb3fd4e834e2f (diff)
downloadports-af13aa1d5ade82c77983431447fe548a4a2a8b03.tar.gz
ports-af13aa1d5ade82c77983431447fe548a4a2a8b03.zip
Notes
-rw-r--r--mail/evolution/Makefile8
-rw-r--r--misc/compat4x/Makefile14
-rw-r--r--misc/compat5x/Makefile11
-rw-r--r--misc/compat6x/Makefile10
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile4
-rw-r--r--ports-mgmt/portupgrade/Makefile4
6 files changed, 7 insertions, 44 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 491993667fd3..504d4a8af362 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -27,8 +27,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack evolutiondataserver gtkhtml3 \
USE_AUTOTOOLS= libtool:15
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/evolution/%%VERSION%%
+USE_LDCONFIG= ${PREFIX}/lib/evolution/${EVO_VERSION}
CONFIGURE_ARGS= --enable-nss=yes \
--enable-mono=no \
--with-sub-version=" FreeBSD GNOME Team Port"
@@ -56,9 +55,6 @@ OPTIONS= PILOT "Enable Palm Pilot sync support" off \
.include <bsd.port.pre.mk>
-USE_LDCONFIG= ${PREFIX}/lib/evolution/${EVO_VERSION}
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
-
.if defined(WITH_PILOT)
LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnome-pilot
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
@@ -100,7 +96,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/sbin|${LOCALBASE}/bin|g' \
${WRKSRC}/plugins/sa-junk-plugin/em-junk-filter.c
-post-install: install-ldconfig-file
+post-install:
${MKDIR} ${PREFIX}/include/evolution-${EVO_VERSION}/composer
${INSTALL_DATA} ${WRKSRC}/composer/e-msg*.h ${PREFIX}/include/evolution-${EVO_VERSION}/composer
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index 8ebba6459b5f..1dcafed20930 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -23,12 +23,9 @@ RUN_DEPENDS= ${LOCALBASE}/share/compat/locale/UTF-8/LC_CTYPE:${PORTSDIR}/misc/lo
WRKSRC= ${WRKDIR}/usr/lib/compat
NO_BUILD= yes
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
LDCONFIG_LIB32= ${LDCONFIG} -32
-USE_LDCONFIG= ${TARGET_DIR}
.include <bsd.port.pre.mk>
@@ -63,9 +60,8 @@ PLIST_SUB+= I386_ONLY="@comment "
PLIST_SUB+= AMD64_ONLY="" AMD64NA="@comment "
PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
-.undef USE_LDCONFIG
-USE_LDCONFIG= no
.else
+USE_LDCONFIG= ${TARGET_DIR}
PLIST_SUB+= AMD64_ONLY="@comment " AMD64NA=""
.endif
@@ -109,13 +105,7 @@ do-install:
${LN} -sf ${lib}.compat4x ${TARGET_DIR}/${lib}
.endfor
-# Include to automatic install file in libdata/ldconfig{,32}
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
-
-post-install: install-ldconfig-file
-.if ${ARCH} == amd64
- ${LDCONFIG} -32 -m ${TARGET32_DIR}
-.endif
+post-install:
@${CAT} ${PKGMESSAGE}
pre-clean:
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index c44647d98bde..255fc521bf57 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -28,8 +28,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
NO_BUILD= yes
ONLY_FOR_ARCHS= alpha amd64 i386 sparc64
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
USE_LDCONFIG= ${TARGET_DIR}
@@ -75,13 +73,4 @@ do-install:
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif
-# Include to automatic install file in libdata/ldconfig{,32}
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
-
-post-install: install-ldconfig-file
-.if ${ARCH} == amd64
- @${LDCONFIG} -32 -m ${TARGET32_DIR}
-.endif
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/misc/compat6x/Makefile b/misc/compat6x/Makefile
index 2f59ccbf79f5..e24051342eb7 100644
--- a/misc/compat6x/Makefile
+++ b/misc/compat6x/Makefile
@@ -21,8 +21,6 @@ USE_BZIP2= yes
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64 alpha sparc64
PLIST= ${PKGDIR}/pkg-plist.${ARCH}
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
USE_LDCONFIG= ${TARGET_DIR}
@@ -46,13 +44,7 @@ do-install:
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif
-# Include this file to use install-ldconfig-file
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
-
-post-install: install-ldconfig-file
-.if ${ARCH} == amd64
- @${LDCONFIG} -32 -m ${TARGET32_DIR}
-.endif
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 8131c536495b..4a6d28c65600 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -25,7 +25,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -55,7 +54,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -84,7 +82,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 549455c220ef..db0dfd945758 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -26,7 +26,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -56,7 +55,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -85,7 +83,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi