aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-04 09:28:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-04 09:28:36 +0000
commitafaa9f3040484b934ed2b3b741493b336b3e9870 (patch)
tree01450b9faaa5036fa5038c75f04ae1835d365b93
parent14cc1e4e24346d9af3f14ccad7042119d03490ba (diff)
Notes
-rw-r--r--databases/xapian-core/Makefile11
-rw-r--r--databases/xapian-core/distinfo6
-rw-r--r--databases/xapian-core/files/patch-Makefile.in47
-rw-r--r--databases/xapian-core/files/patch-clang10
-rw-r--r--databases/xapian-core/pkg-descr2
-rw-r--r--databases/xapian-core/pkg-plist21
-rw-r--r--deskutils/pinot/Makefile2
-rw-r--r--deskutils/recoll/Makefile1
-rw-r--r--mail/mu/Makefile2
-rw-r--r--mail/notmuch/Makefile1
-rw-r--r--sysutils/baloo/Makefile2
11 files changed, 51 insertions, 54 deletions
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index a94151f450d3..715aff37cd25 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xapian-core
-PORTVERSION= 1.2.24
+PORTVERSION= 1.4.3
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
@@ -14,6 +14,8 @@ COMMENT= Probabilistic text search database engine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+CONFLICTS_INSTALL= xapian-core10- xapian-core12-
+
OPTIONS_DEFINE= DOCS SSE2
SSE2_DESC= Use SSE2 for floating point
@@ -24,13 +26,14 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= libtool pathfix tar:xz
+PORTDATA= *
PORTDOCS= *
SSE2_CONFIGURE_ENABLE= sse
post-install:
-.for file in copydatabase delve quest
- ${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/${file} ${STAGEDIR}${PREFIX}/bin/xapian-${file}
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/copydatabase ${STAGEDIR}${PREFIX}/bin/xapian-copydatabase
+ ${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/quest ${STAGEDIR}${PREFIX}/bin/xapian-quest
+ ${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/xapian-metadata ${STAGEDIR}${PREFIX}/bin/xapian-metadata
.include <bsd.port.mk>
diff --git a/databases/xapian-core/distinfo b/databases/xapian-core/distinfo
index 8a3ee30e2c17..c265175b9526 100644
--- a/databases/xapian-core/distinfo
+++ b/databases/xapian-core/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475134941
-SHA256 (xapian-core-1.2.24.tar.xz) = 57a82717ba07e9777958b6ef48d94b81ea41ac4c74d544f74da597fab1e1f87b
-SIZE (xapian-core-1.2.24.tar.xz) = 3210192
+TIMESTAMP = 1485562297
+SHA256 (xapian-core-1.4.3.tar.xz) = 7d5295511ca2de70463a29e75f6a2393df5dc1485bf33074b778c66e1721e475
+SIZE (xapian-core-1.4.3.tar.xz) = 2805964
diff --git a/databases/xapian-core/files/patch-Makefile.in b/databases/xapian-core/files/patch-Makefile.in
index 99c5c7140be1..2191732282bc 100644
--- a/databases/xapian-core/files/patch-Makefile.in
+++ b/databases/xapian-core/files/patch-Makefile.in
@@ -1,33 +1,30 @@
---- Makefile.in.orig 2011-08-10 06:54:57 UTC
+--- Makefile.in.orig 2016-12-28 13:56:24 UTC
+++ Makefile.in
-@@ -47,7 +47,8 @@
- @VPATH_BUILD_TRUE@am__append_1 = -I$(top_builddir)/include \
+@@ -101,13 +101,12 @@ host_triplet = @host@
+ @VPATH_BUILD_TRUE@am__append_1 = -I'$(top_builddir)/include' \
@VPATH_BUILD_TRUE@ -I$(top_srcdir)/languages -Ilanguages \
@VPATH_BUILD_TRUE@ -I$(top_srcdir)/queryparser
--bin_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3) \
-+bin_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3)
-+noinst_bin_PROGRAMS = \
- examples/copydatabase$(EXEEXT) examples/delve$(EXEEXT) \
+-bin_PROGRAMS = bin/xapian-delve$(EXEEXT) $(am__EXEEXT_1) \
+- $(am__EXEEXT_2) examples/copydatabase$(EXEEXT) \
++bin_PROGRAMS = bin/xapian-delve$(EXEEXT) $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3)
++noinst_PROGRAMS = examples/copydatabase$(EXEEXT) \
examples/quest$(EXEEXT) examples/simpleexpand$(EXEEXT) \
examples/simpleindex$(EXEEXT) examples/simplesearch$(EXEEXT) \
-@@ -713,7 +714,7 @@
- @BUILD_BACKEND_CHERT_TRUE@@BUILD_BACKEND_FLINT_TRUE@am__EXEEXT_2 = bin/xapian-chert-update$(EXEEXT)
- @BUILD_BACKEND_REMOTE_TRUE@am__EXEEXT_3 = bin/xapian-progsrv$(EXEEXT) \
- @BUILD_BACKEND_REMOTE_TRUE@ bin/xapian-tcpsrv$(EXEEXT)
--PROGRAMS = $(bin_PROGRAMS)
-+PROGRAMS = $(bin_PROGRAMS) $(noinst_bin_PROGRAMS)
- am__bin_xapian_check_SOURCES_DIST = bin/xapian-check.cc \
- bin/xapian-check-brass.cc bin/xapian-check-brass.h \
- bin/xapian-check-chert.cc bin/xapian-check-chert.h \
-@@ -1323,10 +1324,7 @@
- weight/tradweight.cc weight/weight.cc weight/weightinternal.cc
+ examples/xapian-metadata$(EXEEXT)
+ EXTRA_PROGRAMS =
+-noinst_PROGRAMS = $(am__EXEEXT_3)
+ @BUILD_BACKEND_CHERT_OR_GLASS_TRUE@am__append_2 = \
+ @BUILD_BACKEND_CHERT_OR_GLASS_TRUE@ bin/xapian-check\
+ @BUILD_BACKEND_CHERT_OR_GLASS_TRUE@ bin/xapian-compact\
+@@ -1414,10 +1413,7 @@ lib_src = api/compactor.cc api/constinfo
+ weight/tfidfweight.cc weight/tradweight.cc weight/weight.cc \
+ weight/weightinternal.cc
@MAINTAINER_NO_DOCS_FALSE@dist_man_MANS = xapian-config.1 \
- @MAINTAINER_NO_DOCS_FALSE@ $(am__append_3) $(am__append_5) \
--@MAINTAINER_NO_DOCS_FALSE@ $(am__append_7) \
+-@MAINTAINER_NO_DOCS_FALSE@ $(am__append_4) $(am__append_6) \
-@MAINTAINER_NO_DOCS_FALSE@ examples/copydatabase.1 \
--@MAINTAINER_NO_DOCS_FALSE@ examples/delve.1 examples/quest.1 \
+-@MAINTAINER_NO_DOCS_FALSE@ examples/quest.1 \
-@MAINTAINER_NO_DOCS_FALSE@ examples/xapian-metadata.1
-+@MAINTAINER_NO_DOCS_FALSE@ $(am__append_7)
- bin_xapian_check_CPPFLAGS = \
- -I$(top_srcdir)/backends/brass\
- -I$(top_srcdir)/backends/chert\
++@MAINTAINER_NO_DOCS_FALSE@ $(am__append_4) $(am__append_6)
+ bin_xapian_check_SOURCES = bin/xapian-check.cc
+ bin_xapian_check_LDADD = $(ldflags) $(libxapian_la)
+ bin_xapian_compact_SOURCES = bin/xapian-compact.cc
diff --git a/databases/xapian-core/files/patch-clang b/databases/xapian-core/files/patch-clang
deleted file mode 100644
index 2f039a8a66b3..000000000000
--- a/databases/xapian-core/files/patch-clang
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/safeuuid.h.orig 2013-12-04 00:13:34 UTC
-+++ common/safeuuid.h
-@@ -55,6 +55,7 @@
-
- // UUID API on FreeBSD, NetBSD and AIX.
-
-+# include <stdlib.h>
- # ifdef _AIX
- /* AIX uses a byte typedef in its <uuid.h> which collides with ours, so use a
- * macro to rename theirs out of the way.
diff --git a/databases/xapian-core/pkg-descr b/databases/xapian-core/pkg-descr
index 0892c85cc553..732b65106831 100644
--- a/databases/xapian-core/pkg-descr
+++ b/databases/xapian-core/pkg-descr
@@ -15,4 +15,4 @@ Xapian features include:
- Platform independent data formats
- Allows simultaneous update and searching.
-WWW: http://www.xapian.org/
+WWW: https://xapian.org/
diff --git a/databases/xapian-core/pkg-plist b/databases/xapian-core/pkg-plist
index f679fbc769d2..1455fb4c703b 100644
--- a/databases/xapian-core/pkg-plist
+++ b/databases/xapian-core/pkg-plist
@@ -1,18 +1,20 @@
bin/xapian-check
-bin/xapian-chert-update
bin/xapian-compact
bin/xapian-config
bin/xapian-copydatabase
bin/xapian-delve
bin/xapian-inspect
+bin/xapian-metadata
bin/xapian-progsrv
bin/xapian-quest
bin/xapian-replicate
bin/xapian-replicate-server
bin/xapian-tcpsrv
include/xapian.h
-include/xapian/base.h
+include/xapian/attributes.h
include/xapian/compactor.h
+include/xapian/constants.h
+include/xapian/constinfo.h
include/xapian/database.h
include/xapian/dbfactory.h
include/xapian/deprecated.h
@@ -21,9 +23,14 @@ include/xapian/document.h
include/xapian/enquire.h
include/xapian/error.h
include/xapian/errorhandler.h
+include/xapian/eset.h
include/xapian/expanddecider.h
+include/xapian/geospatial.h
+include/xapian/intrusive_ptr.h
+include/xapian/iterator.h
include/xapian/keymaker.h
include/xapian/matchspy.h
+include/xapian/mset.h
include/xapian/positioniterator.h
include/xapian/postingiterator.h
include/xapian/postingsource.h
@@ -42,18 +49,16 @@ include/xapian/visibility.h
include/xapian/weight.h
lib/cmake/xapian/xapian-config-version.cmake
lib/cmake/xapian/xapian-config.cmake
-lib/libxapian.a
lib/libxapian.so
-lib/libxapian.so.22
-lib/libxapian.so.22.7.2
+lib/libxapian.so.30
+lib/libxapian.so.30.3.0
libdata/pkgconfig/xapian-core.pc
man/man1/xapian-check.1.gz
-man/man1/xapian-chert-update.1.gz
man/man1/xapian-compact.1.gz
man/man1/xapian-config.1.gz
-man/man1/xapian-inspect.1.gz
+man/man1/xapian-delve.1.gz
man/man1/xapian-progsrv.1.gz
-man/man1/xapian-replicate.1.gz
man/man1/xapian-replicate-server.1.gz
+man/man1/xapian-replicate.1.gz
man/man1/xapian-tcpsrv.1.gz
share/aclocal/xapian.m4
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 6d668c2e38ad..1dc237a114f9 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinot
PORTVERSION= 1.09
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MAINTAINER= thierry@FreeBSD.org
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index 75ad2c8b09d7..940a782a2f14 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -3,6 +3,7 @@
PORTNAME= recoll
PORTVERSION= 1.21.6
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://www.lesbonscomptes.com/recoll/
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index 353826af9efc..3600fd57d970 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mu
PORTVERSION= 0.9.16
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= mail
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index b286a48ec607..6a51499d96de 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= notmuch
PORTVERSION= 0.24
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://notmuchmail.org/releases/
diff --git a/sysutils/baloo/Makefile b/sysutils/baloo/Makefile
index da228c445fbe..f8671e6803e2 100644
--- a/sysutils/baloo/Makefile
+++ b/sysutils/baloo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= baloo
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils kde kde-kde4
MAINTAINER= kde@FreeBSD.org