aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 14:29:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 14:29:22 +0000
commitb2e0b4a4497c97aec405d6dfa84db6f88d210970 (patch)
tree2a6305331fdd99dd1aa339bbf022025d1f1f2532
parent3b6d3daa88e3e42b0337274cb4065dd51de8dbb1 (diff)
downloadports-b2e0b4a4497c97aec405d6dfa84db6f88d210970.tar.gz
ports-b2e0b4a4497c97aec405d6dfa84db6f88d210970.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Constant/Makefile33
-rw-r--r--devel/p5-Class-Constant/distinfo3
-rw-r--r--devel/p5-Class-Constant/pkg-descr9
-rw-r--r--devel/p5-Class-Constant/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2d6dd686948c..b03e2a46d0bf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -829,6 +829,7 @@
SUBDIR += p5-Class-BlackHole
SUBDIR += p5-Class-C3
SUBDIR += p5-Class-CodeStyler
+ SUBDIR += p5-Class-Constant
SUBDIR += p5-Class-Container
SUBDIR += p5-Class-Contract
SUBDIR += p5-Class-Data-Accessor
diff --git a/devel/p5-Class-Constant/Makefile b/devel/p5-Class-Constant/Makefile
new file mode 100644
index 000000000000..6dccf3a5ef05
--- /dev/null
+++ b/devel/p5-Class-Constant/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Class-Constant
+# Date created: 2006-08-27
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Constant
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Build constant classes
+
+PERL_MODBUILD= yes
+
+MAN3= Class::Constant.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Constant/distinfo b/devel/p5-Class-Constant/distinfo
new file mode 100644
index 000000000000..084c06cf9b1f
--- /dev/null
+++ b/devel/p5-Class-Constant/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Constant-0.05.tar.gz) = 9ee5766c792dcde9b5dbeb1d2dbac6ed
+SHA256 (Class-Constant-0.05.tar.gz) = 7fabfa43ba125e1e365fbeebcddb6d09ac096f62bb0111801645482dee0dca81
+SIZE (Class-Constant-0.05.tar.gz) = 5736
diff --git a/devel/p5-Class-Constant/pkg-descr b/devel/p5-Class-Constant/pkg-descr
new file mode 100644
index 000000000000..e6b3898ff3d6
--- /dev/null
+++ b/devel/p5-Class-Constant/pkg-descr
@@ -0,0 +1,9 @@
+Class::Constant allows you declaratively created so-called "constant
+classes". These are very much like enumerated types (as close as a
+typeless language like Perl can get, at least).
+
+The classes generated by this module are modeled closely after Java's
+"typesafe enumeration" pattern, but with some added spice to make them
+more useful to Perl programs.
+
+WWW: http://search.cpan.org/dist/Class-Constant/
diff --git a/devel/p5-Class-Constant/pkg-plist b/devel/p5-Class-Constant/pkg-plist
new file mode 100644
index 000000000000..eb4b2322e4fa
--- /dev/null
+++ b/devel/p5-Class-Constant/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Class/Constant.pm
+@dirrmtry %%SITE_PERL%%/Class