aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-25 07:29:25 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-25 07:29:25 +0000
commitb54b77fa86514ba06480f6ea22f36379d22cbde8 (patch)
tree262a5db58bff73f86c94d292d6eafdc8e48838a9
parent57902f95836c2de93d5bb65cd20d7f6edf1cfdfd (diff)
These ports now build on powerpc64.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=480642
-rw-r--r--cad/repsnapper/Makefile2
-rw-r--r--databases/mariadb-connector-c/Makefile4
-rw-r--r--devel/dia2code+/Makefile2
-rw-r--r--devel/flatbuffers/Makefile2
-rw-r--r--devel/libgrading/Makefile2
-rw-r--r--devel/liblas/Makefile5
-rw-r--r--devel/py-bullet3/Makefile2
-rw-r--r--emulators/stella/Makefile1
-rw-r--r--games/emptyepsilon/Makefile2
-rw-r--r--games/stonesoup/Makefile1
-rw-r--r--games/traingame/Makefile2
-rw-r--r--graphics/inkscape/Makefile4
-rw-r--r--graphics/mapnik/Makefile5
-rw-r--r--lang/hugs/Makefile5
-rw-r--r--math/cryptominisat/Makefile2
-rw-r--r--math/vowpal_wabbit/Makefile2
-rw-r--r--security/botan2/Makefile1
-rw-r--r--www/cppcms/Makefile2
18 files changed, 8 insertions, 38 deletions
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 7437a00a153d..7ba17b852a1d 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -12,8 +12,6 @@ COMMENT= Controller and GCode generator for RepRap 3D printers
LICENSE= GPLv2 BSD3CLAUSE MIT
LICENSE_COMB= multi
-BROKEN_powerpc64= fails to compile: clipper.hpp:52:10: 'vector' file not found
-
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
diff --git a/databases/mariadb-connector-c/Makefile b/databases/mariadb-connector-c/Makefile
index 0c4779b854e4..c858c8530878 100644
--- a/databases/mariadb-connector-c/Makefile
+++ b/databases/mariadb-connector-c/Makefile
@@ -19,7 +19,7 @@ COMMENT= MariaDB database connector for C
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-BROKEN_powerpc64= fails to compile: my_stmt_codec.c: error: invalid use of void expression
+LIB_DEPENDS= libcurl.so:ftp/curl
CONFLICTS_INSTALL= mariadb[0-9]*-client-* \
mariadb102-server-* \
@@ -31,8 +31,6 @@ USE_LDCONFIG= ${PREFIX}/lib/mariadb
SITESDIR= mariadb/connector-c-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/mysql
-LIB_DEPENDS= libcurl.so:ftp/curl
-
CMAKE_ARGS+= -DCOMPILATION_COMMENT="FreeBSD Ports" \
-DWITH_EXTERNAL_ZLIB="YES"
diff --git a/devel/dia2code+/Makefile b/devel/dia2code+/Makefile
index b020da756c7e..e603f05b70e9 100644
--- a/devel/dia2code+/Makefile
+++ b/devel/dia2code+/Makefile
@@ -14,8 +14,6 @@ COMMENT= Complete rewrite of dia2code in C++
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to compile: GenerateCodePhp.cpp: 'stoi' is not a member of 'std'
-
USES= autoreconf:build compiler:c++11-lib iconv
USE_GNOME= libxml2
GNU_CONFIGURE= yes
diff --git a/devel/flatbuffers/Makefile b/devel/flatbuffers/Makefile
index 7cbe56df5c72..14563fcd53aa 100644
--- a/devel/flatbuffers/Makefile
+++ b/devel/flatbuffers/Makefile
@@ -13,8 +13,6 @@ COMMENT= Memory efficient serialization library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: base.h:189:32: use of deleted function flatbuffers::EndianSwap(T)
-
USES= cmake:outsource compiler:c++11-lib
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/devel/libgrading/Makefile b/devel/libgrading/Makefile
index c85bf3ccd73c..58053e64cd3d 100644
--- a/devel/libgrading/Makefile
+++ b/devel/libgrading/Makefile
@@ -13,8 +13,6 @@ LICENSE= APACHE20
LIB_DEPENDS= libdistance.so:devel/libdistance
-BROKEN_powerpc64= fails to compile: Arguments.cpp: 'atol' is not a member of 'std'
-
USE_GITHUB= yes
GH_ACCOUNT= trombonehero
diff --git a/devel/liblas/Makefile b/devel/liblas/Makefile
index a2e223912843..77d6ace48657 100644
--- a/devel/liblas/Makefile
+++ b/devel/liblas/Makefile
@@ -11,6 +11,8 @@ COMMENT= Library For Reading And Writing LAS-Format Data
LICENSE= BSD2CLAUSE
+BROKEN_aarch64= fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libgeotiff.so:graphics/libgeotiff
@@ -26,7 +28,4 @@ USE_GITHUB= yes
GH_ACCOUNT= libLAS
GH_PROJECT= ${GH_ACCOUNT}
-BROKEN_aarch64= fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
-BROKEN_powerpc64= fails to compile: undefined reference to boost::program_options::to_internal
-
.include <bsd.port.mk>
diff --git a/devel/py-bullet3/Makefile b/devel/py-bullet3/Makefile
index f008d30c903f..04745b02bede 100644
--- a/devel/py-bullet3/Makefile
+++ b/devel/py-bullet3/Makefile
@@ -12,8 +12,6 @@ COMMENT= Python version of 3D collision detection library Bullet
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: FontData.h:265:1: narrowing conversion of '-96' from 'int' to 'char' inside { }
-
USES= compiler:c++11-lang localbase python
USE_GITHUB= yes
GH_ACCOUNT= bulletphysics
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index dd9cfbce174b..f33e3c1bc758 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/License.txt
BROKEN_aarch64= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
BROKEN_armv6= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
BROKEN_armv7= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
-BROKEN_powerpc64= fails to compile: CartDebug.cxx: 'snprintf' is not a member of 'std'
LIB_DEPENDS= libpng.so:graphics/png
diff --git a/games/emptyepsilon/Makefile b/games/emptyepsilon/Makefile
index 40baba1bd897..f4419e90d3d9 100644
--- a/games/emptyepsilon/Makefile
+++ b/games/emptyepsilon/Makefile
@@ -13,8 +13,6 @@ COMMENT= Spaceship bridge simulator game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: scienceDatabase.cpp: call of overloaded 'abs(float)' is ambiguous
-
LIB_DEPENDS= libsfml-system.so:devel/sfml
USES= cmake:outsource compiler:c++11-lib
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index b4e10a818a74..ec5dde502df2 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -11,7 +11,6 @@ COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../../LICENSE
-BROKEN_powerpc64= fails to compile: tool/tile.h: 'nullptr' was not declared in this scope
NOT_FOR_ARCHS= armv6
NOT_FOR_ARCHS_REASON= missing platform \#define or unsupported compiler
diff --git a/games/traingame/Makefile b/games/traingame/Makefile
index 55d2aa114a2d..f86611005672 100644
--- a/games/traingame/Makefile
+++ b/games/traingame/Makefile
@@ -16,8 +16,6 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libxerces-c.so:textproc/xerces-c3 \
libboost_filesystem.so:devel/boost-libs
-BROKEN_powerpc64= fails to compile: Main.cpp.o: undefined reference to boost::program_options::arg
-
USE_GITHUB= yes
GH_ACCOUNT= nickg
GH_TAGNAME= cb6513e
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index b0b2816bca25..99ab35dafa9f 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -16,8 +16,6 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/GPL2.txt
LICENSE_FILE_GPLv3= ${WRKSRC}/GPL3.txt
LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL2.1.txt
-BROKEN_powerpc64= fails to build: lib/libinkscape_base.so: undefined reference to Magick::Image::read(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
-
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libpopt.so:devel/popt \
libgc.so:devel/boehm-gc \
@@ -32,10 +30,10 @@ LIB_DEPENDS= libpopt.so:devel/popt \
libpng.so:graphics/png \
libMagick++-6.so:graphics/ImageMagick
-USE_GNOME= gtkmm24 libxml2 libxslt
USES= compiler:c++11-lib cmake cpe desktop-file-utils gnome \
iconv:wchar_t jpeg pathfix pkgconfig python:2.7,build \
shebangfix tar:bzip2
+USE_GNOME= gtkmm24 libxml2 libxslt
USE_XORG= x11
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DWITH_GNOME_VFS:BOOL=NO
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index b51e278793f2..a5127d1839c0 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -18,14 +18,13 @@ COMMENT= Free Toolkit For Developing Mapping Applications
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc= fails to install: runs out of virtual memory
+
LIB_DEPENDS= libicuuc.so:devel/icu \
libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz
-BROKEN_powerpc= fails to install: runs out of virtual memory
-BROKEN_powerpc64= fails to link: libmapnik.so: undefined reference to boost::match_results
-
USES= compiler:c++11-lib pkgconfig python scons tar:bzip2
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 03fa5c211bc8..b6ba63a223bf 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -11,11 +11,10 @@ DISTNAME= ${PORTNAME}-plus-${HUGS_DATE}
MAINTAINER= haskell@FreeBSD.org
COMMENT= Interpreter for the functional programming language Haskell 98
-BUILD_DEPENDS= bash:shells/bash
-
BROKEN_armv6= fails to compile: cppinput.c: invalid preprocessing directive \#!
BROKEN_armv7= fails to compile: cppinput.c: invalid preprocessing directive \#!
-BROKEN_powerpc64= fails to compile: cppinput.c: detected recursion whilst expanding macro "vector"
+
+BUILD_DEPENDS= bash:shells/bash
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/math/cryptominisat/Makefile b/math/cryptominisat/Makefile
index cbf02a468fcf..41c34273a576 100644
--- a/math/cryptominisat/Makefile
+++ b/math/cryptominisat/Makefile
@@ -13,8 +13,6 @@ LICENSE_COMB= multi
LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE.txt
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: main.cpp: undefined reference to boost::program_options::abstract_variables_map::operator[]
-
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
USES= cmake:outsource compiler:c++11-lib
diff --git a/math/vowpal_wabbit/Makefile b/math/vowpal_wabbit/Makefile
index 16615f2b752a..502a49ef6968 100644
--- a/math/vowpal_wabbit/Makefile
+++ b/math/vowpal_wabbit/Makefile
@@ -11,8 +11,6 @@ COMMENT= Fast out-of-core learning system
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-BROKEN_powerpc64= fails to compile: network.cc: 'atoi' was not declared in this scope
-
USES= compiler:c++11-lang libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 6bbdc6facf62..2aea84d89a06 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BROKEN_armv6= include/arm_neon.h:28:2: error: "NEON support not enabled"
BROKEN_armv7= fails to package: pkg-static: Unable to access file stage/usr/local/include/botan-2/botan/rdrand_rng.h:No such file or directory
-BROKEN_powerpc64= fails to configure: Unknown compiler "None"; available options: clang ekopath gcc hpcc icc msvc pgi sunstudio xlc
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
diff --git a/www/cppcms/Makefile b/www/cppcms/Makefile
index bab5b7255b0f..ff3b5b6e57b3 100644
--- a/www/cppcms/Makefile
+++ b/www/cppcms/Makefile
@@ -11,8 +11,6 @@ COMMENT= C++ web development framework
LICENSE= MIT
-BROKEN_powerpc64= Does not build: error: 'localeconv_l' was not declared in this scope
-
LIB_DEPENDS= libpcre.so:devel/pcre
USES= cmake python:2.7 shebangfix ssl tar:bzip2