aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-19 14:01:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-19 14:01:43 +0000
commitb9cef10e719d1ff5cd0f15cde9c9027a38e2c38f (patch)
tree31e61eff2dad1f2d7bf146994f39179ed15cca93
parent65a956cdb57f9dad50f10c58a96b0c00d1307907 (diff)
downloadports-b9cef10e719d1ff5cd0f15cde9c9027a38e2c38f.tar.gz
ports-b9cef10e719d1ff5cd0f15cde9c9027a38e2c38f.zip
MFH: r539609
devel/plan9port: fix build on GCC architectures Use newer GCC: cc1: error: unrecognized command line option "-Wno-misleading-indentation" cc1: error: unrecognized command line option "-Wno-stringop-truncation" cc1: error: unrecognized command line option "-Wno-stringop-overflow" cc1: error: unrecognized command line option "-Wno-format-truncation" Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q2/; revision=539610
-rw-r--r--devel/plan9port/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index f5cf6497d87d..84980605e12a 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -22,7 +22,7 @@ BROKEN_armv7= fails to compile: thread.c:130:5: no member named 'arm_r0' in 'mc
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= localbase:ldflags perl5 shebangfix xorg
+USES= compiler:c11 localbase:ldflags perl5 shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= 9fans
GH_TAGNAME= e995a0c101863688d5f14649ae3de45a7c43789c
@@ -61,7 +61,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|ulong|u64int|' ${WRKSRC}/src/libmach/FreeBSD.c
do-configure:
- @${ECHO_CMD} 'CFLAGS="${CFLAGS}"' > ${WRKSRC}/LOCAL.config
+ @${ECHO_CMD} 'CC9="${CC}"' > ${WRKSRC}/LOCAL.config
+ @${ECHO_CMD} 'CFLAGS="${CFLAGS}"' >> ${WRKSRC}/LOCAL.config
@${ECHO_CMD} 'LDFLAGS="${LDFLAGS}"' >> ${WRKSRC}/LOCAL.config
@${ECHO_CMD} 'FONTSRV=fontsrv' >> ${WRKSRC}/LOCAL.config