aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-01 14:38:04 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-01 14:38:04 +0000
commitc4f9abaffb06c1aae4af9c5a7053882cf364066e (patch)
tree7ad24a50ef47a835890cacf7ab3a3bea22cd4f57
parente7b17c2e881c66af0468258215ee976695158201 (diff)
downloadports-c4f9abaffb06c1aae4af9c5a7053882cf364066e.tar.gz
ports-c4f9abaffb06c1aae4af9c5a7053882cf364066e.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/razorback-fsMonitor/Makefile45
-rw-r--r--security/razorback-fsMonitor/distinfo2
-rw-r--r--security/razorback-fsMonitor/pkg-descr8
-rw-r--r--security/razorback-fsMonitor/pkg-plist6
5 files changed, 62 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c8cb89728670..2591ddd58c07 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -786,6 +786,7 @@
SUBDIR += rats
SUBDIR += razorback-api
SUBDIR += razorback-fileInject
+ SUBDIR += razorback-fsMonitor
SUBDIR += razorback-fsWalk
SUBDIR += rdigest
SUBDIR += retranslator
diff --git a/security/razorback-fsMonitor/Makefile b/security/razorback-fsMonitor/Makefile
new file mode 100644
index 000000000000..83011928284a
--- /dev/null
+++ b/security/razorback-fsMonitor/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: razorback-fsMonitor
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fsMonitor
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - File System Monitor
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api \
+ fam.0:${PORTSDIR}/devel/fam
+
+OPTIONS= DEBUG "Enable Debug" off \
+ ASSERT "Enable Asserts" off
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if defined(WITH_ASSERT)
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/fsMonitor.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/fsMonitor.conf.sample ${PREFIX}/etc/razorback/fsMonitor.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-fsMonitor/distinfo b/security/razorback-fsMonitor/distinfo
new file mode 100644
index 000000000000..b17ae2f98244
--- /dev/null
+++ b/security/razorback-fsMonitor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/fsMonitor-0.5.0.tar.gz) = c339b66e73b2d48bb5ff1b581d2de07d8bd1e2da44cdf3a4e28cfeab66981f79
+SIZE (razorback/fsMonitor-0.5.0.tar.gz) = 318887
diff --git a/security/razorback-fsMonitor/pkg-descr b/security/razorback-fsMonitor/pkg-descr
new file mode 100644
index 000000000000..3742c9ac8e1a
--- /dev/null
+++ b/security/razorback-fsMonitor/pkg-descr
@@ -0,0 +1,8 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+This nugget uses inotify to monitor any number of file system paths
+and send any changed or created files to the dispatcher for collection.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-fsMonitor/pkg-plist b/security/razorback-fsMonitor/pkg-plist
new file mode 100644
index 000000000000..99d3e32a6117
--- /dev/null
+++ b/security/razorback-fsMonitor/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/fsMonitor
+@unexec if cmp -s %D/etc/razorback/fsMonitor.conf %D/etc/razorback/fsMonitor.conf.sample; then rm -f %D/etc/razorback/fsMonitor.conf; fi
+etc/razorback/fsMonitor.conf.sample
+@exec if [ ! -f %D/etc/razorback/fsMonitor.conf ]; then cp -p %D/%F %B/fsMonitor.conf; fi
+@dirrmtry etc/razorback