aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-14 08:12:40 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-14 08:12:40 +0000
commitd0a3ace740979a8891d60af375f705dd34b03ac7 (patch)
treefaa9fe29861b67b60cfafa8d89a13ae759d3160c
parentd468b28ca80a0e412b5d8d66a5615afdf50a1178 (diff)
downloadports-d0a3ace740979a8891d60af375f705dd34b03ac7.tar.gz
ports-d0a3ace740979a8891d60af375f705dd34b03ac7.zip
Notes
-rw-r--r--net/p5-Crypt-DH-GMP/Makefile9
-rw-r--r--net/p5-Crypt-DH-GMP/distinfo6
-rw-r--r--net/p5-Crypt-DH-GMP/files/patch-Makefile.PL19
3 files changed, 29 insertions, 5 deletions
diff --git a/net/p5-Crypt-DH-GMP/Makefile b/net/p5-Crypt-DH-GMP/Makefile
index 01bb6b0521e5..6258ad85a13f 100644
--- a/net/p5-Crypt-DH-GMP/Makefile
+++ b/net/p5-Crypt-DH-GMP/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= Crypt-DH-GMP
-PORTVERSION= 0.00006
-PORTREVISION= 1
+PORTVERSION= 0.00009
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +13,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Crypt::DH Using GMP Directly
+BUILD_DEPENDS= p5-Devel-CheckLib>=0:${PORTSDIR}/devel/p5-Devel-CheckLib \
+ p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort \
+ p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+post-patch:
+ ${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' ${WRKSRC}/Makefile.PL
+
PERL_CONFIGURE= YES
MAN3= Crypt::DH::GMP.3 \
Crypt::DH::GMP::Compat.3
diff --git a/net/p5-Crypt-DH-GMP/distinfo b/net/p5-Crypt-DH-GMP/distinfo
index 59424fac928e..d3afb25cd533 100644
--- a/net/p5-Crypt-DH-GMP/distinfo
+++ b/net/p5-Crypt-DH-GMP/distinfo
@@ -1,3 +1,3 @@
-MD5 (Crypt-DH-GMP-0.00006.tar.gz) = 515d10da337a72f3fb27a800f035986c
-SHA256 (Crypt-DH-GMP-0.00006.tar.gz) = bd7c6ed1d1d76e058650b1eb134007ed4df26a173b7a40502eb047bcc03a6583
-SIZE (Crypt-DH-GMP-0.00006.tar.gz) = 14987
+MD5 (Crypt-DH-GMP-0.00009.tar.gz) = 6c3271908c554fdf60782921dad7f0a5
+SHA256 (Crypt-DH-GMP-0.00009.tar.gz) = ebfbcf2630f6a85b63cd87585d301442f43c91df71d214f7ec325d41a7617ab9
+SIZE (Crypt-DH-GMP-0.00009.tar.gz) = 73737
diff --git a/net/p5-Crypt-DH-GMP/files/patch-Makefile.PL b/net/p5-Crypt-DH-GMP/files/patch-Makefile.PL
new file mode 100644
index 000000000000..5eabda246c24
--- /dev/null
+++ b/net/p5-Crypt-DH-GMP/files/patch-Makefile.PL
@@ -0,0 +1,19 @@
+--- Makefile.PL.orig 2010-10-13 16:31:29.000000000 +0800
++++ Makefile.PL 2010-10-13 16:33:05.000000000 +0800
+@@ -10,6 +10,9 @@
+ my @INCLUDES;
+ my @LIBPATHS;
+
++push @INCLUDES , '%%LOCALBASE%%/include';
++push @LIBPATHS, '%%LOCALBASE%%/lib';
++
+ if ($^O eq 'darwin') {
+ if (! exists $ENV{USE_MACPORTS}) {
+ print
+@@ -60,4 +63,4 @@
+
+ test_requires 'Test::More';
+ test_requires 'Test::Requires';
+-WriteAll;
+\ No newline at end of file
++WriteAll;