aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-01-06 10:22:07 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-01-06 10:22:07 +0000
commitd275f59502e96499bd4ae93a04fbc6cb1b1d2471 (patch)
treeabe58b3503ae4561dad1c26e197448973116d317
parent50687327e1a71b6578e717b9115a39d11d65728d (diff)
Notes
-rw-r--r--www/openvrml/Makefile77
-rw-r--r--www/openvrml/distinfo6
-rw-r--r--www/openvrml/files/lookat.sh.in4
-rw-r--r--www/openvrml/files/patch-030_freetype_prototypes50
-rw-r--r--www/openvrml/files/patch-Makefile.in14
-rw-r--r--www/openvrml/files/patch-configure11
-rw-r--r--www/openvrml/files/patch-mozilla-plugin_src_openvrml-player_player.cpp19
-rw-r--r--www/openvrml/files/patch-src_libopenvrml-gl_openvrml_gl_viewer.cpp11
-rw-r--r--www/openvrml/files/patch-test_node_interface_set.cpp8
-rw-r--r--www/openvrml/files/patch-tests_Makefile.in11
-rw-r--r--www/openvrml/pkg-descr10
-rw-r--r--www/openvrml/pkg-message5
-rw-r--r--www/openvrml/pkg-plist49
13 files changed, 126 insertions, 149 deletions
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 475820ba8956..db80eb6b9758 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openvrml
-PORTVERSION= 0.15.10
-PORTREVISION= 7
+PORTVERSION= 0.17.0
CATEGORIES= www graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,38 +14,37 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= VRML97 runtime and browser ("lookat")
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mozilla-js.pc:${PORTSDIR}/www/mozilla \
- ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mozilla-js.pc:${PORTSDIR}/www/mozilla
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ js.1:${PORTSDIR}/lang/spidermonkey \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ curl.4:${PORTSDIR}/ftp/curl
USE_GL= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack libglade2 libgnomeui
USE_SDL= sdl
-USE_GCC= 3.4
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -largp -Wl,--rpath -Wl,${LOCALBASE}/lib/mozilla -L${X11BASE}/lib -lXext" \
- XPIDLFLAGS="-I${LOCALBASE}/share/idl/mozilla"
+USE_JAVA= yes
+GNU_CONFIGURE= yes
+LIBTOOLFILES= configure mozilla-plugin/configure lib/gtkglext/configure
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${JAVA_HOME}/include -I${JAVA_HOME}/include/${OPSYS:L}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${JAVA_HOME}/jre/lib/${ARCH}/client ${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ LIBS="-lm"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_GECKO= firefox seamonkey
-PLIST_SUB= VER=${PORTVERSION}
-SUB_FILES= lookat.sh
+PLIST_SUB= PLUGINS_DIR=${BROWSER_PLUGINS_DIR:S|^${LOCALBASE}/||}
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700029
-BROKEN= Incorrect objformat handling
-.endif
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if ${ARCH} == "sparc64"
BROKEN= Gets internal gcc error on ${ARCH}
@@ -58,26 +56,43 @@ LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python
LIB_DEPENDS+= boost_regex.4:${PORTSDIR}/devel/boost
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" \
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Warning: building this port eats up to 1.5 GB of RAM (32 bits) or 3 GB (64 bits)"
+ @${ECHO_MSG} "of RAM; do not try to build it on a small configuration!"
+ @${ECHO_MSG}
+
+pre-configure:
+ ${REINPLACE_CMD} -e \
+ 's|JNI_LIBS="|JNI_LIBS="-L${JAVA_HOME}/jre/lib/${ARCH}/client -Wl,-rpath,${JAVA_HOME}/jre/lib/${ARCH}/client |' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e \
+ 's|-rpath $$(libdir)|-rpath $$(libdir) -rpath ${JAVA_HOME}/jre/lib/${ARCH}/client|' \
+ ${WRKSRC}/src/Makefile.in
+.for cfg in ${LIBTOOLFILES}
+ ${REINPLACE_CMD} -e \
+ "/hardcode_libdir_flag_spec/s|\(=.\)\(.*\)\(\$$libdir\)|& \2${JAVA_HOME}/jre/lib/${ARCH}/client|" \
+ ${WRKSRC}/${cfg}
+.endfor
+ ${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${BROWSER_PLUGINS_DIR}|' \
+ ${WRKSRC}/mozilla-plugin/src/Makefile.in
+.if ${GECKO} != "firefox"
+ ${REINPLACE_CMD} -e "s|FIREFOX_JS|${GECKO:U}_JS|g;s|firefox-js|${GECKO}-js|" \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s|firefox-plugin|${GECKO}-plugin|g" \
+ ${WRKSRC}/mozilla-plugin/configure
+.endif
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/doc/manual/ ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/models/*.wrl ${EXAMPLESDIR}
.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.if defined(MAINTAINER_MODE)
-test: build
- (cd ${WRKSRC}/tests ; \
- ./testsuite )
-.endif
+regression-test:
+ (cd ${BUILD_WRKSRC}/tests ; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check-TESTS)
.include <bsd.port.post.mk>
diff --git a/www/openvrml/distinfo b/www/openvrml/distinfo
index 113339544b0e..3218fb09e403 100644
--- a/www/openvrml/distinfo
+++ b/www/openvrml/distinfo
@@ -1,3 +1,3 @@
-MD5 (openvrml-0.15.10.tar.gz) = 9ed3fa9da6f74e2a0bf45cdab655db30
-SHA256 (openvrml-0.15.10.tar.gz) = a91dca66e83b921c7a06ad7986d6f58a3d27db30250081aff745e84db9f5960f
-SIZE (openvrml-0.15.10.tar.gz) = 5334341
+MD5 (openvrml-0.17.0.tar.gz) = 4621541309428e3df3d2f9b32a180881
+SHA256 (openvrml-0.17.0.tar.gz) = fd9ec5b2aa04af7c703639dd3f0d284ffc62a70c2acd33a04ed12d4bb9fac8e3
+SIZE (openvrml-0.17.0.tar.gz) = 5592292
diff --git a/www/openvrml/files/lookat.sh.in b/www/openvrml/files/lookat.sh.in
deleted file mode 100644
index 0f3d2f823315..000000000000
--- a/www/openvrml/files/lookat.sh.in
+++ /dev/null
@@ -1,4 +0,0 @@
-#! /bin/sh
-# $FreeBSD$
-
-LD_LIBRARY_PATH=%%LOCALBASE%%/lib/mozilla %%PREFIX%%/bin/lookat $1
diff --git a/www/openvrml/files/patch-030_freetype_prototypes b/www/openvrml/files/patch-030_freetype_prototypes
deleted file mode 100644
index 5f6dc6700380..000000000000
--- a/www/openvrml/files/patch-030_freetype_prototypes
+++ /dev/null
@@ -1,50 +0,0 @@
-Index: openvrml-0.15.10/src/libopenvrml/openvrml/vrml97node.cpp
-===================================================================
---- src/libopenvrml/openvrml/vrml97node.cpp.orig 2006-06-11 14:23:00.000000000 +0200
-+++ src/libopenvrml/openvrml/vrml97node.cpp 2006-06-11 15:12:02.000000000 +0200
-@@ -16604,7 +16604,7 @@
-
- const float stepSize_ = 0.2;
-
-- int moveTo_(FT_Vector * const to, void * const user) throw ()
-+ int moveTo_(const FT_Vector * to, void * user)
- {
- using std::vector;
- assert(user);
-@@ -16620,7 +16620,7 @@
- return 0;
- }
-
-- int lineTo_(FT_Vector * const to, void * const user) throw ()
-+ int lineTo_(const FT_Vector * to, void * user)
- {
- assert(user);
- GlyphContours_ & c = *static_cast<GlyphContours_ *>(user);
-@@ -16682,10 +16682,9 @@
- }
- }
-
-- int conicTo_(FT_Vector * const control,
-- FT_Vector * const to,
-+ int conicTo_(const FT_Vector * control,
-+ const FT_Vector * to,
- void * const user)
-- throw ()
- {
- using std::vector;
-
-@@ -16716,11 +16715,10 @@
- return 0;
- }
-
-- int cubicTo_(FT_Vector * const control1,
-- FT_Vector * const control2,
-- FT_Vector * const to,
-+ int cubicTo_(const FT_Vector * control1,
-+ const FT_Vector * control2,
-+ const FT_Vector * to,
- void * const user)
-- throw ()
- {
- using std::vector;
-
diff --git a/www/openvrml/files/patch-Makefile.in b/www/openvrml/files/patch-Makefile.in
index 8386629f5a47..1c1b92c58c28 100644
--- a/www/openvrml/files/patch-Makefile.in
+++ b/www/openvrml/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Mon Jul 4 01:29:49 2005
-+++ Makefile.in Fri Jul 22 16:32:32 2005
-@@ -236,7 +236,7 @@
- target_cpu = @target_cpu@
- target_os = @target_os@
+--- Makefile.in.orig Sat Jul 21 14:49:12 2007
++++ Makefile.in Sat Jul 21 14:52:07 2007
+@@ -252,7 +252,7 @@
target_vendor = @target_vendor@
--SUBDIRS = doc ide-projects m4 models lib java src mozilla-plugin tests
-+SUBDIRS = ide-projects m4 models lib java src mozilla-plugin tests
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = doc ide-projects models lib java src mozilla-plugin examples tests
++SUBDIRS = ide-projects models lib java src mozilla-plugin examples tests
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
openvrml.pc.in \
diff --git a/www/openvrml/files/patch-configure b/www/openvrml/files/patch-configure
new file mode 100644
index 000000000000..e07c2093d224
--- /dev/null
+++ b/www/openvrml/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2007-12-15 03:20:29.000000000 +0100
++++ configure 2008-01-02 19:25:59.000000000 +0100
+@@ -25326,7 +25326,7 @@
+ #
+
+ if test -n "${openvrml_run_path}"; then
+- OPENVRML_RPATH="-rpath ${openvrml_run_path}"
++ OPENVRML_RPATH="${openvrml_run_path}"
+ fi
+
+
diff --git a/www/openvrml/files/patch-mozilla-plugin_src_openvrml-player_player.cpp b/www/openvrml/files/patch-mozilla-plugin_src_openvrml-player_player.cpp
deleted file mode 100644
index 6bc8559c91f4..000000000000
--- a/www/openvrml/files/patch-mozilla-plugin_src_openvrml-player_player.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- mozilla-plugin/src/openvrml-player/player.cpp.orig Tue Nov 15 00:16:02 2005
-+++ mozilla-plugin/src/openvrml-player/player.cpp Tue Nov 15 00:21:07 2005
-@@ -22,14 +22,14 @@
- # include <boost/lexical_cast.hpp>
- # include <boost/spirit.hpp>
- # include <boost/spirit/phoenix.hpp>
-+# include <openvrml/browser.h>
-+# include <openvrml/gl/viewer.h>
- # include <unistd.h>
- # include <argp.h>
- # include <X11/keysym.h>
- # include <gdk/gdkx.h>
- # include <gtk/gtk.h>
- # include <gtk/gtkgl.h>
--# include <openvrml/browser.h>
--# include <openvrml/gl/viewer.h>
-
- namespace {
-
diff --git a/www/openvrml/files/patch-src_libopenvrml-gl_openvrml_gl_viewer.cpp b/www/openvrml/files/patch-src_libopenvrml-gl_openvrml_gl_viewer.cpp
new file mode 100644
index 000000000000..ec5727d99954
--- /dev/null
+++ b/www/openvrml/files/patch-src_libopenvrml-gl_openvrml_gl_viewer.cpp
@@ -0,0 +1,11 @@
+--- ./src/libopenvrml-gl/openvrml/gl/viewer.cpp.orig 2007-11-11 09:51:10.000000000 +0100
++++ ./src/libopenvrml-gl/openvrml/gl/viewer.cpp 2007-11-19 22:12:07.000000000 +0100
+@@ -1969,7 +1969,7 @@
+ # ifdef HAVE_APPLE_OPENGL_FRAMEWORK
+ typedef GLvoid (OPENVRML_GL_CALLBACK_* TessCB)(...);
+ # else
+- typedef GLvoid (OPENVRML_GL_CALLBACK_* TessCB)(GLvoid);
++ typedef GLvoid (OPENVRML_GL_CALLBACK_* TessCB)();
+ # endif
+
+ /**
diff --git a/www/openvrml/files/patch-test_node_interface_set.cpp b/www/openvrml/files/patch-test_node_interface_set.cpp
deleted file mode 100644
index 4ccbadb92f79..000000000000
--- a/www/openvrml/files/patch-test_node_interface_set.cpp
+++ /dev/null
@@ -1,8 +0,0 @@
---- tests/node_interface_set.cpp.orig Sun Jul 8 23:24:35 2007
-+++ tests/node_interface_set.cpp Sun Jul 8 23:23:24 2007
-@@ -1,3 +1,5 @@
-+# define BOOST_TEST_DYN_LINK
-+# define BOOST_TEST_MAIN
- # include <boost/test/unit_test.hpp>
- # include <openvrml/node.h>
-
diff --git a/www/openvrml/files/patch-tests_Makefile.in b/www/openvrml/files/patch-tests_Makefile.in
new file mode 100644
index 000000000000..8f532f77f760
--- /dev/null
+++ b/www/openvrml/files/patch-tests_Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig Fri Jun 1 08:56:46 2007
++++ tests/Makefile.in Sun Jun 3 09:34:02 2007
+@@ -184,7 +184,7 @@
+ JS_LIBS = @JS_LIBS@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ @JNI_LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
diff --git a/www/openvrml/pkg-descr b/www/openvrml/pkg-descr
index 4c4f1c135cf4..58762cda40ec 100644
--- a/www/openvrml/pkg-descr
+++ b/www/openvrml/pkg-descr
@@ -1,8 +1,6 @@
-OpenVRML is a free cross-platform runtime for VRML97 available under
-the GNU Lesser General Public License.
-
-The basic OpenVRML distribution includes libraries you can use to
-add VRML support to an application, and "Lookat", a simple
-stand-alone VRML browser. A plug-in for mozilla is included.
+OpenVRML is a free cross-platform runtime for VRML and X3D available under the
+GNU Lesser General Public License. The OpenVRML distribution includes libraries
+you can use to add VRML/X3D support to an application. OpenVRML also provides a
+plug-in to render VRML/X3D worlds in Web browsers.
WWW: http://openvrml.sourceforge.net/
diff --git a/www/openvrml/pkg-message b/www/openvrml/pkg-message
deleted file mode 100644
index 6cdf9f2d0b0c..000000000000
--- a/www/openvrml/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-===========================================
-Please run lookat via the script lookat.sh:
-
-lookat.sh sample.wrl
-===========================================
diff --git a/www/openvrml/pkg-plist b/www/openvrml/pkg-plist
index ca4e10060b88..5c6e7f8a7b21 100644
--- a/www/openvrml/pkg-plist
+++ b/www/openvrml/pkg-plist
@@ -1,38 +1,53 @@
-bin/lookat
-bin/lookat.sh
+bin/openvrml-player
+include/openvrml/openvrml-common.h
+include/openvrml/openvrml-config.h
+include/openvrml/openvrml-gl-common.h
+include/openvrml/openvrml-gl-config.h
include/openvrml/openvrml/basetypes.h
include/openvrml/openvrml/bounding_volume.h
include/openvrml/openvrml/browser.h
-include/openvrml/openvrml/common.h
include/openvrml/openvrml/event.h
include/openvrml/openvrml/exposedfield.h
include/openvrml/openvrml/field_value.h
include/openvrml/openvrml/frustum.h
include/openvrml/openvrml/gl/viewer.h
-include/openvrml/openvrml/img.h
include/openvrml/openvrml/node.h
-include/openvrml/openvrml/node_ptr.h
+include/openvrml/openvrml/node_impl_util.h
+include/openvrml/openvrml/read_write_mutex.h
include/openvrml/openvrml/rendering_context.h
include/openvrml/openvrml/scope.h
include/openvrml/openvrml/script.h
-include/openvrml/openvrml/system.h
include/openvrml/openvrml/viewer.h
+include/openvrml/openvrml/vrml97_grammar.h
include/openvrml/openvrml/vrml97node.h
+include/openvrml/openvrml/x3d_cad_geometry.h
+include/openvrml/openvrml/x3d_core.h
+include/openvrml/openvrml/x3d_dis.h
+include/openvrml/openvrml/x3d_environmental_effects.h
+include/openvrml/openvrml/x3d_event_utilities.h
+include/openvrml/openvrml/x3d_geometry2d.h
+include/openvrml/openvrml/x3d_geospatial.h
+include/openvrml/openvrml/x3d_grouping.h
+include/openvrml/openvrml/x3d_hanim.h
+include/openvrml/openvrml/x3d_interpolation.h
+include/openvrml/openvrml/x3d_key_device_sensor.h
+include/openvrml/openvrml/x3d_networking.h
+include/openvrml/openvrml/x3d_nurbs.h
+include/openvrml/openvrml/x3d_rendering.h
+include/openvrml/openvrml/x3d_shape.h
+include/openvrml/openvrml/x3d_texturing.h
+include/openvrml/openvrml/x3d_vrml_grammar.h
lib/libopenvrml-gl.a
-lib/libopenvrml-gl.la
lib/libopenvrml-gl.so
-lib/libopenvrml-gl.so.6
+lib/libopenvrml-gl.so.7
lib/libopenvrml.a
-lib/libopenvrml.la
lib/libopenvrml.so
-lib/libopenvrml.so.5
+lib/libopenvrml.so.8
+%%PLUGINS_DIR%%/openvrml.la
+%%PLUGINS_DIR%%/openvrml.so
libdata/pkgconfig/openvrml-gl.pc
libdata/pkgconfig/openvrml.pc
-libexec/openvrml-player
-share/idl/openvrml-%%VER%%/openvrml.idl
-share/pixmaps/lookat.xpm
-lib/mozilla/plugins/openvrml.so
-lib/mozilla/plugins/openvrml.xpt
+libexec/openvrml-xembed
%%PORTDOCS%%%%EXAMPLESDIR%%/Anchor.wrl
%%PORTDOCS%%%%EXAMPLESDIR%%/Click.wrl
%%PORTDOCS%%%%EXAMPLESDIR%%/EventPROTO.wrl
@@ -51,10 +66,12 @@ lib/mozilla/plugins/openvrml.xpt
%%PORTDOCS%%%%EXAMPLESDIR%%/scale.wrl
%%PORTDOCS%%%%EXAMPLESDIR%%/snoman.wrl
%%PORTDOCS%%%%EXAMPLESDIR%%/warbird.wrl
+share/openvrml-player/glade/openvrml-player.glade
+@dirrm share/openvrml-player/glade
+@dirrm share/openvrml-player
@dirrm include/openvrml/openvrml/gl
@dirrm include/openvrml/openvrml
@dirrm include/openvrml
-@dirrm share/idl/openvrml-%%VER%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrmtry share/gtk-doc/html/gtkglext
@dirrmtry share/gtk-doc/html