aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-11-23 10:20:30 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-11-23 10:20:30 +0000
commitdcc5b27c9d78bac695e7e6009b32b7815770e44d (patch)
tree9a83b6ecf745cf6017b61717213f79680d29908d
parent0de3152ad63cda4daff816770eaa75e4d5962d33 (diff)
Notes
-rw-r--r--databases/timescaledb/Makefile14
-rw-r--r--databases/timescaledb/distinfo6
-rw-r--r--databases/timescaledb/files/patch-src_CMakeLists.txt15
-rw-r--r--databases/timescaledb/files/pkg-message.in (renamed from databases/timescaledb/pkg-message)0
4 files changed, 26 insertions, 9 deletions
diff --git a/databases/timescaledb/Makefile b/databases/timescaledb/Makefile
index 8ff95ccf99ca..18a3c1149754 100644
--- a/databases/timescaledb/Makefile
+++ b/databases/timescaledb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= timescaledb
-PORTVERSION= 0.6.0
+PORTVERSION= 0.7.0
CATEGORIES= databases
MAINTAINER= kbowling@FreeBSD.org
@@ -11,17 +11,17 @@ COMMENT= Time-series database built on PostgreSQL
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c11 gmake pgsql:9.6
+USES= compiler:c11 cmake:outsource pgsql:9.6,10
USE_LDCONFIG= yes
USE_GITHUB= YES
GH_ACCOUNT= timescale
-MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
- install_bin=/usr/bin/install
-
WANT_PGSQL= server
+SUB_LIST+= PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-message
+
PLIST_FILES= lib/postgresql/timescaledb.so \
share/postgresql/extension/timescaledb--0.1.0--0.2.0.sql \
share/postgresql/extension/timescaledb--0.2.0--0.3.0.sql \
@@ -30,7 +30,9 @@ PLIST_FILES= lib/postgresql/timescaledb.so \
share/postgresql/extension/timescaledb--0.4.1--0.4.2.sql \
share/postgresql/extension/timescaledb--0.4.2--0.5.0.sql \
share/postgresql/extension/timescaledb--0.5.0--0.6.0.sql \
- share/postgresql/extension/timescaledb--0.6.0.sql \
+ share/postgresql/extension/timescaledb--0.6.0--0.6.1.sql \
+ share/postgresql/extension/timescaledb--0.6.1--0.7.0.sql \
+ share/postgresql/extension/timescaledb--0.7.0.sql \
share/postgresql/extension/timescaledb.control
post-install:
diff --git a/databases/timescaledb/distinfo b/databases/timescaledb/distinfo
index dfe4bb1bcadc..e5d90c8d0b47 100644
--- a/databases/timescaledb/distinfo
+++ b/databases/timescaledb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508301885
-SHA256 (timescale-timescaledb-0.6.0_GH0.tar.gz) = d8447eab8504cf4eb22567a844c86358d9cb46a2b1d65c7a021072079d90effb
-SIZE (timescale-timescaledb-0.6.0_GH0.tar.gz) = 317259
+TIMESTAMP = 1511336203
+SHA256 (timescale-timescaledb-0.7.0_GH0.tar.gz) = 11087c59f2b91c035376ffdf64161be45789244c377260c1bef2f8fceebfd9d7
+SIZE (timescale-timescaledb-0.7.0_GH0.tar.gz) = 374746
diff --git a/databases/timescaledb/files/patch-src_CMakeLists.txt b/databases/timescaledb/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..59734f6b94ca
--- /dev/null
+++ b/databases/timescaledb/files/patch-src_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- src/CMakeLists.txt.orig 2017-11-22 08:00:04 UTC
++++ src/CMakeLists.txt
+@@ -13,11 +13,10 @@ if (APPLE)
+ set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -multiply_defined suppress -Wl,-undefined,dynamic_lookup -Wl,-dead_strip_dylibs -bundle_loader ${PG_BINDIR}/postgres")
+ endif (APPLE)
+
+-include_directories (${CMAKE_CURRENT_BINARY_DIR} ${PG_INCLUDEDIR_SERVER})
++include_directories (${CMAKE_CURRENT_BINARY_DIR} ${PG_INCLUDEDIR} ${PG_INCLUDEDIR_SERVER})
+
+ if (WIN32)
+ set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${PG_LIBDIR}/postgres.lib ws2_32.lib")
+- include_directories(${CMAKE_CURRENT_BINARY_DIR} ${PG_INCLUDEDIR})
+ include_directories(${PG_INCLUDEDIR_SERVER}/port/win32)
+
+ if (MSVC)
diff --git a/databases/timescaledb/pkg-message b/databases/timescaledb/files/pkg-message.in
index 76d7f4149ab5..76d7f4149ab5 100644
--- a/databases/timescaledb/pkg-message
+++ b/databases/timescaledb/files/pkg-message.in