aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-10-10 16:01:23 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-10-10 16:01:23 +0000
commitde6a557d94e90528d18ac521758638b007407994 (patch)
treec6e104d9e09f7b915d99b35bac3c1a44ccaccc17
parenta6bfded62587c4cd54d012f85f6b71d9bc678cbb (diff)
Notes
-rw-r--r--www/drush/Makefile19
-rw-r--r--www/drush/distinfo4
-rw-r--r--www/drush/pkg-plist1
3 files changed, 9 insertions, 15 deletions
diff --git a/www/drush/Makefile b/www/drush/Makefile
index a1e2c92764c6..78c474626c82 100644
--- a/www/drush/Makefile
+++ b/www/drush/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= drush
-PORTVERSION= 6.2.0
+PORTVERSION= 6.4.0
CATEGORIES= www
MAINTAINER= dgeo@centrale-marseille.fr
@@ -17,7 +17,7 @@ NO_BUILD= yes
GH_ACCOUNT= ${PORTNAME}-ops
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${PORTVERSION}
-GH_COMMIT= b1a8edb
+GH_COMMIT= fd4baef
USE_GITHUB= yes
# set php requirements same as drupal itself
@@ -25,13 +25,10 @@ USE_PHP= gd pcre session mbstring ctype json hash simplexml dom pdo filter
WANT_PHP_CLI= yes
PORTDOCS= *
-
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
do-configure:
@${REINPLACE_CMD} -e 's|XXXDATADIRXXX|${STAGEDIR}${DATADIR}|g' ${WRKSRC}/drush
@@ -44,13 +41,9 @@ do-install:
${LN} -s ${DATADIR}/drush ${STAGEDIR}${PREFIX}/bin/drush
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ( cd ${WRKSRC} && ${INSTALL_MAN} *.md docs/* ${STAGEDIR}${DOCSDIR} )
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ( cd ${WRKSRC} && ${INSTALL_MAN} examples/* ${STAGEDIR}${EXAMPLESDIR} )
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ( cd ${WRKSRC} && ${INSTALL_MAN} *.md docs/* ${STAGEDIR}${DOCSDIR} )
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ( cd ${WRKSRC} && ${INSTALL_MAN} examples/* ${STAGEDIR}${EXAMPLESDIR} )
.include <bsd.port.mk>
diff --git a/www/drush/distinfo b/www/drush/distinfo
index b27cc968a60c..4861cab753e5 100644
--- a/www/drush/distinfo
+++ b/www/drush/distinfo
@@ -1,2 +1,2 @@
-SHA256 (drush-6.2.0.tar.gz) = 236b2365dce7490e4ee87f6d3ce82da01d0d2ad25c0e936a960a22cd2b72616b
-SIZE (drush-6.2.0.tar.gz) = 504555
+SHA256 (drush-6.4.0.tar.gz) = ee48d3c6d17db9bf09b0d475213b89826f6daaa9ba7781fca510238b99089026
+SIZE (drush-6.4.0.tar.gz) = 508662
diff --git a/www/drush/pkg-plist b/www/drush/pkg-plist
index 5ce474f6e089..ea6484af12f5 100644
--- a/www/drush/pkg-plist
+++ b/www/drush/pkg-plist
@@ -215,6 +215,7 @@ bin/drush
%%DATADIR%%/commands/core/docs.drush.inc
%%DATADIR%%/commands/core/core.drush.inc
%%DATADIR%%/commands/core/cache.drush.inc
+%%DATADIR%%/commands/core/browse.drush.inc
%%DATADIR%%/commands/core/archive.drush.inc
%%DATADIR%%/classes/DrushRole.php
@dirrmtry %%DATADIR%%/tests/resources