aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-09 16:15:39 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-09 16:15:39 +0000
commite387fda4873e79f584422dfead5aca6bae6e80d4 (patch)
treef336e2423479cd41b5cbd7db0f1aa63153e738d9
parentec8153cdbeecfe749ab28eb568743775474f9221 (diff)
Pyggel (Python Graphical Game Engine + Libraries) will ease the learning curve
of getting into 3d programming, while also having a strong enough framework for full-sized applications. PYGGEL demo game WWW: https://code.google.com/p/pyggel/
Notes
Notes: svn path=/head/; revision=350724
-rw-r--r--games/Makefile1
-rw-r--r--games/robocalypto/Makefile54
-rw-r--r--games/robocalypto/distinfo4
-rw-r--r--games/robocalypto/files/robocalypto.in7
-rw-r--r--games/robocalypto/pkg-descr7
-rw-r--r--games/robocalypto/pkg-plist29
6 files changed, 102 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c7694933ec49..b585c559841b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -830,6 +830,7 @@
SUBDIR += rftg
SUBDIR += ri-li
SUBDIR += rnd_jue
+ SUBDIR += robocalypto
SUBDIR += robocode
SUBDIR += robotfindskitten
SUBDIR += rockdodger
diff --git a/games/robocalypto/Makefile b/games/robocalypto/Makefile
new file mode 100644
index 000000000000..929299cc068b
--- /dev/null
+++ b/games/robocalypto/Makefile
@@ -0,0 +1,54 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= robocalypto
+PORTVERSION= 0.08
+DISTVERSIONSUFFIX= -alpha4c
+CATEGORIES= games python
+MASTER_SITES= GOOGLE_CODE \
+ SF/nemysisfreebsdp/games/:icons
+PROJECTHOST= pyggel
+DISTFILES= PYGGEL-V${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= python
+EXTRACT_ONLY= PYGGEL-V${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= PYGGEL demo game
+
+LICENSE= Public_Domain_LICENSE
+LICENSE_NAME= Public Domain License
+LICENSE_TEXT= Public Domain
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyggel>=0:${PORTSDIR}/graphics/py-pyggel
+
+WRKSRC= ${WRKDIR}/PYGGEL-V${DISTVERSION}${DISTVERSIONSUFFIX}/Robocalypto
+
+USES= zip
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Robocalypto" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;StrategyGame;" ""
+
+post-patch:
+.for f in run_game.py gamelib/main.py gamelib/game.py
+ @${REINPLACE_CMD} -e 's|^.*#!.*python.*$$|#!${PYTHON_CMD}|' \
+ ${WRKSRC}/${f}
+.endfor
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+
+do-install:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "data gamelib" ${STAGEDIR}${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/games/robocalypto/distinfo b/games/robocalypto/distinfo
new file mode 100644
index 000000000000..a79e326a3b61
--- /dev/null
+++ b/games/robocalypto/distinfo
@@ -0,0 +1,4 @@
+SHA256 (python/PYGGEL-V0.08-alpha4c.zip) = 492bafd20a8cb1af2de4c5142875371a5d6dd3f1223959b169c15b6196bbca92
+SIZE (python/PYGGEL-V0.08-alpha4c.zip) = 438750
+SHA256 (python/robocalypto.png) = fadd40ed071b46267d84c969ef0748cb282bc5dece5ba0d7e8bebd78a4c3a602
+SIZE (python/robocalypto.png) = 4520
diff --git a/games/robocalypto/files/robocalypto.in b/games/robocalypto/files/robocalypto.in
new file mode 100644
index 000000000000..8736ed7fdef4
--- /dev/null
+++ b/games/robocalypto/files/robocalypto.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec %%PYTHON_CMD%% ./run_game.py "${@}"
diff --git a/games/robocalypto/pkg-descr b/games/robocalypto/pkg-descr
new file mode 100644
index 000000000000..b75d41a6062f
--- /dev/null
+++ b/games/robocalypto/pkg-descr
@@ -0,0 +1,7 @@
+Pyggel (Python Graphical Game Engine + Libraries) will ease the learning curve
+of getting into 3d programming, while also having a strong enough framework
+for full-sized applications.
+
+PYGGEL demo game
+
+WWW: https://code.google.com/p/pyggel/
diff --git a/games/robocalypto/pkg-plist b/games/robocalypto/pkg-plist
new file mode 100644
index 000000000000..dc122de7cbf6
--- /dev/null
+++ b/games/robocalypto/pkg-plist
@@ -0,0 +1,29 @@
+bin/robocalypto
+share/pixmaps/robocalypto.png
+%%DATADIR%%/data/DS-DIGI.ttf
+%%DATADIR%%/data/bullet.mtl
+%%DATADIR%%/data/bullet.obj
+%%DATADIR%%/data/ceiling.png
+%%DATADIR%%/data/digital-7.ttf
+%%DATADIR%%/data/door.png
+%%DATADIR%%/data/explosion.png
+%%DATADIR%%/data/flash.png
+%%DATADIR%%/data/floor.png
+%%DATADIR%%/data/gun.mtl
+%%DATADIR%%/data/gun.obj
+%%DATADIR%%/data/gun4.mtl
+%%DATADIR%%/data/gun4.obj
+%%DATADIR%%/data/hud.png
+%%DATADIR%%/data/robo.mtl
+%%DATADIR%%/data/robo.obj
+%%DATADIR%%/data/screen.png
+%%DATADIR%%/data/target.png
+%%DATADIR%%/data/wall.png
+%%DATADIR%%/gamelib/__init__.py
+%%DATADIR%%/gamelib/game.py
+%%DATADIR%%/gamelib/main.py
+%%DATADIR%%/gamelib/objects.py
+%%DATADIR%%/run_game.py
+@dirrm %%DATADIR%%/gamelib
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%