aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-07-03 00:02:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-07-03 00:02:13 +0000
commite6e8f977b7706b5d70264c63e37ed67104350dcc (patch)
treeccc27c73396675001c2f92d2ca3ec338f67e3eb7
parent63d27a6ff1a7b16ef6aa486f0cbfa562756918f3 (diff)
downloadports-e6e8f977b7706b5d70264c63e37ed67104350dcc.tar.gz
ports-e6e8f977b7706b5d70264c63e37ed67104350dcc.zip
Notes
-rw-r--r--graphics/deep_zoom/Makefile4
-rw-r--r--graphics/imlib2/Makefile2
-rw-r--r--graphics/imlib2/files/patch-imlib2-config.in11
-rw-r--r--x11-wm/fluxspace/Makefile5
-rw-r--r--x11-wm/phluid/Makefile6
5 files changed, 21 insertions, 7 deletions
diff --git a/graphics/deep_zoom/Makefile b/graphics/deep_zoom/Makefile
index 88c190e33bb9..6c0f857c0c04 100644
--- a/graphics/deep_zoom/Makefile
+++ b/graphics/deep_zoom/Makefile
@@ -8,7 +8,7 @@
PORTNAME= deep_zoom
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://members.rogers.com/rowley-c/deep_zoom/
@@ -19,7 +19,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
gmp.6:${PORTSDIR}/math/libgmp4
-IMLIB2_CONFIG= ${X11BASE}/bin/imlib2-config
+IMLIB2_CONFIG= ${LOCALBASE}/bin/imlib2-config
USE_REINPLACE= yes
USE_GNOME= glib12
USE_GMAKE= yes
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index e9cf62f38614..06f7378c86cb 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://enlightenment.freedesktop.org/files/
diff --git a/graphics/imlib2/files/patch-imlib2-config.in b/graphics/imlib2/files/patch-imlib2-config.in
new file mode 100644
index 000000000000..25215305bfaf
--- /dev/null
+++ b/graphics/imlib2/files/patch-imlib2-config.in
@@ -0,0 +1,11 @@
+--- imlib2-config.in.orig Sun Jul 3 07:35:44 2005
++++ imlib2-config.in Sun Jul 3 07:36:02 2005
+@@ -42,7 +42,7 @@
+ if test @includedir@ != /usr/include ; then
+ includes=-I@includedir@
+ fi
+- echo $includes
++ echo $includes @my_includes@
+ ;;
+ --libs)
+ libdirs=-L@libdir@
diff --git a/x11-wm/fluxspace/Makefile b/x11-wm/fluxspace/Makefile
index ff22551995b9..74c30a49ad12 100644
--- a/x11-wm/fluxspace/Makefile
+++ b/x11-wm/fluxspace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fluxspace
PORTVERSION= 0.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= http://www.isomedia.com/homes/stevencooper/files/
@@ -20,6 +20,9 @@ BUILD_DEPENDS= imlib2-config:${PORTSDIR}/graphics/imlib2 \
USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
.include <bsd.port.pre.mk>
diff --git a/x11-wm/phluid/Makefile b/x11-wm/phluid/Makefile
index 4fdec8ce9ece..f29d5477b763 100644
--- a/x11-wm/phluid/Makefile
+++ b/x11-wm/phluid/Makefile
@@ -7,7 +7,7 @@
PORTNAME= phluid
PORTVERSION= 0.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phluid
@@ -20,7 +20,7 @@ LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
- LDFLAGS="-L${X11BASE}/lib -lm"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm"
.include <bsd.port.mk>