aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-10-22 11:24:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-10-22 11:24:21 +0000
commitf1dfb5839658bc3af7d9caffa41c2f1d1c06018d (patch)
treed60971c81357687df95024c077a7dee3b2b068f3
parent18e31e4fdc73f3568077822dd5f6f0c9a69b1f54 (diff)
Notes
-rw-r--r--devel/opencl/Makefile42
-rw-r--r--devel/opencl/distinfo25
-rw-r--r--devel/opencl/pkg-descr2
-rw-r--r--devel/opencl/pkg-plist15
4 files changed, 42 insertions, 42 deletions
diff --git a/devel/opencl/Makefile b/devel/opencl/Makefile
index 09ca4dcd0140..6f81319eee49 100644
--- a/devel/opencl/Makefile
+++ b/devel/opencl/Makefile
@@ -2,40 +2,40 @@
# $FreeBSD$
PORTNAME= opencl
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= devel
-MASTER_SITES= http://www.khronos.org/registry/cl/api/${PORTVERSION}/
-DISTFILES= opencl.h cl_platform.h cl.h cl_ext.h cl_dx9_media_sharing.h \
- cl_d3d10.h cl_d3d11.h cl_gl.h cl_gl_ext.h cl.hpp
-DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY=
MAINTAINER= ohartman@zedat.fu-berlin.de
-COMMENT= Open Computing Language (OpenCL) specifications V2.0 (header files)
+COMMENT= Open Computing Language (OpenCL) specifications V2.1 (header files)
LICENSE= unknown
LICENSE_NAME= BSD-esque license agreement
LICENSE_TEXT= License is included in each of the header files of this port
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS= opencl-1.[0-1]
+CONFLICTS= opencl-1.[0-2]
-NO_BUILD= yes
+USE_GITHUB= yes
+GH_ACCOUNT= KhronosGroup
+GH_PROJECT= OpenCL-Headers:DEFAULT OpenCL-CLHPP:clhpp
+GH_TAGNAME= ${HEADER_TAG}:DEFAULT ${CLHPP_TAG}:clhpp
-.for f in ${DISTFILES}
-PLIST_FILES+=include/CL/$f
-.endfor
+# the header releases don't have tags yet, so use git commit for now
+HEADER_TAG= 2d06e09
+CLHPP_TAG= v2.0.10
-pre-patch:
- @${MKDIR} ${WRKSRC}
-.for f in ${DISTFILES}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/$f ${WRKSRC}/
-.endfor
+USES= python:build
+NO_CONFIGURE= yes
+
+do-build:
+ @cd ${WRKSRC_clhpp} && ${PYTHON_CMD} gen_cl_hpp.py
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/CL
-.for f in ${DISTFILES}
- ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${PREFIX}/include/CL
-.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/CL
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/CL
+ ${INSTALL_DATA} ${WRKSRC_clhpp}/cl.hpp \
+ ${STAGEDIR}${PREFIX}/include/CL/cl.hpp
+ ${INSTALL_DATA} ${WRKSRC_clhpp}/input_cl2.hpp \
+ ${STAGEDIR}${PREFIX}/include/CL/cl2.hpp
.include <bsd.port.mk>
diff --git a/devel/opencl/distinfo b/devel/opencl/distinfo
index 6502c497326e..94ace692aced 100644
--- a/devel/opencl/distinfo
+++ b/devel/opencl/distinfo
@@ -1,20 +1,5 @@
-SHA256 (opencl/opencl.h) = fceb7e76d81159caab6308a05ff05d18fbd84718eff4263473ecd148c458987c
-SIZE (opencl/opencl.h) = 1754
-SHA256 (opencl/cl_platform.h) = 042877b8091bfeeb489018505ce36c37cd3295e691856461b1c0a8fbb6b2cc21
-SIZE (opencl/cl_platform.h) = 42192
-SHA256 (opencl/cl.h) = 5c39e93d4492cd3005ae806a91b7dd3cad28f4e69036208be21e37f8a4395717
-SIZE (opencl/cl.h) = 70803
-SHA256 (opencl/cl_ext.h) = be1ff04c63b678383828ab1e69ecf3bec54eec4cf4ae33e210b4a16eff47d809
-SIZE (opencl/cl_ext.h) = 14002
-SHA256 (opencl/cl_dx9_media_sharing.h) = 41968538b82523ef8fb642a1a4da20a6262ce0448f71541db080f8ccc03971b6
-SIZE (opencl/cl_dx9_media_sharing.h) = 5181
-SHA256 (opencl/cl_d3d10.h) = 14b00ef68a2d7f471c7ef5b4576bc103888da70fc525b263b49ff7fff150e188
-SIZE (opencl/cl_d3d10.h) = 4883
-SHA256 (opencl/cl_d3d11.h) = 707709a73b6b43b96c55e813efb2d655efcc82eb103da4b8aea191231df7e1fd
-SIZE (opencl/cl_d3d11.h) = 4877
-SHA256 (opencl/cl_gl.h) = 40375d991f4e847c94ad56c6c14400e3e7d72620117b49636518a96d57f30647
-SIZE (opencl/cl_gl.h) = 7346
-SHA256 (opencl/cl_gl_ext.h) = dccb3b45e53bfe0219bb48e6dbe9591bbe6a090a8b0d93a3b8580f526abc4616
-SIZE (opencl/cl_gl_ext.h) = 2630
-SHA256 (opencl/cl.hpp) = eeacf0fefc51d618dda67d52e2bbff7dc9a67e90bc38166b3fad26d44800013a
-SIZE (opencl/cl.hpp) = 915453
+TIMESTAMP = 1477133498
+SHA256 (KhronosGroup-OpenCL-Headers-2.1-2d06e09_GH0.tar.gz) = 6e5d2fc99809fd963ac2ce3648e79fa7997262741992b7a4ccd923f8d1194f6f
+SIZE (KhronosGroup-OpenCL-Headers-2.1-2d06e09_GH0.tar.gz) = 30745
+SHA256 (KhronosGroup-OpenCL-CLHPP-v2.0.10_GH0.tar.gz) = fa27456295c3fa534ce824eb0314190a8b3ebd3ba4d93a0b1270fc65bf378f2b
+SIZE (KhronosGroup-OpenCL-CLHPP-v2.0.10_GH0.tar.gz) = 129954
diff --git a/devel/opencl/pkg-descr b/devel/opencl/pkg-descr
index e794f597bd54..26bf4b64f80a 100644
--- a/devel/opencl/pkg-descr
+++ b/devel/opencl/pkg-descr
@@ -3,4 +3,4 @@ for general purpose parallel programming across CPUs, GPUs and
other processors, giving software developers portable and efficient
access to the power of these heterogeneous processing platforms.
-This is OpenCL 2.0
+These header are covering OpenCL API 2.1
diff --git a/devel/opencl/pkg-plist b/devel/opencl/pkg-plist
new file mode 100644
index 000000000000..f9adb3702c80
--- /dev/null
+++ b/devel/opencl/pkg-plist
@@ -0,0 +1,15 @@
+include/CL/cl.h
+include/CL/cl.hpp
+include/CL/cl2.hpp
+include/CL/cl_d3d10.h
+include/CL/cl_d3d11.h
+include/CL/cl_dx9_media_sharing.h
+include/CL/cl_dx9_media_sharing_intel.h
+include/CL/cl_egl.h
+include/CL/cl_ext.h
+include/CL/cl_ext_intel.h
+include/CL/cl_gl.h
+include/CL/cl_gl_ext.h
+include/CL/cl_platform.h
+include/CL/cl_va_api_media_sharing_intel.h
+include/CL/opencl.h