aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-04-15 14:52:14 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-04-15 14:52:14 +0000
commitf7cf5a40583ca5d62a7549fa761894101d163c17 (patch)
tree99acded5be8f6d1518c6c094f1e0e0b965cd9a7c
parent39aa70d2f3a1d948bb67cfccc0a0084c02e63fe6 (diff)
Notes
-rw-r--r--Mk/bsd.php.mk3
-rw-r--r--lang/php5-extensions/Makefile6
-rw-r--r--lang/php5/Makefile.ext7
-rw-r--r--lang/php53/Makefile.ext7
4 files changed, 18 insertions, 5 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index db3cd6254bec..60d96fb2a134 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -255,7 +255,7 @@ _USE_PHP_VER4= ${_USE_PHP_ALL} crack dbase dbx dio domxml filepro mcal mcve \
mhash ncurses oracle overload pfpro xslt yp
_USE_PHP_VER5= ${_USE_PHP_ALL} dom filter mysqli pdo \
pdo_mysql pdo_pgsql pdo_sqlite \
- simplexml soap spl sqlite tidy xmlreader xmlwriter xsl
+ simplexml soap spl sqlite sqlite3 tidy xmlreader xmlwriter xsl
_USE_PHP_VER52= ${_USE_PHP_ALL} dbase ncurses dom filter ming mysqli oci8 \
pdo pdo_mysql pdo_sqlite simplexml soap spl sqlite tidy \
xmlreader xmlwriter xsl mhash
@@ -324,6 +324,7 @@ soap_DEPENDS= net/php${PHP_VER}-soap
sockets_DEPENDS=net/php${PHP_VER}-sockets
spl_DEPENDS= devel/php${PHP_VER}-spl
sqlite_DEPENDS= databases/php${PHP_VER}-sqlite
+sqlite3_DEPENDS=databases/php${PHP_VER}-sqlite3
sybase_ct_DEPENDS= databases/php${PHP_VER}-sybase_ct
sysvmsg_DEPENDS=devel/php${PHP_VER}-sysvmsg
sysvsem_DEPENDS=devel/php${PHP_VER}-sysvsem
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 9d5d9a1bb621..3be6a298854e 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= lang
MASTER_SITES= # none
PKGNAMESUFFIX= -extensions
@@ -34,6 +34,7 @@ WITH_POSIX= yes
WITH_SESSION= yes
WITH_SIMPLEXML= yes
WITH_SQLITE= yes
+WITH_SQLITE3= yes
WITH_TOKENIZER= yes
WITH_XML= yes
WITH_XMLREADER= yes
@@ -83,6 +84,7 @@ OPTIONS= BCMATH "bc style precision math functions" off \
SOAP "SOAP support" off \
SOCKETS "sockets support" off \
SQLITE "sqlite support" on \
+ SQLITE3 "sqlite3 support" on \
SYBASE_CT "Sybase database support" off \
SYSVMSG "System V message support" off \
SYSVSEM "System V semaphore support" off \
@@ -113,7 +115,7 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
MSSQL MYSQL MYSQLI \
ODBC OPENSSL PCNTL PDF PDO PDO_SQLITE PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
- SOCKETS SQLITE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
+ SOCKETS SQLITE SQLITE3 SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
YAZ ZIP ZLIB
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index bb2b685c241f..47d9eef82c93 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -344,6 +344,11 @@ PHP_HEADER_DIRS=libsqlite/src
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
+.if ${PHP_MODNAME} == "sqlite3"
+USE_SQLITE= yes
+CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
+.endif
+
.if ${PHP_MODNAME} == "sybase_ct"
LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
@@ -513,7 +518,7 @@ BROKEN_WITH_MYSQL= 323 40
. endif
.endif
-.if ${PHP_MODNAME} == "openssl"
+.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index bb2b685c241f..47d9eef82c93 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -344,6 +344,11 @@ PHP_HEADER_DIRS=libsqlite/src
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
+.if ${PHP_MODNAME} == "sqlite3"
+USE_SQLITE= yes
+CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
+.endif
+
.if ${PHP_MODNAME} == "sybase_ct"
LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
@@ -513,7 +518,7 @@ BROKEN_WITH_MYSQL= 323 40
. endif
.endif
-.if ${PHP_MODNAME} == "openssl"
+.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif