aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-06-10 10:24:27 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-06-10 10:24:27 +0000
commitff1132239fae664d20b42deca424f16d8dff0e93 (patch)
treef1cda7ece1290e417eb542bebee600b62f60b641
parentceea7ce56605f2972c70ee9532de8f6fb0513123 (diff)
downloadports-ff1132239fae664d20b42deca424f16d8dff0e93.tar.gz
ports-ff1132239fae664d20b42deca424f16d8dff0e93.zip
MFH: r538378
Chase audio/libadplug update. This also requires an update to 1.8.1. Approved by: ports-secteam (joneum) Security: 329ecd60-aaf7-11ea-8659-10bf48e1088e
Notes
Notes: svn path=/branches/2020Q2/; revision=538383
-rw-r--r--audio/adplay/Makefile20
-rw-r--r--audio/adplay/distinfo6
-rw-r--r--audio/adplay/files/patch-acinclude.m420
3 files changed, 14 insertions, 32 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 693b276e89b8..cbc131c980bb 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= adplay
-PORTVERSION= 1.8
+PORTVERSION= 1.8.1
PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= audio
@@ -17,30 +17,32 @@ LIB_DEPENDS= libadplug.so:audio/libadplug \
libbinio.so:devel/libbinio
USES= autoreconf libtool pkgconfig
-GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= adplug
GH_PROJECT= ${PORTNAME}-unix
GH_TUPLE= adplug:database:${DBVERSION}:database/database-${DBVERSION}
-DBFILE= adplug.db
-DBVERSION= v1.0
-
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sharedstatedir=${DATADIR}
+PLIST_FILES= ${DATADIR}/adplug.db \
+ bin/adplay \
+ man/man1/adplay.1.gz
+
OPTIONS_DEFINE= ALSA SDL
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-ALSA_CONFIGURE_WITH= alsa-prefix=${LOCALBASE}/lib
ALSA_CONFIGURE_OFF= --disable-output-alsa
+ALSA_CONFIGURE_WITH= alsa-prefix=${LOCALBASE}/lib
ALSA_CFLAGS+= `pkg-config --cflags alsa`
-SDL_CONFIGURE_OFF= --disable-output-sdl
SDL_USES= sdl
-SDL_USE= SDL=sdl,mixer
+SDL_USE= SDL=mixer,sdl
+SDL_CONFIGURE_OFF= --disable-output-sdl
-PLIST_FILES= bin/adplay %%DATADIR%%/adplug.db man/man1/adplay.1.gz
+DBFILE= adplug.db
+DBVERSION= v1.0
post-patch:
@${RM} ${WRKSRC}/src/getopt.h
diff --git a/audio/adplay/distinfo b/audio/adplay/distinfo
index a71c1a975e2e..76e9c42092f2 100644
--- a/audio/adplay/distinfo
+++ b/audio/adplay/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1511100939
-SHA256 (adplug-adplay-unix-v1.8_GH0.tar.gz) = dcb4dbf886b6087900012d00034a85fbaa29d7488d54d923122af625d8b918aa
-SIZE (adplug-adplay-unix-v1.8_GH0.tar.gz) = 42111
+TIMESTAMP = 1590309553
+SHA256 (adplug-adplay-unix-v1.8.1_GH0.tar.gz) = 5fa1d475740bf88f5a618c1a79b52d1b0faf0c70b1c3f181114711fd2c84aa2d
+SIZE (adplug-adplay-unix-v1.8.1_GH0.tar.gz) = 42222
SHA256 (adplug-database-v1.0_GH0.tar.gz) = 1c2cfd08bbaba19209893d5a6ef18287251aa34c82c2704570255e19a2535a99
SIZE (adplug-database-v1.0_GH0.tar.gz) = 4462
diff --git a/audio/adplay/files/patch-acinclude.m4 b/audio/adplay/files/patch-acinclude.m4
deleted file mode 100644
index 0a1636dfd0e7..000000000000
--- a/audio/adplay/files/patch-acinclude.m4
+++ /dev/null
@@ -1,20 +0,0 @@
---- acinclude.m4.orig 2010-01-01 08:21:00 UTC
-+++ acinclude.m4
-@@ -422,7 +422,7 @@ if test "$alsa_prefix" != "" ; then
- fi
-
- dnl add the alsa library
--ALSA_LIBS="$ALSA_LIBS -lasound -lm -ldl -lpthread"
-+ALSA_LIBS="$ALSA_LIBS -lasound -lm -lpthread"
- LIBS="$ALSA_LIBS $LIBS"
- AC_MSG_RESULT($ALSA_LIBS)
-
-@@ -541,7 +541,7 @@ AC_ARG_ENABLE(aotest, [ --disable-aotes
-
- # see where dl* and friends live
- AC_CHECK_FUNCS(dlopen, [AO_DL_LIBS=""], [
-- AC_CHECK_LIB(dl, dlopen, [AO_DL_LIBS="-ldl"], [
-+ AC_CHECK_LIB(dl, dlopen, [
- AC_MSG_WARN([could not find dlopen() needed by libao sound drivers
- your system may not be supported.])
- ])