aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-06 23:52:17 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-06 23:52:17 +0000
commit00a7f38fa8fa7442fbb3aed69b039dd216640f3c (patch)
tree05a9e3d6bf08fee687f979912661a84be94aa1d5
parentc41a90a41831b3c296ba59bfaba155ea06e13b20 (diff)
downloadports-00a7f38fa8fa7442fbb3aed69b039dd216640f3c.tar.gz
ports-00a7f38fa8fa7442fbb3aed69b039dd216640f3c.zip
Notes
-rw-r--r--audio/deadbeef/Makefile1
-rw-r--r--devel/codeblocks/Makefile7
-rw-r--r--devel/mongo-cxx-driver/Makefile3
-rw-r--r--games/wesnoth/Makefile5
-rw-r--r--graphics/gnash/Makefile2
-rw-r--r--irc/ezbounce/Makefile4
-rw-r--r--math/stp/Makefile3
-rw-r--r--security/spass/Makefile5
8 files changed, 11 insertions, 19 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index f09227ae3287..637cf2a12c9a 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -26,6 +26,7 @@ CPPFLAGS+= -I../dumb/dumb-kode54/include -I../../plugins/libmp4ff \
-I../../plugins/gme/game-music-emu-0.6pre \
-I./sidplay-libs/libsidplay/include/sidplay \
-I${LOCALBASE}/include
+CFLAGS+= -Wno-narrowing
LIBS+= -L${LOCALBASE}/lib -lexecinfo -lintl
USE_GNOME= intltool
INSTALLS_ICONS= yes
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 670223131126..bdae961ae565 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -14,8 +14,6 @@ COMMENT= Open source, cross-platform, free C/C++ IDE
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-BROKEN_powerpc64= fails to configure: checking for exit in -lboost_system-boost_system... no
-
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
@@ -23,8 +21,9 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libhunspell-1.6.so:textproc/hunspell \
libtinyxml.so:textproc/tinyxml
-USES= tar:xz autoreconf compiler desktop-file-utils fam:gamin localbase \
- gettext-runtime libtool pathfix pkgconfig shared-mime-info
+USES= autoreconf compiler:c++11-lang desktop-file-utils \
+ fam:gamin gettext-runtime libtool localbase \
+ pathfix pkgconfig shared-mime-info tar:xz
USE_WX= 2.8
USE_GNOME= gtk20 cairo
USE_XORG= x11
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
index d67c1dcc4717..f905e1c7fdfe 100644
--- a/devel/mongo-cxx-driver/Makefile
+++ b/devel/mongo-cxx-driver/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/APACHE-2.0.txt
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'BIO_s_file_internal'
-BROKEN_powerpc64= fails to configure: Checking for C++ library boost_regex... no
LIB_DEPENDS= libboost_system.so:devel/boost-libs
@@ -32,7 +31,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mongodb
GH_PROJECT= mongo-cxx-driver
-USES= scons ssl
+USES= compiler:c++11-lang scons ssl
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
--cc=${CC} \
--cxx=${CXX}
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 996def3f8e75..bbeb3550967e 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -15,8 +15,6 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to link: schema_validator.cpp: undefined reference to boost::match_results
-
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libvorbisfile.so:audio/libvorbis \
libboost_thread.so:devel/boost-libs \
@@ -27,7 +25,8 @@ LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
PORTSCOUT= limitw:1,even
-USES= cmake:outsource cpe pkgconfig python:2.7,run readline:port shebangfix ssl tar:bzip2
+USES= cmake:outsource compiler:c++11-lang cpe pkgconfig \
+ python:2.7,run readline:port shebangfix ssl tar:bzip2
USE_SDL= image2 mixer2 ttf2
USE_LDCONFIG= yes
USE_GNOME= cairo pango
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 3325c04ceabd..6ecbe349bb08 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
CONFLICTS= gnash-devel-[0-9]*
-USES= cpe tar:bzip2 compiler:features autoreconf pkgconfig gmake libtool jpeg desktop-file-utils
+USES= autoreconf compiler:c++11-lang cpe desktop-file-utils gmake jpeg libtool pkgconfig tar:bzip2
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
WANT_GSTREAMER= yes
diff --git a/irc/ezbounce/Makefile b/irc/ezbounce/Makefile
index 2c44e07479e8..6b837d44d81f 100644
--- a/irc/ezbounce/Makefile
+++ b/irc/ezbounce/Makefile
@@ -10,8 +10,6 @@ MASTER_SITES= http://BSDforge.com/projects/source/irc/ezbounce/
MAINTAINER= portmaster@BSDforge.com
COMMENT= Highly configurable IRC Proxy
-BROKEN_powerpc64= fails to configure: checking for boostlib >= 1.33... not found
-
OPTIONS_DEFINE= DOCS SSL COMPRESS
OPTIONS_DEFAULT=SSL COMPRESS
OPTIONS_SUB= yes
@@ -23,7 +21,7 @@ COMPRESS_CONFIGURE_WITH=boost
COMPRESS_DESC= Chat log compression (requires boost)
GNU_CONFIGURE= yes
-USES= gmake
+USES= compiler:c++0x gmake
USE_GCC= any
# ezbounce 1.99.15 isn't compatible with C++11 and later, which some compilers
diff --git a/math/stp/Makefile b/math/stp/Makefile
index 548929f78045..2baec95114a1 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -14,13 +14,12 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: undefined reference to sbrk
-BROKEN_powerpc64= fails to compile: main.cpp.o: undefined reference to boost::program_options::error_with_option_name::get_canonical_option_name()
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libminisat.so:math/minisat \
libcryptominisat5.so:math/cryptominisat
-USES= bison:build cmake:outsource perl5 python
+USES= bison:build compiler:c++11-lang cmake:outsource perl5 python
USE_GITHUB= yes
USE_PERL5= build
USE_LDCONFIG= yes
diff --git a/security/spass/Makefile b/security/spass/Makefile
index 27c84171febc..c8cd99a937a8 100644
--- a/security/spass/Makefile
+++ b/security/spass/Makefile
@@ -11,9 +11,6 @@ COMMENT= Secure password generator with a true random number generator
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_sparc64= cannot link with boost
-BROKEN_powerpc64= fails to link: main.cpp.o: undefined reference to boost::program_options::options_description::options_description
-
BUILD_DEPENDS= ${LOCALBASE}/include/boost/format.hpp:devel/boost-libs
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
@@ -21,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= guyru
GH_TAGNAME= cb0de64
-USES= cmake
+USES= cmake compiler:c++11-lang
CMAKE_ARGS= -DWITH_ALSA:BOOL=off -DWITH_OSS:BOOL=on