aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-11 11:33:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-11 11:33:25 +0000
commit0819f6ac9dd557a3e652365efad8b260d2697706 (patch)
treee9fefa33b67e7fb24c824ca50b86a79f5266e953
parentedc4d68104cd816cf6ce5b68ea872bce7c67d498 (diff)
Unbreak. The port did not override PLIST, which is required for
dynamic plists. This solution is different from the one submitted by the maintainer and does not require a 600k pkg-plist file in the ports tree. PR: 88812
Notes
Notes: svn path=/head/; revision=147909
-rw-r--r--www/moodle/Makefile8
-rw-r--r--www/moodle2/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/www/moodle/Makefile b/www/moodle/Makefile
index 038bdcc97bc8..3a5f6644462d 100644
--- a/www/moodle/Makefile
+++ b/www/moodle/Makefile
@@ -14,11 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jmrueda@diatel.upm.es
COMMENT= Course management system based on social constructionism
-BROKEN= Modifies ports tree at build time
-
-WRKSRC= ${WRKDIR}/moodle
-
USE_PHP= session gd pcre
+WRKSRC= ${WRKDIR}/moodle
.if defined(WITH_MYSQL)
USE_PHP+= mysql
@@ -31,6 +28,7 @@ USE_PHP+= pgsql
.include <bsd.port.pre.mk>
NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
MOODLEDIR?= www/data/moodle
MOODLEDATADIR?= www/data/moodledata
@@ -45,6 +43,8 @@ pre-everything::
post-patch:
####This is an old patched file.
@${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
+
+pre-install:
@${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
@${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
@${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
diff --git a/www/moodle2/Makefile b/www/moodle2/Makefile
index 038bdcc97bc8..3a5f6644462d 100644
--- a/www/moodle2/Makefile
+++ b/www/moodle2/Makefile
@@ -14,11 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jmrueda@diatel.upm.es
COMMENT= Course management system based on social constructionism
-BROKEN= Modifies ports tree at build time
-
-WRKSRC= ${WRKDIR}/moodle
-
USE_PHP= session gd pcre
+WRKSRC= ${WRKDIR}/moodle
.if defined(WITH_MYSQL)
USE_PHP+= mysql
@@ -31,6 +28,7 @@ USE_PHP+= pgsql
.include <bsd.port.pre.mk>
NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
MOODLEDIR?= www/data/moodle
MOODLEDATADIR?= www/data/moodledata
@@ -45,6 +43,8 @@ pre-everything::
post-patch:
####This is an old patched file.
@${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
+
+pre-install:
@${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
@${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
@${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}