aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-31 00:11:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-31 00:11:28 +0000
commit0d7efa9686c5ab038cf9fea0ebef199a41c54e58 (patch)
tree2006b92959cc2dee99bfa4728656c79a7e0a166f
parent47c1047a0dbd89b2a61fb0dc98c18a87e5e876a3 (diff)
downloadports-0d7efa9686c5ab038cf9fea0ebef199a41c54e58.tar.gz
ports-0d7efa9686c5ab038cf9fea0ebef199a41c54e58.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pear-Text_Highlighter/Makefile35
-rw-r--r--textproc/pear-Text_Highlighter/distinfo3
-rw-r--r--textproc/pear-Text_Highlighter/pkg-descr9
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4a0c571802fc..795d419e8e54 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -747,6 +747,7 @@
SUBDIR += pear-Spreadsheet_Excel_Writer
SUBDIR += pear-Structures_DataGrid_DataSource_RSS
SUBDIR += pear-Structures_DataGrid_DataSource_XML
+ SUBDIR += pear-Text_Highlighter
SUBDIR += pear-XML_Beautifier
SUBDIR += pear-XML_DTD
SUBDIR += pear-XML_Feed_Parser
diff --git a/textproc/pear-Text_Highlighter/Makefile b/textproc/pear-Text_Highlighter/Makefile
new file mode 100644
index 000000000000..a7463c927b0b
--- /dev/null
+++ b/textproc/pear-Text_Highlighter/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pear-File_Highlighter
+# Date created: 28 Dec 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text_Highlighter
+PORTVERSION= 0.7.0
+CATEGORIES= textproc pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PEAR Syntax highlighting
+
+BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+
+CATEGORY= Text
+FILES= Highlighter.php abap.xml diff.xml generate.bat \
+ javascript.xml php.xml sample.css cpp.xml dtd.xml \
+ html.xml mysql.xml python.xml sql.xml \
+ Highlighter/ABAP.php Highlighter/CSS.php Highlighter/DTD.php \
+ Highlighter/HTML.php Highlighter/JAVASCRIPT.php Highlighter/PERL.php \
+ Highlighter/PYTHON.php Highlighter/SQL.php Highlighter/CPP.php \
+ Highlighter/DIFF.php Highlighter/Generator.php Highlighter/JAVA.php \
+ Highlighter/MYSQL.php Highlighter/PHP.php Highlighter/RUBY.php \
+ Highlighter/Renderer.php Highlighter/XML.php \
+ Highlighter/Renderer/Array.php Highlighter/Renderer/BB.php \
+ Highlighter/Renderer/Console.php Highlighter/Renderer/Html.php \
+ Highlighter/Renderer/HtmlTags.php Highlighter/Renderer/JSON.php \
+ Highlighter/Renderer/XML.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-Text_Highlighter/distinfo b/textproc/pear-Text_Highlighter/distinfo
new file mode 100644
index 000000000000..7e43acc44d79
--- /dev/null
+++ b/textproc/pear-Text_Highlighter/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Text_Highlighter-0.7.0.tgz) = 66c15ab304c389fa63c9471106bfcd78
+SHA256 (PEAR/Text_Highlighter-0.7.0.tgz) = e1b900f11e107b38f18ba2cb6813c8e5de2b5903db47beabbfd3198f2cafc4af
+SIZE (PEAR/Text_Highlighter-0.7.0.tgz) = 129483
diff --git a/textproc/pear-Text_Highlighter/pkg-descr b/textproc/pear-Text_Highlighter/pkg-descr
new file mode 100644
index 000000000000..a7806b6d8a79
--- /dev/null
+++ b/textproc/pear-Text_Highlighter/pkg-descr
@@ -0,0 +1,9 @@
+File_Fortune provides a PHP interface to reading fortune files. With it, you may
+retrieve a single fortune, a random fortune, or all fortunes in the file.
+
+Additionally, it offers the ability to access fortune files as if they were a
+native array, including updating and deleting items. All write operations will
+produce a binary header file to allow compatability with the fortune and
+fortune-mod programs (as well as other fortune interfaces).
+
+WWW: http://pear.php.net/package/File_Fortune/