aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 13:30:32 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 13:30:32 +0000
commit152c8d7c3c1dc0f75bef8b676d0a98cf1231926c (patch)
tree0dfcb2e46a804b4df79160d1771d41d1998ee3dd
parent2c178c2e139681514ca1e26e746d97c106cc44d2 (diff)
downloadports-152c8d7c3c1dc0f75bef8b676d0a98cf1231926c.tar.gz
ports-152c8d7c3c1dc0f75bef8b676d0a98cf1231926c.zip
Notes
-rw-r--r--net-mgmt/gsnmp/Makefile2
-rw-r--r--net-mgmt/guifi-snpservices/Makefile1
-rw-r--r--net-mgmt/icingaweb2-module-businessprocess/Makefile2
-rw-r--r--net-mgmt/icingaweb2-module-vsphere/Makefile2
-rw-r--r--net-mgmt/jnettop/Makefile2
-rw-r--r--net-mgmt/mbrowse/Makefile2
-rw-r--r--net-mgmt/ndpmon/Makefile2
-rw-r--r--net-mgmt/phpweathermap/Makefile2
-rw-r--r--net-mgmt/resource-agents/Makefile2
-rw-r--r--net-mgmt/scli/Makefile2
-rw-r--r--net-mgmt/spectools/Makefile1
-rw-r--r--net-mgmt/super_mediator/Makefile2
-rw-r--r--net-mgmt/tornova/Makefile2
-rw-r--r--net-mgmt/torrus/Makefile2
-rw-r--r--net-mgmt/virt-viewer/Makefile4
15 files changed, 16 insertions, 14 deletions
diff --git a/net-mgmt/gsnmp/Makefile b/net-mgmt/gsnmp/Makefile
index c5538ac2c2c3..a7568397fa9e 100644
--- a/net-mgmt/gsnmp/Makefile
+++ b/net-mgmt/gsnmp/Makefile
@@ -14,7 +14,7 @@ COMMENT= SNMP library written on top of glib and gnet2
LIB_DEPENDS= libgnet-2.0.so:net/gnet2
-USES= libtool pathfix pkgconfig
+USES= gnome libtool pathfix pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net-mgmt/guifi-snpservices/Makefile b/net-mgmt/guifi-snpservices/Makefile
index 130cc5576918..2e121edd7fc7 100644
--- a/net-mgmt/guifi-snpservices/Makefile
+++ b/net-mgmt/guifi-snpservices/Makefile
@@ -16,6 +16,7 @@ COMMENT= Graphics server for the guifi.net meshnet
RUN_DEPENDS= mrtg:net-mgmt/mrtg \
rrdtool:databases/rrdtool
+USES= php
USE_PHP= gd simplexml dom
SNPSERVICES_TMPDIR?= /var/tmp/${PORTNAME}
diff --git a/net-mgmt/icingaweb2-module-businessprocess/Makefile b/net-mgmt/icingaweb2-module-businessprocess/Makefile
index 86e23c5235b1..aab279102539 100644
--- a/net-mgmt/icingaweb2-module-businessprocess/Makefile
+++ b/net-mgmt/icingaweb2-module-businessprocess/Makefile
@@ -23,7 +23,7 @@ NO_ARCH= yes
OPTIONS_DEFINE= NLS
-NLS_USES= gettext
+NLS_USES= gettext php
NLS_USE= php=intl
WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
diff --git a/net-mgmt/icingaweb2-module-vsphere/Makefile b/net-mgmt/icingaweb2-module-vsphere/Makefile
index 3d7da3dfc31d..29819023668d 100644
--- a/net-mgmt/icingaweb2-module-vsphere/Makefile
+++ b/net-mgmt/icingaweb2-module-vsphere/Makefile
@@ -12,9 +12,9 @@ COMMENT= Automated import of your VMs and Physical Host from VMware Sphere
RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2 \
${LOCALBASE}/www/icingaweb2/modules/director/run.php:net-mgmt/icingaweb2-module-director
+USES= php
USE_GITHUB= yes
GH_ACCOUNT= icinga
-
USE_PHP= posix soap
NO_BUILD= yes
diff --git a/net-mgmt/jnettop/Makefile b/net-mgmt/jnettop/Makefile
index 6ff790115686..9d4d3169cb6f 100644
--- a/net-mgmt/jnettop/Makefile
+++ b/net-mgmt/jnettop/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= zi@FreeBSD.org
COMMENT= Traffic visualizer, similar to nettop
GNU_CONFIGURE= yes
-USES= pkgconfig gmake
+USES= gmake gnome pkgconfig
USE_GNOME= glib20
LICENSE= GPLv2
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index 601ad7de2f31..20b3b2aa4db4 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
GNU_CONFIGURE= yes
PLIST_FILES= bin/mbrowse
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= gtk20
CONFIGURE_ARGS= --with-snmp-prefix=${PREFIX} --with-snmp-type=net
CPPFLAGS+= `net-snmp-config --cflags`
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index 4f32c791bea0..64d4b402e9be 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -13,7 +13,7 @@ COMMENT= On-link icmpv6 message monitoring and reporting daemon
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= perl5 shebangfix ssl tar:tgz
+USES= gnome perl5 shebangfix ssl tar:tgz
SHEBANG_FILES= demopipeprogram.pl.sample
USE_PERL5= run
USE_GNOME= libxml2
diff --git a/net-mgmt/phpweathermap/Makefile b/net-mgmt/phpweathermap/Makefile
index e2bc5c26bda7..49d893ea45e5 100644
--- a/net-mgmt/phpweathermap/Makefile
+++ b/net-mgmt/phpweathermap/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Getopt.php:devel/pear@${PHP_FLAVOR}
NO_BUILD= yes
NO_ARCH= yes
-USES= zip
+USES= php zip
USE_PHP= gd
WM_FILES= HTML_ImageMap.class.php WeatherMap.functions.php \
diff --git a/net-mgmt/resource-agents/Makefile b/net-mgmt/resource-agents/Makefile
index 04714c6ac66b..63064fca2dbc 100644
--- a/net-mgmt/resource-agents/Makefile
+++ b/net-mgmt/resource-agents/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= heartbeat-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs
-USES= autoreconf gmake pkgconfig python shebangfix
+USES= autoreconf gmake gnome pkgconfig python shebangfix
USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-fatal-warnings
diff --git a/net-mgmt/scli/Makefile b/net-mgmt/scli/Makefile
index 6f5a3f0f1150..350d45bc119d 100644
--- a/net-mgmt/scli/Makefile
+++ b/net-mgmt/scli/Makefile
@@ -16,7 +16,7 @@ BROKEN= unfetchable
LIB_DEPENDS= libgsnmp.so:net-mgmt/gsnmp
GNU_CONFIGURE= yes
-USES= gmake ncurses pkgconfig readline
+USES= gmake gnome ncurses pkgconfig readline
USE_GNOME= libxml2
INFO= scli
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 8ea60e72816c..3e7eec9a1422 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -26,6 +26,7 @@ OPTIONS_DEFAULT= GTK2 NCURSES
OPTIONS_SUB= yes
GTK2_ALL_TARGET= spectool_gtk
+GTK2_USES= gnome
GTK2_USE= GNOME=gtk20
NCURSES_ALL_TARGET= spectool_curses
diff --git a/net-mgmt/super_mediator/Makefile b/net-mgmt/super_mediator/Makefile
index d6e9981cb94e..38c0211b68c3 100644
--- a/net-mgmt/super_mediator/Makefile
+++ b/net-mgmt/super_mediator/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfixbuf.so:net/libfixbuf \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= compiler:c11 libtool pathfix perl5 pkgconfig ssl
+USES= compiler:c11 gnome libtool pathfix perl5 pkgconfig ssl
USE_GNOME= glib20
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
diff --git a/net-mgmt/tornova/Makefile b/net-mgmt/tornova/Makefile
index be75c0dec5ce..162ece935fee 100644
--- a/net-mgmt/tornova/Makefile
+++ b/net-mgmt/tornova/Makefile
@@ -19,7 +19,7 @@ USE_GITHUB= yes
GH_ACCOUNT= neelchauhan
GH_PROJECT= TorNova
-USES= python:2.7
+USES= gnome python:2.7
USE_PYTHON= autoplist distutils
USE_GNOME= gtk30 pygobject3
NO_ARCH= yes
diff --git a/net-mgmt/torrus/Makefile b/net-mgmt/torrus/Makefile
index a586f9f83efa..0edc17720bbf 100644
--- a/net-mgmt/torrus/Makefile
+++ b/net-mgmt/torrus/Makefile
@@ -26,7 +26,7 @@ BUILD_DEPENDS= rrdtool>=0:databases/rrdtool \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GNOME= libxml2
-USES= perl5
+USES= gnome perl5
USE_PERL5= run
GNU_CONFIGURE= yes
NO_ARCH= yes
diff --git a/net-mgmt/virt-viewer/Makefile b/net-mgmt/virt-viewer/Makefile
index cd7410ff9434..72b7d54d4d4a 100644
--- a/net-mgmt/virt-viewer/Makefile
+++ b/net-mgmt/virt-viewer/Makefile
@@ -26,8 +26,8 @@ OPTIONS_SUB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= DATADIRNAME=share
CONFIGURE_ARGS= --with-spice-gtk
-USES= autoreconf libtool desktop-file-utils gmake pkgconfig \
- shared-mime-info cpe gettext-tools
+USES= autoreconf cpe desktop-file-utils gettext-tools gmake gnome \
+ libtool pkgconfig shared-mime-info
USE_GNOME= gtk30
INSTALLS_ICONS= yes
CPE_VENDOR= redhat