aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 21:12:04 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 21:12:04 +0000
commit1961e8f62aa09557e68027fa6176735ba83a79ef (patch)
treedf7478b3ce3a289731e54a4067ac68190c12dda4
parentc44aa1025fcba37a9681ff3c349fdad8085af0ef (diff)
downloadports-1961e8f62aa09557e68027fa6176735ba83a79ef.tar.gz
ports-1961e8f62aa09557e68027fa6176735ba83a79ef.zip
Notes
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-clay-core/Makefile37
-rw-r--r--java/eclipse-clay-core/distinfo2
-rw-r--r--java/eclipse-clay-core/pkg-descr8
-rw-r--r--java/eclipse-clay-core/pkg-plist97
5 files changed, 145 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 4ca60f513af2..6bab207b72f1 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -18,6 +18,7 @@
SUBDIR += eclipse
SUBDIR += eclipse-cdt
SUBDIR += eclipse-checkstyle
+ SUBDIR += eclipse-clay-core
SUBDIR += eclipse-emf
SUBDIR += eclipse-examples
SUBDIR += eclipse-gef
diff --git a/java/eclipse-clay-core/Makefile b/java/eclipse-clay-core/Makefile
new file mode 100644
index 000000000000..9b7532936636
--- /dev/null
+++ b/java/eclipse-clay-core/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: eclipse-clay-core
+# Date created: January 13, 2004
+# Whom: mitsuru@riken.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= clay
+PORTVERSION= 1.0.5
+CATEGORIES= java devel
+MASTER_SITES= http://www.azzurri.jp/download/
+PKGNAMEPREFIX= eclipse-
+PKGNAMESUFFIX= -core
+DISTNAME= jp.azzurri.clay.core_${PORTVERSION}.bin.dist.${DISTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= mitsuru@riken.jp
+COMMENT= A database design tool for the Eclipse development environment
+
+RUN_DEPENDS+= ${LOCALBASE}/eclipse/features/org.eclipse.gef_3.0.0/feature.xml:${PORTSDIR}/java/eclipse-gef
+
+RESTRICTED= Condition is not clear
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+DISABLE_SIZE?= yes
+PLIST_SUB= RELEASEVERSION=${PORTVERSION}
+
+DISTVERSION= 20040730
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-clay-core/distinfo b/java/eclipse-clay-core/distinfo
new file mode 100644
index 000000000000..b51e0b62cc07
--- /dev/null
+++ b/java/eclipse-clay-core/distinfo
@@ -0,0 +1,2 @@
+MD5 (eclipse/jp.azzurri.clay.core_1.0.5.bin.dist.20040730.zip) = e460a937ce18dfa41953fbf3581543b2
+SIZE (eclipse/jp.azzurri.clay.core_1.0.5.bin.dist.20040730.zip) = 813998
diff --git a/java/eclipse-clay-core/pkg-descr b/java/eclipse-clay-core/pkg-descr
new file mode 100644
index 000000000000..7f37be3c5761
--- /dev/null
+++ b/java/eclipse-clay-core/pkg-descr
@@ -0,0 +1,8 @@
+Clay is a database design tool that runs as a plug-in in the
+Eclipse development environment. Clay has an intuitive user
+interface for graphically designing database models. Clay can
+also create a database model by reverse engineering an existing
+database. Furthermore, Clay generates the SQL (DDL) code
+appropriate for your database.
+
+WWW: http://www.azzurri.jp/en/software/clay/
diff --git a/java/eclipse-clay-core/pkg-plist b/java/eclipse-clay-core/pkg-plist
new file mode 100644
index 000000000000..a5cbf5d86371
--- /dev/null
+++ b/java/eclipse-clay-core/pkg-plist
@@ -0,0 +1,97 @@
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/azzurri_logo.gif
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/feature.properties
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/feature.xml
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/feature_ja.properties
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/license.html
+eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%/license_en.html
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/about.html
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/about.ini
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/about.mappings
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/about.properties
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/about_en.html
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/azzurri_clay_core.jar
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/clayFeature.jpg
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/license.html
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/license_en.html
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/en/about.properties
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/en/welcome.xml
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/ja/about.properties
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/ja/welcome.xml
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/plugin.xml
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/schema/databaseModelValidators.exsd
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/schema/sqldialects.exsd
+eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/welcome.xml
+eclipse/plugins/jp.azzurri.clay.ui.jdbc_%%RELEASEVERSION%%/azzurri_clay_ui_jdbc.jar
+eclipse/plugins/jp.azzurri.clay.ui.jdbc_%%RELEASEVERSION%%/fragment.xml
+eclipse/plugins/jp.azzurri.clay.ui.jdbc_%%RELEASEVERSION%%/icons/reverse_database.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/.options
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/about.html
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/about_en.html
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/azzurri.cer
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/azzurri_clay_ui.jar
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/azzurri_logo.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/check_off_enabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/check_on_disabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/check_on_enabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_index.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_index_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_with_key.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_with_key_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_with_link.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claycolumn_with_link_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claydomain.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claydomain_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/clayindex.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/clayindex_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claykey.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claykey_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claylinks.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claylinks_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claymodel.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claymodel_new.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claymodel_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/clayschema.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/clayschema_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claytable.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claytable_new.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/claytable_wbg.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/connection16.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/connection32.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/copy_edit.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/cut_edit.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/database.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/disp_sbook_enabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/export_htmldoc_wiz.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/extension_obj.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/ext_point_obj.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/file_obj.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/fldr_obj.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/import_wiz.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/java_workingset_wiz.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/newsbook_wiz.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/outline.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/overview.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/packagefolder_obj.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/paste_edit.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/remove_disabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/remove_enabled.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/remove_gray.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/space.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/sqldoc.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/sqldoc_new.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons/synch_synch.gif
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/license.html
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/license_en.html
+eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/plugin.xml
+@dirrm eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/en
+@dirrm eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl/ja
+@dirrm eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/nl
+@dirrm eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%/schema
+@dirrm eclipse/plugins/jp.azzurri.clay.core_%%RELEASEVERSION%%
+@dirrm eclipse/plugins/jp.azzurri.clay.ui.jdbc_%%RELEASEVERSION%%/icons
+@dirrm eclipse/plugins/jp.azzurri.clay.ui.jdbc_%%RELEASEVERSION%%
+@dirrm eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%/icons
+@dirrm eclipse/plugins/jp.azzurri.clay.ui_%%RELEASEVERSION%%
+@dirrm eclipse/features/jp.azzurri.clay.core_%%RELEASEVERSION%%