aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-12-02 00:45:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-12-02 00:45:49 +0000
commit2227e221a1010ebfb6a983905f382e604bb23bd5 (patch)
tree959845570f5d700d219c690c4302c43e4acc7419
parent08a9421aaf2f898ccbf80cf7d0edd9a056c047da (diff)
downloadports-2227e221a1010ebfb6a983905f382e604bb23bd5.tar.gz
ports-2227e221a1010ebfb6a983905f382e604bb23bd5.zip
Notes
-rw-r--r--audio/glame/Makefile8
-rw-r--r--devel/glade--/Makefile8
-rw-r--r--graphics/truevision/Makefile8
-rw-r--r--mail/gmail/Makefile10
-rw-r--r--mail/mmc/Makefile8
-rw-r--r--math/rascal/Makefile8
6 files changed, 42 insertions, 8 deletions
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
index b3bd698b2d0b..21b52bba1bb5 100644
--- a/audio/glame/Makefile
+++ b/audio/glame/Makefile
@@ -24,6 +24,12 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lltdl ${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -38,4 +44,4 @@ post-install:
--entry="* glame: (glame). audio processing tool for GNOME" \
${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/glade--/Makefile b/devel/glade--/Makefile
index b47d77480fc5..f6d3dbca0ea7 100644
--- a/devel/glade--/Makefile
+++ b/devel/glade--/Makefile
@@ -22,10 +22,16 @@ USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${PERL} -pi -e 's|%%GTK_CONFIG%%|${GTK_CONFIG}|g' \
${WRKSRC}/src/glade--.cc
@${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Cxx.cc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
index 4bf62ffbb5ed..1bf7bd43f278 100644
--- a/graphics/truevision/Makefile
+++ b/graphics/truevision/Makefile
@@ -26,6 +26,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_FLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -36,4 +42,4 @@ pre-patch:
@${REINPLACE_CMD} -e "s,-lgthread,-lgthread12,g ; \
s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/gmail/Makefile b/mail/gmail/Makefile
index 0bc21cf86886..29adeb312447 100644
--- a/mail/gmail/Makefile
+++ b/mail/gmail/Makefile
@@ -12,8 +12,6 @@ MASTER_SITES= http://gmail.linuxpower.org/
MAINTAINER= baskruit@bsltwr.dnsalias.org
-BROKEN= "Does not build"
-
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client \
gmime.6:${PORTSDIR}/mail/gmime
@@ -22,4 +20,10 @@ USE_GMAKE= YES
USE_GNOME= YES
USE_LIBTOOL= YES
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/mmc/Makefile b/mail/mmc/Makefile
index c5278b6a9f00..2e1a47e12a61 100644
--- a/mail/mmc/Makefile
+++ b/mail/mmc/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -29,4 +35,4 @@ pre-patch:
's|\$$\(gnomedatadir\)/gnome/|\$$\(datadir\)/|g ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/rascal/Makefile b/math/rascal/Makefile
index 2687c538ff0f..045f6877c959 100644
--- a/math/rascal/Makefile
+++ b/math/rascal/Makefile
@@ -26,6 +26,12 @@ ALL_TARGET= rascal grascal
MANCOMPRESSED= yes
MAN1= rascal.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,g\+\+,${CXX},g ; \
@@ -33,4 +39,4 @@ post-patch:
s,gnome-config,${GNOME_CONFIG},g ; \
s,CC,CXX,g" ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>