aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-11-02 16:12:05 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-11-02 16:12:05 +0000
commit2862d2c72d8e6605f4eb902402c08da3a05c2638 (patch)
treee5bcf029fe582af54bed6b77062f15f36432cda4
parent750fe11447ed94fcbcf428d4977bea0646f6a44e (diff)
downloadports-2862d2c72d8e6605f4eb902402c08da3a05c2638.tar.gz
ports-2862d2c72d8e6605f4eb902402c08da3a05c2638.zip
Notes
-rw-r--r--lang/php72/Makefile.ext5
-rw-r--r--security/php72-hash/Makefile3
2 files changed, 5 insertions, 3 deletions
diff --git a/lang/php72/Makefile.ext b/lang/php72/Makefile.ext
index 73e0f92d97f2..f0d141507ae0 100644
--- a/lang/php72/Makefile.ext
+++ b/lang/php72/Makefile.ext
@@ -131,6 +131,11 @@ CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.if ${PHP_MODNAME} == "hash"
CONFIGURE_ARGS+=--enable-hash \
--with-mhash
+CFLAGS_mips64= -DHAVE_SLOW_HASH3
+CFLAGS_powerpc64= -DHAVE_SLOW_HASH3
+CFLAGS_powerpc= -DHAVE_SLOW_HASH3
+CFLAGS_powerpcspe= -DHAVE_SLOW_HASH3
+CFLAGS_sparc64= -DHAVE_SLOW_HASH3
.endif
.if ${PHP_MODNAME} == "iconv"
diff --git a/security/php72-hash/Makefile b/security/php72-hash/Makefile
index 5b9cfc698766..60b453738980 100644
--- a/security/php72-hash/Makefile
+++ b/security/php72-hash/Makefile
@@ -6,9 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -hash
-BROKEN_mips64= fails to compile: KeccakHash.h: No such file or directory
-BROKEN_powerpc64= fails to compile: KeccakHash.h: No such file or directory
-
TEST_TARGET= test
.include "${MASTERDIR}/Makefile"