aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-25 13:03:32 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-25 13:03:32 +0000
commit319b83159a2a256cae4443571d440a795def33c9 (patch)
tree759fded23d5e4baa92307879926edbee8f5567f8
parentc69e9adf00304f57fb5edbb312d13043e519fcb2 (diff)
Adding sysutils/fusefs-curlftpfs:
CurlFtpFS is a filesystem for acessing FTP hosts based on FUSE and libcurl. CurlFtpFS differentiates itself from other FTP filesystems because it features: * SSLv3 and TLSv1 support * connecting through tunneling HTTP proxies * automatically reconnection if the server times out * transform absolute symlinks to point back into the ftp file system WWW: http://curlftpfs.sourceforge.net/ Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=163363
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile31
-rw-r--r--sysutils/fusefs-curlftpfs/distinfo3
-rw-r--r--sysutils/fusefs-curlftpfs/pkg-descr13
4 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cba3122a4f68..c3952732e47b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -177,6 +177,7 @@
SUBDIR += freqsdwn
SUBDIR += fsbackup
SUBDIR += ftrace
+ SUBDIR += fusefs-curlftpfs
SUBDIR += fusefs-kmod
SUBDIR += fusefs-libs
SUBDIR += fusefs-sshfs
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
new file mode 100644
index 000000000000..76ebefe44703
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fusefs-curlftpfs
+# Date created: 25 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curlftpfs
+PORTVERSION= 0.8
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Mount remote ftp directories
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+GNU_CONFIGURE= yes
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/curlftpfs
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-curlftpfs/distinfo b/sysutils/fusefs-curlftpfs/distinfo
new file mode 100644
index 000000000000..4cc7d4ff9115
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (curlftpfs-0.8.tar.gz) = 5322877611319397319ca0012ccc61c9
+SHA256 (curlftpfs-0.8.tar.gz) = 610c5e769f23632ff2d14067880b377797228151b661b1da78fea50651ec12d1
+SIZE (curlftpfs-0.8.tar.gz) = 345187
diff --git a/sysutils/fusefs-curlftpfs/pkg-descr b/sysutils/fusefs-curlftpfs/pkg-descr
new file mode 100644
index 000000000000..2ab38d64ae57
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/pkg-descr
@@ -0,0 +1,13 @@
+CurlFtpFS is a filesystem for acessing FTP hosts based on FUSE and
+libcurl.
+
+CurlFtpFS differentiates itself from other FTP filesystems because it
+features:
+
+ * SSLv3 and TLSv1 support
+ * connecting through tunneling HTTP proxies
+ * automatically reconnection if the server times out
+ * transform absolute symlinks to point back into the ftp file
+ system
+
+WWW: http://curlftpfs.sourceforge.net/