aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:41:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:41:03 +0000
commit31aa31cccc3a73c6e83a04087cdde6b6b87158b8 (patch)
tree0efd16c28e9935d739f8e5e87487548616f61e40
parentf7315265039cfebfa1e0e487fb136928794c8816 (diff)
downloadports-31aa31cccc3a73c6e83a04087cdde6b6b87158b8.tar.gz
ports-31aa31cccc3a73c6e83a04087cdde6b6b87158b8.zip
Notes
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-systemconfig/Makefile33
-rw-r--r--deskutils/etoile-systemconfig/distinfo3
-rw-r--r--deskutils/etoile-systemconfig/pkg-descr13
-rw-r--r--deskutils/etoile-systemconfig/pkg-plist8
5 files changed, 58 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 69f11570b07c..cd73ef3aa951 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -48,6 +48,7 @@
SUBDIR += etoile-panekit
SUBDIR += etoile-preferenceskit
SUBDIR += etoile-servicesbarkit
+ SUBDIR += etoile-systemconfig
SUBDIR += etoile-trackerkit
SUBDIR += etoile-ui
SUBDIR += etoile-workspaceswitcher
diff --git a/deskutils/etoile-systemconfig/Makefile b/deskutils/etoile-systemconfig/Makefile
new file mode 100644
index 000000000000..a11aa05cb965
--- /dev/null
+++ b/deskutils/etoile-systemconfig/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-systemconfig
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= systemconfig
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Framework which provides a way to set system preferences
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/SystemConfig
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-systemconfig/distinfo b/deskutils/etoile-systemconfig/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/deskutils/etoile-systemconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/deskutils/etoile-systemconfig/pkg-descr b/deskutils/etoile-systemconfig/pkg-descr
new file mode 100644
index 000000000000..5a52b6efad3a
--- /dev/null
+++ b/deskutils/etoile-systemconfig/pkg-descr
@@ -0,0 +1,13 @@
+SystemConfig is a framework which provides various a common way to set system
+specific preferences by interfacing with the host system. Host system means the
+following combo:
+ * operating sytem
+ * additional abstraction support (sound, network etc.)
+ * display/window server
+Versatile and flexible devices support is often done through an extra
+abstraction layer/library on top of the kernel. This is what 'additional
+abstraction support' means. GNOME System tools backend is an example of such
+library that allows to set various settings (like network related ones) without
+having to pay attention on which operating system Etoile is used.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-systemconfig/pkg-plist b/deskutils/etoile-systemconfig/pkg-plist
new file mode 100644
index 000000000000..1b170dcb82db
--- /dev/null
+++ b/deskutils/etoile-systemconfig/pkg-plist
@@ -0,0 +1,8 @@
+Local/Library/Headers/libSystemConfig/SCKeyboard.h
+Local/Library/Headers/libSystemConfig/SCMonitor.h
+Local/Library/Headers/libSystemConfig/SCMouse.h
+Local/Library/Headers/libSystemConfig/SCSound.h
+Local/Library/Libraries/libSystemConfig.so
+Local/Library/Libraries/libSystemConfig.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libSystemConfig.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/libSystemConfig