aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-17 15:10:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-17 15:10:33 +0000
commit33393ed6a67414610a7689f546e2906ba5fcd90d (patch)
treecfdb66e5537dbc1fc807298cec098fb6b2ad2975
parent8ebdd95921d70ddf8853f593b625e411e79dce15 (diff)
downloadports-33393ed6a67414610a7689f546e2906ba5fcd90d.tar.gz
ports-33393ed6a67414610a7689f546e2906ba5fcd90d.zip
Notes
-rw-r--r--editors/tea/Makefile21
-rw-r--r--editors/tea/distinfo4
-rw-r--r--editors/tea/files/patch-document.cpp16
-rw-r--r--editors/tea/files/patch-rvln.cpp10
-rw-r--r--editors/tea/pkg-descr6
5 files changed, 19 insertions, 38 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index c923072d8172..4cf8ab9823c0 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tea
-DISTVERSION= 35.0.0
+PORTVERSION= 36.0.1
CATEGORIES= editors
MASTER_SITES= http://semiletov.org/tea/dloads/
@@ -11,16 +11,18 @@ COMMENT= Simple and powerful Qt4-based text editor
LICENSE= GPLv3
+OPTIONS_RADIO= SPELL
+OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
+OPTIONS_DEFAULT= ASPELL
+
USE_BZIP2= yes
-USE_DOS2UNIX= rvln.*
USE_QT4= gui moc_build qmake_build rcc_build
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/tea share/pixmaps/tea_icon_v2.png
-OPTIONS_RADIO= SPELL
-OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
-OPTIONS_DEFAULT= ASPELL
+DESKTOP_ENTRIES="TEA" "" "${PREFIX}/share/pixmaps/tea_icon_v2.png" \
+ "${PORTNAME}" "" ""
.include <bsd.port.options.mk>
@@ -40,12 +42,17 @@ QMAKEFLAGS+= USE_HUNSPELL=false
post-patch:
@${REINPLACE_CMD} -e \
+ 's|Q_OS_LINUX|Q_OS_UNIX|' ${WRKSRC}/document.cpp
+ @${REINPLACE_CMD} -e \
's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
do-configure:
@cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ (cd ${WRKSRC}/bin \
+ && ${INSTALL_PROGRAM} tea ${PREFIX}/bin)
+ (cd ${WRKSRC}/icons \
+ && ${INSTALL_DATA} tea_icon_v2.png ${PREFIX}/share/pixmaps)
.include <bsd.port.mk>
diff --git a/editors/tea/distinfo b/editors/tea/distinfo
index a7ee36677c5d..52c0d98d06b5 100644
--- a/editors/tea/distinfo
+++ b/editors/tea/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tea-35.0.0.tar.bz2) = a2b7972937e1bd3fd01ff0194748aef326fe4f08ad5f2930e7c06d88e433b7fb
-SIZE (tea-35.0.0.tar.bz2) = 314921
+SHA256 (tea-36.0.1.tar.bz2) = 472d7db0a814b4398564d77ccfcdfb6d8dd78452faca73079f6513e624942048
+SIZE (tea-36.0.1.tar.bz2) = 316905
diff --git a/editors/tea/files/patch-document.cpp b/editors/tea/files/patch-document.cpp
deleted file mode 100644
index 6ecc5cfad458..000000000000
--- a/editors/tea/files/patch-document.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- document.cpp.orig
-+++ document.cpp
-@@ -206,11 +206,11 @@
-
- qDebug() << "defined(Q_OS_WIN) || defined(Q_OS_OS2)";
-
--#elif defined(Q_OS_LINUX)
-+#elif defined(Q_OS_LINUX) || defined(Q_OS_UNIX)
-
- eol = "\n";
-
-- qDebug() << "Q_OS_LINUX";
-+ qDebug() << "defined(Q_OS_LINUX) || defined(Q_OS_UNIX)";
-
-
- #elif defined(Q_OS_MAC)
diff --git a/editors/tea/files/patch-rvln.cpp b/editors/tea/files/patch-rvln.cpp
deleted file mode 100644
index 4c3685785760..000000000000
--- a/editors/tea/files/patch-rvln.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- rvln.cpp.orig
-+++ rvln.cpp
-@@ -55,6 +55,7 @@
- #include <QSettings>
- #include <QLibraryInfo>
- #include <QCryptographicHash>
-+#include <QDebug>
-
-
- #ifdef PRINTER_ENABLE
diff --git a/editors/tea/pkg-descr b/editors/tea/pkg-descr
index 5445adca7444..3120632f7b78 100644
--- a/editors/tea/pkg-descr
+++ b/editors/tea/pkg-descr
@@ -1,6 +1,6 @@
-TEA is powerful text editor for Unix-like systems. It depends on Qt4 and,
-optionally, GNU Aspell. With an ultimately small size, TEA provides
-hundreds of functions. Some of the features include:
+TEA is powerful text editor for Unix-like systems. It depends on Qt4
+and, optionally, GNU Aspell or Hunspell. With an ultimately small size,
+TEA provides hundreds of functions. Some of the features include:
- Built-in MC-like file manager (with support for archived files)
- Spellchecker (using the Aspell or/and Hunspell)