aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-30 11:28:20 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-30 11:28:20 +0000
commit39d38dc020cd816b5630815f16100dafd1dfed8c (patch)
tree18d5ba387a69ce95a022e675692b042698c805f8
parent679a7a09053f1e9590e8f774602b3b7573b01654 (diff)
downloadports-39d38dc020cd816b5630815f16100dafd1dfed8c.tar.gz
ports-39d38dc020cd816b5630815f16100dafd1dfed8c.zip
Notes
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/inconsolata-lgc-ttf/Makefile40
-rw-r--r--x11-fonts/inconsolata-lgc-ttf/distinfo2
-rw-r--r--x11-fonts/inconsolata-lgc-ttf/pkg-descr9
4 files changed, 52 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index c95153dc5e94..55b7e0e9a489 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -92,6 +92,7 @@
SUBDIR += gnu-unifont-ttf
SUBDIR += gohufont
SUBDIR += hanazono-fonts-ttf
+ SUBDIR += inconsolata-lgc-ttf
SUBDIR += inconsolata-ttf
SUBDIR += indic-ttf
SUBDIR += intlfonts
diff --git a/x11-fonts/inconsolata-lgc-ttf/Makefile b/x11-fonts/inconsolata-lgc-ttf/Makefile
new file mode 100644
index 000000000000..69b588962520
--- /dev/null
+++ b/x11-fonts/inconsolata-lgc-ttf/Makefile
@@ -0,0 +1,40 @@
+# Created by: Ilya A. Arkhipov <rum1cro@yandex.ru>
+# $FreeBSD$
+
+PORTNAME= Inconsolata-LGC
+PORTVERSION= 20131024
+CATEGORIES= x11-fonts
+
+MAINTAINER= rum1cro@yandex.ru
+COMMENT= Monospaced TrueType font with Cyrillic glyphs
+
+LICENSE= OFL11
+
+USE_GITHUB= yes
+GH_ACCOUNT= DeLaGuardo
+GH_COMMIT= 16e2c94
+GH_TAGNAME= ${GH_COMMIT}
+
+USE_XORG= x11
+INSTALLS_TTF= yes
+NO_BUILD= yes
+FONTDIR= TTF
+
+PLIST_FILES= lib/X11/fonts/${FONTDIR}/inconsolatalgc.ttf \
+ lib/X11/fonts/${FONTDIR}/inconsolatalgcbold.ttf \
+ lib/X11/fonts/${FONTDIR}/inconsolatalgcbolditalic.ttf \
+ lib/X11/fonts/${FONTDIR}/inconsolatalgcitalic.ttf
+PLIST_DIRSTRY= lib/X11/fonts/${FONTDIR}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/fonts/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/inconsolatalgc.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/inconsolatalgcbold.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/inconsolatalgcbolditalic.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/inconsolatalgcitalic.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/${FONTDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/inconsolata-lgc-ttf/distinfo b/x11-fonts/inconsolata-lgc-ttf/distinfo
new file mode 100644
index 000000000000..b0aa6bce551d
--- /dev/null
+++ b/x11-fonts/inconsolata-lgc-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Inconsolata-LGC-20131024.tar.gz) = 8d10b2f780f1c97c7c4ddb5c704a7e7aefb6f1bf82dc84909c05c95f03d89ef8
+SIZE (Inconsolata-LGC-20131024.tar.gz) = 463032
diff --git a/x11-fonts/inconsolata-lgc-ttf/pkg-descr b/x11-fonts/inconsolata-lgc-ttf/pkg-descr
new file mode 100644
index 000000000000..1356963f6ffb
--- /dev/null
+++ b/x11-fonts/inconsolata-lgc-ttf/pkg-descr
@@ -0,0 +1,9 @@
+Inconsolata is one of the most suitable fonts for programmers created by Raph
+Levien. Since the original Inconsolata does not contain Cyrillic alphabet,
+it was slightly inconvenient for quite a few programmers from Russia.
+
+Inconsolata LGC is a modified version of Inconsolata with added the Cyrillic
+alphabet which directly descends from Inconsolata Hellenic supporting modern
+Greek.
+
+WWW: https://github.com/DeLaGuardo/Inconsolata-LGC