aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2007-06-10 10:05:16 +0000
committerPhilip Paeps <philip@FreeBSD.org>2007-06-10 10:05:16 +0000
commit3edc013beee77c1af1a21799b0f67c30e3a87bce (patch)
tree8c4b0c9c46f833b81f7ff09cbcc0ae07411ffeb3
parent0d17ea06d3495cdbc2d4a8e4f90de91c447b3592 (diff)
downloadports-3edc013beee77c1af1a21799b0f67c30e3a87bce.tar.gz
ports-3edc013beee77c1af1a21799b0f67c30e3a87bce.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--x11-wm/Makefile2
-rw-r--r--x11-wm/ion-3/Makefile53
-rw-r--r--x11-wm/ion-3/distinfo6
-rw-r--r--x11-wm/ion-3/files/patch-system.mk30
-rw-r--r--x11-wm/ion-3/pkg-plist44
-rw-r--r--x11-wm/ion-3ds/Makefile42
-rw-r--r--x11-wm/ion-3ds/distinfo3
-rw-r--r--x11-wm/ion-3ds/files/patch-system.mk113
-rw-r--r--x11-wm/ion-3ds/pkg-descr20
-rw-r--r--x11-wm/ion-3ds/pkg-plist91
11 files changed, 83 insertions, 322 deletions
diff --git a/MOVED b/MOVED
index e8538e8a88ee..ed90a922fdc4 100644
--- a/MOVED
+++ b/MOVED
@@ -3065,3 +3065,4 @@ multimedia/snd-music-duplicates||2007-06-05|Has expired: Development has been ce
audio/freebirth||2007-06-05|Has expired: Doesn't work on FreeBSD 5.0 and higher
net/sixxs-heartbeatd||2007-06-05|obsolete, use net/sixxs-aiccu instead
graphics/tgif-nls|graphics/tgif|2007-06-09|graphics/tgif now supports NLS by default
+x11-wm/ion-3ds|x11-wm/ion-3|2007-06-10|Upstream project became -rc, soon to become release
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index fbcf2dc4bac2..af6014895063 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -65,7 +65,7 @@
SUBDIR += icewm
SUBDIR += ion
SUBDIR += ion-2
- SUBDIR += ion-3ds
+ SUBDIR += ion-3
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kahakai
diff --git a/x11-wm/ion-3/Makefile b/x11-wm/ion-3/Makefile
index 2f81d41200c0..3c5e9bb2299a 100644
--- a/x11-wm/ion-3/Makefile
+++ b/x11-wm/ion-3/Makefile
@@ -5,38 +5,69 @@
# $FreeBSD$
#
-PORTNAME= ion-3ds
-PORTVERSION= 20070318
-PORTREVISION= 1
+PORTNAME= ion-3rc
+PORTVERSION= 20070608
CATEGORIES= x11-wm
-MASTER_SITES= http://modeemi.fi/~tuomov/dl/
+MASTER_SITES= http://modeemi.fi/~tuomov/dl/:ion3 \
+ http://wannabehacker.com/src/:xinerama
+DISTNAME= ion-3rc-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ion3
MAINTAINER= philip@FreeBSD.org
COMMENT= The development version of the Ion window manager
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
-USE_X_PREFIX= yes
-USE_GETTEXT= yes
+CONFLICTS= ion-3ds-200*
+
+USE_XLIB= yes
USE_GMAKE= yes
USE_LUA= 5.1
MAKE_ENV= DEFINES="${IONDEFINES}"
.if defined(WITHOUT_NLS)
IONDEFINES+= -DCF_NO_LOCALE
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+.if !defined(WITH_XINERAMA)
+PLIST_SUB+= XINERAMA="@comment "
+.else
+PLIST_SUB+= XINERAMA=""
+DISTFILES+= mod_xinerama-20070430${EXTRACT_SUFX}:xinerama
.endif
MAN1= ion3.1 pwm3.1
-MANLANG= "" fi cs de
-DOCSDIR= share/doc/ion3
+MANLANG= "" fi cs
-# NO, I don't want to use configure but ion's author system.mk
+# Use our own system.mk, instead of the one generated by configure
do-configure:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= needs wide character string functions in libc
+post-extract:
+.if defined(WITH_XINERAMA)
+ @${MV} ${WRKDIR}/mod_xinerama-3 ${WRKSRC}/mod_xinerama
+.endif
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^_install:|dont&|' ${WRKSRC}/Makefile
+.endif
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's| po | |' ${WRKSRC}/Makefile
+.endif
+.if defined(WITH_XINERAMA)
+ @${REINPLACE_CMD} -e 's|^MODULE_LIST =|& mod_xinerama|' \
+ ${WRKSRC}/modulelist.mk
+.endif
+
+post-install:
+.if defined(WITH_XINERAMA) && !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/mod_xinerama/README \
+ ${DOCSDIR}/README.mod_xinerama
.endif
.include <bsd.port.post.mk>
diff --git a/x11-wm/ion-3/distinfo b/x11-wm/ion-3/distinfo
index 6f65812b6071..4d58708bd67d 100644
--- a/x11-wm/ion-3/distinfo
+++ b/x11-wm/ion-3/distinfo
@@ -1,3 +1,3 @@
-MD5 (ion-3ds-20070318.tar.gz) = f02264ab7ecc990c2cd322f57a5e8a4d
-SHA256 (ion-3ds-20070318.tar.gz) = 712da027fb12774f67d933d95a95452d98a5658617fc5515011ca79b6035258a
-SIZE (ion-3ds-20070318.tar.gz) = 657282
+MD5 (ion-3rc-20070608.tar.gz) = ba02edff5d4726104f98fa70b6cd96d8
+SHA256 (ion-3rc-20070608.tar.gz) = 1ebad89f61c3ac58bd583cfe3a0cb71c5254679a9f35f46d954d6e72eada86e8
+SIZE (ion-3rc-20070608.tar.gz) = 655442
diff --git a/x11-wm/ion-3/files/patch-system.mk b/x11-wm/ion-3/files/patch-system.mk
index 5e261bc0704c..1bce2c3c0cff 100644
--- a/x11-wm/ion-3/files/patch-system.mk
+++ b/x11-wm/ion-3/files/patch-system.mk
@@ -1,5 +1,5 @@
---- system.mk.orig Sun Mar 18 21:32:12 2007
-+++ system.mk Sat Mar 31 22:49:58 2007
+--- system.mk.orig Fri Jun 8 18:57:05 2007
++++ system.mk Sun Jun 10 11:48:58 2007
@@ -7,7 +7,7 @@
## Installation paths
##
@@ -9,14 +9,20 @@
# Unless you are creating a package conforming to some OS's standards, you
# probably do not want to modify the following directories:
-@@ -19,7 +19,7 @@
+@@ -17,11 +17,11 @@
+ # Configuration .lua files
+ ETCDIR=$(PREFIX)/etc/ion3
# Some .lua files and ion-* shell scripts
- SHAREDIR=$(PREFIX)/share/ion3
+-SHAREDIR=$(PREFIX)/share/ion3
++SHAREDIR=$(PREFIX)/share/ion-3rc
# Manual pages
-MANDIR=$(PREFIX)/share/man
+MANDIR=$(MANPREFIX)/man
# Some documents
- DOCDIR=$(PREFIX)/share/doc/ion3
+-DOCDIR=$(PREFIX)/share/doc/ion3
++DOCDIR=$(PREFIX)/share/doc/ion-3rc
+ # Nothing at the moment
+ INCDIR=$(PREFIX)/include/ion3
# Nothing at the moment
@@ -47,7 +47,7 @@
#PRELOAD_MODULES=1
@@ -71,7 +77,7 @@
# If you're on an archaic system (such as relatively recent *BSD releases)
# without even dummy multibyte/widechar and localisation support, you may
-@@ -112,24 +112,24 @@
+@@ -112,8 +112,8 @@
#DEFINES += -DCF_NO_LOCALE
# On some other systems you may something like this:
@@ -80,8 +86,9 @@
+EXTRA_LIBS += -L$(LOCALBASE)/lib -lintl
+EXTRA_INCLUDES += -I$(LOCALBASE)/include
-
- ##
+ # clock_gettime for monotonic time
+ EXTRA_LIBS += -lrt
+@@ -123,7 +123,7 @@
## C compiler
##
@@ -90,10 +97,9 @@
# Same as '-Wall -pedantic' without '-Wunused' as callbacks often
# have unused variables.
- WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
+@@ -131,8 +131,8 @@
-Wtrigraphs -Wformat -Wchar-subscripts \
-- -Wparentheses -pedantic -Wuninitialized
-+ -Wparentheses
+ -Wparentheses -pedantic -Wuninitialized
-CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
-LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
@@ -102,7 +108,7 @@
EXPORT_DYNAMIC=-Xlinker --export-dynamic
# The following options are mainly for development use and can be used
-@@ -143,7 +143,7 @@
+@@ -146,7 +146,7 @@
#POSIX_SOURCE=-D_POSIX_SOURCE
# Most systems
diff --git a/x11-wm/ion-3/pkg-plist b/x11-wm/ion-3/pkg-plist
index f213aec5f644..a1e9469af09a 100644
--- a/x11-wm/ion-3/pkg-plist
+++ b/x11-wm/ion-3/pkg-plist
@@ -18,18 +18,13 @@ etc/ion3/look_clean.lua
etc/ion3/look_cleanios.lua
etc/ion3/look_cleanviolet.lua
etc/ion3/look_dusky.lua
+etc/ion3/look_greenlight.lua
etc/ion3/look_greyviolet.lua
etc/ion3/look_ios.lua
etc/ion3/look_newviolet.lua
etc/ion3/look_simpleblue.lua
etc/ion3/lookcommon_clean.lua
-etc/ion3/lookcommon_clean_frame.lua
-etc/ion3/lookcommon_clean_stdisp.lua
-etc/ion3/lookcommon_clean_tab.lua
etc/ion3/lookcommon_emboss.lua
-etc/ion3/lookcommon_emboss_frame.lua
-etc/ion3/lookcommon_emboss_stdisp.lua
-etc/ion3/lookcommon_emboss_tab.lua
lib/ion3/bin/ion-completefile
lib/ion3/bin/ion-statusd
lib/ion3/lc/de.lc
@@ -39,11 +34,11 @@ lib/ion3/lc/ioncore_ext.lc
lib/ion3/lc/ioncore_luaext.lc
lib/ion3/lc/ioncore_menudb.lc
lib/ion3/lc/ioncore_misc.lc
+lib/ion3/lc/ioncore_tabnum.lc
lib/ion3/lc/ioncore_wd.lc
lib/ion3/lc/ioncore_winprops.lc
lib/ion3/lc/mod_dock.lc
lib/ion3/lc/mod_menu.lc
-lib/ion3/lc/mod_mgmtmode.lc
lib/ion3/lc/mod_query.lc
lib/ion3/lc/mod_query_chdir.lc
lib/ion3/lc/mod_sm.lc
@@ -56,36 +51,33 @@ lib/ion3/lc/statusd_mail.lc
lib/ion3/mod/de.so
lib/ion3/mod/mod_dock.so
lib/ion3/mod/mod_menu.so
-lib/ion3/mod/mod_mgmtmode.so
lib/ion3/mod/mod_query.so
lib/ion3/mod/mod_sm.so
lib/ion3/mod/mod_sp.so
lib/ion3/mod/mod_statusbar.so
lib/ion3/mod/mod_tiling.so
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/LICENSE
-%%DOCSDIR%%/README
-%%DOCSDIR%%/RELNOTES
-share/ion3/ion-completeman
-share/ion3/ion-runinxterm
-share/ion3/welcome.cs.txt
-share/ion3/welcome.de.txt
-share/ion3/welcome.fi.txt
-share/ion3/welcome.txt
-share/locale/cs/LC_MESSAGES/ion3.mo
-share/locale/de/LC_MESSAGES/ion3.mo
-share/locale/fi/LC_MESSAGES/ion3.mo
-share/locale/ru/LC_MESSAGES/ion3.mo
+%%XINERAMA%%lib/ion3/lc/mod_xinerama.lc
+%%XINERAMA%%lib/ion3/mod/mod_xinerama.so
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RELNOTES
+%%XINERAMA%%%%PORTDOCS%%%%DOCSDIR%%/README.mod_xinerama
+%%DATADIR%%/ion-completeman
+%%DATADIR%%/ion-runinxterm
+%%DATADIR%%/welcome.cs.txt
+%%DATADIR%%/welcome.fi.txt
+%%DATADIR%%/welcome.txt
+%%NLS%%share/locale/cs/LC_MESSAGES/ion3.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/ion3.mo
@dirrm lib/ion3/bin
@dirrm lib/ion3/lc
@dirrm lib/ion3/mod
@dirrm lib/ion3
-@dirrm share/ion3
-@dirrm %%DOCSDIR%%
+@dirrm share/ion-3
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry etc/ion3
@dirrmtry man/cs/man1
@dirrmtry man/cs
-@dirrmtry man/de/man1
-@dirrmtry man/de
@dirrmtry man/fi/man1
@dirrmtry man/fi
diff --git a/x11-wm/ion-3ds/Makefile b/x11-wm/ion-3ds/Makefile
deleted file mode 100644
index 2f81d41200c0..000000000000
--- a/x11-wm/ion-3ds/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: ion3-ds
-# Date created: 18 June 2005
-# Whom: Ed Schouten <ed@fxq.nl>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ion-3ds
-PORTVERSION= 20070318
-PORTREVISION= 1
-CATEGORIES= x11-wm
-MASTER_SITES= http://modeemi.fi/~tuomov/dl/
-
-MAINTAINER= philip@FreeBSD.org
-COMMENT= The development version of the Ion window manager
-
-RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
-
-USE_X_PREFIX= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_LUA= 5.1
-MAKE_ENV= DEFINES="${IONDEFINES}"
-
-.if defined(WITHOUT_NLS)
-IONDEFINES+= -DCF_NO_LOCALE
-.endif
-
-MAN1= ion3.1 pwm3.1
-MANLANG= "" fi cs de
-DOCSDIR= share/doc/ion3
-
-# NO, I don't want to use configure but ion's author system.mk
-do-configure:
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= needs wide character string functions in libc
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/x11-wm/ion-3ds/distinfo b/x11-wm/ion-3ds/distinfo
deleted file mode 100644
index 6f65812b6071..000000000000
--- a/x11-wm/ion-3ds/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (ion-3ds-20070318.tar.gz) = f02264ab7ecc990c2cd322f57a5e8a4d
-SHA256 (ion-3ds-20070318.tar.gz) = 712da027fb12774f67d933d95a95452d98a5658617fc5515011ca79b6035258a
-SIZE (ion-3ds-20070318.tar.gz) = 657282
diff --git a/x11-wm/ion-3ds/files/patch-system.mk b/x11-wm/ion-3ds/files/patch-system.mk
deleted file mode 100644
index 5e261bc0704c..000000000000
--- a/x11-wm/ion-3ds/files/patch-system.mk
+++ /dev/null
@@ -1,113 +0,0 @@
---- system.mk.orig Sun Mar 18 21:32:12 2007
-+++ system.mk Sat Mar 31 22:49:58 2007
-@@ -7,7 +7,7 @@
- ## Installation paths
- ##
-
--PREFIX=/usr/local
-+#PREFIX=/usr/local
-
- # Unless you are creating a package conforming to some OS's standards, you
- # probably do not want to modify the following directories:
-@@ -19,7 +19,7 @@
- # Some .lua files and ion-* shell scripts
- SHAREDIR=$(PREFIX)/share/ion3
- # Manual pages
--MANDIR=$(PREFIX)/share/man
-+MANDIR=$(MANPREFIX)/man
- # Some documents
- DOCDIR=$(PREFIX)/share/doc/ion3
- # Nothing at the moment
-@@ -47,7 +47,7 @@
- #PRELOAD_MODULES=1
-
- # Flags to link with libdl.
--DL_LIBS=-ldl
-+#DL_LIBS=-ldl
-
-
- ##
-@@ -56,11 +56,11 @@
-
- # If you have installed Lua 5.1 from the official tarball without changing
- # paths, this should do it.
--LUA_DIR=/usr/local
--LUA_LIBS = -L$(LUA_DIR)/lib -llua
--LUA_INCLUDES = -I$(LUA_DIR)/include
--LUA=$(LUA_DIR)/bin/lua
--LUAC=$(LUA_DIR)/bin/luac
-+LUA_DIR=$(LOCALBASE)
-+LUA_LIBS = -L$(LUA_LIBDIR) -llua
-+LUA_INCLUDES = -I$(LUA_INCDIR)
-+LUA=$(LUA_BINDIR)/lua
-+LUAC=$(LUA_BINDIR)/luac
-
- # If you are using the Debian packages, the following settings should be
- # what you want.
-@@ -74,7 +74,7 @@
- ## X libraries, includes and options
- ##
-
--X11_PREFIX=/usr/X11R6
-+X11_PREFIX=$(X11BASE)
- # SunOS/Solaris
- #X11_PREFIX=/usr/openwin
-
-@@ -83,7 +83,7 @@
-
- # XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
- # The following setting should work around that situation.
--DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
-+#DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
-
- # Use the Xutf8 routines (XFree86 extension) instead of the Xmb routines
- # in an UTF-8 locale. (No, you don't need this in UTF-8 locales, and
-@@ -104,7 +104,7 @@
- # asprintf and vasprintf in the c library. (gnu libc has.)
- # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in sprintf_2.2/ is used.
--#HAS_SYSTEM_ASPRINTF=1
-+HAS_SYSTEM_ASPRINTF=1
-
- # If you're on an archaic system (such as relatively recent *BSD releases)
- # without even dummy multibyte/widechar and localisation support, you may
-@@ -112,24 +112,24 @@
- #DEFINES += -DCF_NO_LOCALE
-
- # On some other systems you may something like this:
--#EXTRA_LIBS += -lintl
--#EXTRA_INCLUDES +=
-+EXTRA_LIBS += -L$(LOCALBASE)/lib -lintl
-+EXTRA_INCLUDES += -I$(LOCALBASE)/include
-
-
- ##
- ## C compiler
- ##
-
--CC=gcc
-+CC?=gcc
-
- # Same as '-Wall -pedantic' without '-Wunused' as callbacks often
- # have unused variables.
- WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
- -Wtrigraphs -Wformat -Wchar-subscripts \
-- -Wparentheses -pedantic -Wuninitialized
-+ -Wparentheses
-
--CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
--LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
-+CFLAGS+=$(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
-+LDFLAGS+=$(EXTRA_LIBS) $(LIBS)
- EXPORT_DYNAMIC=-Xlinker --export-dynamic
-
- # The following options are mainly for development use and can be used
-@@ -143,7 +143,7 @@
- #POSIX_SOURCE=-D_POSIX_SOURCE
-
- # Most systems
--#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
-+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
- # SunOS, (Irix)
- #XOPEN_SOURCE=-D__EXTENSIONS__
-
diff --git a/x11-wm/ion-3ds/pkg-descr b/x11-wm/ion-3ds/pkg-descr
deleted file mode 100644
index 20d61b9ef91b..000000000000
--- a/x11-wm/ion-3ds/pkg-descr
+++ /dev/null
@@ -1,20 +0,0 @@
-Ion (based on PWM) is a new kind of window manager that brings a
-text-editorish, keyboard friendly user interface to window management.
-
-Modern GUIs are unusable. Overlapping windows are hard to manage, especially
-from the keyboard, and the user often ends up in a jungle. Not to mention the
-application programs, which are even worse. Mouse-based search-and-click
-interfaces are slow - keyboard is fast having learnt the commands. Ion (the
-last three letters of vision =-) was written as an example and an experiment of
-something presumably better (just the window manager, though).
-
-Ion simply divides the screen into frames that take the whole screen. Big
-displays have so much space that this is convenient and smaller displays
-couldn't show more than one window at a time anyway. The frames can be split
-and growing the size of one will shrink others. Alike in PWM, clients can be
-moved between frames and multiple clients can be attached to one frame.
-
-With Ion you will hardly ever have to touch the mouse again for navigation
-between windows and the windows are always in order.
-
-WWW: http://modeemi.cs.tut.fi/~tuomov/ion/
diff --git a/x11-wm/ion-3ds/pkg-plist b/x11-wm/ion-3ds/pkg-plist
deleted file mode 100644
index f213aec5f644..000000000000
--- a/x11-wm/ion-3ds/pkg-plist
+++ /dev/null
@@ -1,91 +0,0 @@
-bin/ion3
-bin/pwm3
-etc/ion3/cfg_defaults.lua
-etc/ion3/cfg_dock.lua
-etc/ion3/cfg_ion.lua
-etc/ion3/cfg_ioncore.lua
-etc/ion3/cfg_kludges.lua
-etc/ion3/cfg_layouts.lua
-etc/ion3/cfg_menu.lua
-etc/ion3/cfg_pwm.lua
-etc/ion3/cfg_query.lua
-etc/ion3/cfg_sp.lua
-etc/ion3/cfg_statusbar.lua
-etc/ion3/cfg_tiling.lua
-etc/ion3/look.lua
-etc/ion3/look_brownsteel.lua
-etc/ion3/look_clean.lua
-etc/ion3/look_cleanios.lua
-etc/ion3/look_cleanviolet.lua
-etc/ion3/look_dusky.lua
-etc/ion3/look_greyviolet.lua
-etc/ion3/look_ios.lua
-etc/ion3/look_newviolet.lua
-etc/ion3/look_simpleblue.lua
-etc/ion3/lookcommon_clean.lua
-etc/ion3/lookcommon_clean_frame.lua
-etc/ion3/lookcommon_clean_stdisp.lua
-etc/ion3/lookcommon_clean_tab.lua
-etc/ion3/lookcommon_emboss.lua
-etc/ion3/lookcommon_emboss_frame.lua
-etc/ion3/lookcommon_emboss_stdisp.lua
-etc/ion3/lookcommon_emboss_tab.lua
-lib/ion3/bin/ion-completefile
-lib/ion3/bin/ion-statusd
-lib/ion3/lc/de.lc
-lib/ion3/lc/ioncore_bindings.lc
-lib/ion3/lc/ioncore_efbb.lc
-lib/ion3/lc/ioncore_ext.lc
-lib/ion3/lc/ioncore_luaext.lc
-lib/ion3/lc/ioncore_menudb.lc
-lib/ion3/lc/ioncore_misc.lc
-lib/ion3/lc/ioncore_wd.lc
-lib/ion3/lc/ioncore_winprops.lc
-lib/ion3/lc/mod_dock.lc
-lib/ion3/lc/mod_menu.lc
-lib/ion3/lc/mod_mgmtmode.lc
-lib/ion3/lc/mod_query.lc
-lib/ion3/lc/mod_query_chdir.lc
-lib/ion3/lc/mod_sm.lc
-lib/ion3/lc/mod_sp.lc
-lib/ion3/lc/mod_statusbar.lc
-lib/ion3/lc/mod_tiling.lc
-lib/ion3/lc/statusd_date.lc
-lib/ion3/lc/statusd_load.lc
-lib/ion3/lc/statusd_mail.lc
-lib/ion3/mod/de.so
-lib/ion3/mod/mod_dock.so
-lib/ion3/mod/mod_menu.so
-lib/ion3/mod/mod_mgmtmode.so
-lib/ion3/mod/mod_query.so
-lib/ion3/mod/mod_sm.so
-lib/ion3/mod/mod_sp.so
-lib/ion3/mod/mod_statusbar.so
-lib/ion3/mod/mod_tiling.so
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/LICENSE
-%%DOCSDIR%%/README
-%%DOCSDIR%%/RELNOTES
-share/ion3/ion-completeman
-share/ion3/ion-runinxterm
-share/ion3/welcome.cs.txt
-share/ion3/welcome.de.txt
-share/ion3/welcome.fi.txt
-share/ion3/welcome.txt
-share/locale/cs/LC_MESSAGES/ion3.mo
-share/locale/de/LC_MESSAGES/ion3.mo
-share/locale/fi/LC_MESSAGES/ion3.mo
-share/locale/ru/LC_MESSAGES/ion3.mo
-@dirrm lib/ion3/bin
-@dirrm lib/ion3/lc
-@dirrm lib/ion3/mod
-@dirrm lib/ion3
-@dirrm share/ion3
-@dirrm %%DOCSDIR%%
-@dirrmtry etc/ion3
-@dirrmtry man/cs/man1
-@dirrmtry man/cs
-@dirrmtry man/de/man1
-@dirrmtry man/de
-@dirrmtry man/fi/man1
-@dirrmtry man/fi