aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-05-11 01:49:38 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-05-11 01:49:38 +0000
commit463afd887fd8c05cd482bcfa11fc2d1ea5bd757c (patch)
tree292d7bf1354223cb9a9bd0487ef4171bba6a587c
parent25c1ff8868c1946a02edb03352f06c8d202ce663 (diff)
downloadports-463afd887fd8c05cd482bcfa11fc2d1ea5bd757c.tar.gz
ports-463afd887fd8c05cd482bcfa11fc2d1ea5bd757c.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-childprocess/Makefile22
-rw-r--r--devel/rubygem-childprocess/distinfo2
-rw-r--r--devel/rubygem-childprocess/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index edca3161fe8a..f2ab999c34ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3673,6 +3673,7 @@
SUBDIR += rubygem-bson
SUBDIR += rubygem-bugspots
SUBDIR += rubygem-builder
+ SUBDIR += rubygem-childprocess
SUBDIR += rubygem-chronic
SUBDIR += rubygem-classifier
SUBDIR += rubygem-clio
diff --git a/devel/rubygem-childprocess/Makefile b/devel/rubygem-childprocess/Makefile
new file mode 100644
index 000000000000..2c671f7ae1e4
--- /dev/null
+++ b/devel/rubygem-childprocess/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: childprocess
+# Date created: 10 May 2012
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= childprocess
+PORTVERSION= 0.3.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= External background process controller
+
+RUN_DEPENDS= rubygem-ffi>=1.0.6:${PORTSDIR}/devel/rubygem-ffi
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-childprocess/distinfo b/devel/rubygem-childprocess/distinfo
new file mode 100644
index 000000000000..06aaec3ce7b9
--- /dev/null
+++ b/devel/rubygem-childprocess/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/childprocess-0.3.2.gem) = 78d471ac236c3316b55b23dd349f7ad4723582c5563c3b1fcd07cde80328d200
+SIZE (rubygem/childprocess-0.3.2.gem) = 24064
diff --git a/devel/rubygem-childprocess/pkg-descr b/devel/rubygem-childprocess/pkg-descr
new file mode 100644
index 000000000000..7fd90cadb9c7
--- /dev/null
+++ b/devel/rubygem-childprocess/pkg-descr
@@ -0,0 +1,8 @@
+This gem aims at being a simple and reliable solution for controlling
+external programs running in the background on any Ruby / OS
+combination.
+
+The code originated in the selenium-webdriver gem, but should prove
+useful as a standalone library.
+
+WWW: https://github.com/jarib/childprocess