aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-31 14:02:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-31 14:02:28 +0000
commit479b327f4955490692a8d291ff4c3ed7d97c791f (patch)
tree06bc6748f55d769d1b132744e4b7c35fdfe3c8c5
parentdc4fdadb8ac52aec9369c058885d7814119d352e (diff)
downloadports-479b327f4955490692a8d291ff4c3ed7d97c791f.tar.gz
ports-479b327f4955490692a8d291ff4c3ed7d97c791f.zip
Notes
-rw-r--r--emulators/pearpc/Makefile9
-rw-r--r--emulators/pearpc/files/mbrtowc.c79
-rw-r--r--emulators/pearpc/files/patch-src::io::prom::fs::hfsplus::unicode.c19
-rw-r--r--emulators/pearpc/files/wcrtomb.c57
4 files changed, 164 insertions, 0 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 26aae716d7dc..961a8b9b37da 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -47,6 +47,11 @@ CONFIGURE_ARGS+= --enable-cpu=jitc_x86
CONFIGURE_ARGS+= --enable-cpu=generic
.endif
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+CFLAGS+= -DFREEBSD_MB_SUPPORT
+.endif
+
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} ""
@@ -57,6 +62,10 @@ pre-everything::
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
+.if ${OSVERSION} < 500000
+ @${CP} ${FILESDIR}/wcrtomb.c ${FILESDIR}/mbrtowc.c \
+ ${WRKSRC}/
+.endif
post-install:
@${MKDIR} ${DATADIR}
diff --git a/emulators/pearpc/files/mbrtowc.c b/emulators/pearpc/files/mbrtowc.c
new file mode 100644
index 000000000000..00689d484dba
--- /dev/null
+++ b/emulators/pearpc/files/mbrtowc.c
@@ -0,0 +1,79 @@
+/*-
+ * Copyright (c) 2002, 2003 Tim J. Robbins.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#include <sys/cdefs.h>
+__FBSDID("$FreeBSD$");
+
+#include <errno.h>
+#include <rune.h>
+#include <stdlib.h>
+#include <wchar.h>
+
+/*
+ * Emulate the ISO C mbrtowc() function in terms of the deprecated
+ * 4.4BSD sgetrune() function.
+ */
+size_t
+mbrtowc(wchar_t * __restrict pwc, const char * __restrict s,
+ size_t n, mbstate_t * __restrict ps __unused)
+{
+ const char *e;
+ rune_t r;
+
+ if (s == NULL) {
+ pwc = NULL;
+ s = "";
+ n = 1;
+ }
+
+ if ((r = sgetrune(s, n, &e)) == _INVALID_RUNE) {
+ /*
+ * The design of sgetrune() doesn't give us any way to tell
+ * between incomplete and invalid multibyte sequences.
+ */
+
+ if (n >= (size_t)MB_CUR_MAX) {
+ /*
+ * If we have been supplied with at least MB_CUR_MAX
+ * bytes and still cannot find a valid character, the
+ * data must be invalid.
+ */
+ errno = EILSEQ;
+ return ((size_t)-1);
+ }
+
+ /*
+ * .. otherwise, it's an incomplete character or an invalid
+ * character we cannot detect yet.
+ */
+ return ((size_t)-2);
+ }
+
+ if (pwc != NULL)
+ *pwc = (wchar_t)r;
+
+ return (r != 0 ? (size_t)(e - s) : 0);
+}
diff --git a/emulators/pearpc/files/patch-src::io::prom::fs::hfsplus::unicode.c b/emulators/pearpc/files/patch-src::io::prom::fs::hfsplus::unicode.c
new file mode 100644
index 000000000000..0034da8ce6cd
--- /dev/null
+++ b/emulators/pearpc/files/patch-src::io::prom::fs::hfsplus::unicode.c
@@ -0,0 +1,19 @@
+--- src/io/prom/fs/hfsplus/unicode.c.DIST Thu May 6 10:45:32 2004
++++ src/io/prom/fs/hfsplus/unicode.c Tue May 25 10:06:24 2004
+@@ -28,6 +28,16 @@
+
+ #include "unicode.h"
+
++#ifdef FREEBSD_MB_SUPPORT
++size_t mbrtowc __P((wchar_t * __restrict, const char * __restrict, size_t,
++ mbstate_t * __restrict));
++size_t wcrtomb __P((char * __restrict, wchar_t, mbstate_t * __restrict));
++
++#include "mbrtowc.c"
++#include "wcrtomb.c"
++#endif /* FREEBSD_MB_SUPPORT */
++
++
+ /* convert the asci string astr into a unicode string given by ustr.
+ *
+ * ToDo: Think about better error handling ?
diff --git a/emulators/pearpc/files/wcrtomb.c b/emulators/pearpc/files/wcrtomb.c
new file mode 100644
index 000000000000..c0cb44a23b3d
--- /dev/null
+++ b/emulators/pearpc/files/wcrtomb.c
@@ -0,0 +1,57 @@
+/*-
+ * Copyright (c) 2002, 2003 Tim J. Robbins.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#include <sys/cdefs.h>
+__FBSDID("$FreeBSD$");
+
+#include <errno.h>
+#include <limits.h>
+#include <rune.h>
+#include <stdlib.h>
+#include <wchar.h>
+
+/*
+ * Emulate the ISO C wcrtomb() function in terms of the deprecated
+ * 4.4BSD sputrune() function.
+ */
+size_t
+wcrtomb(char * __restrict s, wchar_t wc,
+ mbstate_t * __restrict ps __unused)
+{
+ char *e;
+ char buf[MB_LEN_MAX];
+
+ if (s == NULL) {
+ s = buf;
+ wc = L'\0';
+ }
+ sputrune(wc, s, MB_CUR_MAX, &e);
+ if (e == NULL) {
+ errno = EILSEQ;
+ return ((size_t)-1);
+ }
+ return ((size_t)(e - s));
+}