aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-07-02 11:11:21 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-07-02 11:11:21 +0000
commit4de98b27e1c752a01f9d725fcc0c80938d27225f (patch)
tree7ef5594c03efe1652c19a6c1396aefa61c12078a
parent8e552b8049f15b9027afbbc1c3bcd7ae51ef92a2 (diff)
downloadports-4de98b27e1c752a01f9d725fcc0c80938d27225f.tar.gz
ports-4de98b27e1c752a01f9d725fcc0c80938d27225f.zip
Notes
-rw-r--r--math/yacas/Makefile23
-rw-r--r--math/yacas/distinfo6
-rw-r--r--math/yacas/files/patch-docs_CMakeLists.txt10
-rw-r--r--math/yacas/pkg-plist8
4 files changed, 20 insertions, 27 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index d8d8ffe6755a..6f0d1c1c2fe1 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,33 +2,32 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.6.0
-PORTREVISION= 4
+PORTVERSION= 1.7.0
+PORTREVISION= 0
DISTVERSIONPREFIX= v
CATEGORIES= math
MAINTAINER= gahr@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LICENSE= GPLv2
+LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-TEST_DEPENDS= bash:shells/bash
+TEST_DEPENDS= bash:shells/bash \
-OPTIONS_DEFINE= DOCS
-DOCS_CMAKE_ON= -DENABLE_DOCS:BOOL=ON \
- -DDOCSDIR:STRING=${DOCSDIR_REL} \
+BUILD_DEPENDS= gtest-config:devel/googletest
+
+CMAKE_ARGS= -DENABLE_DOCS:BOOL=OFF \
-DENABLE_CYACAS_CONSOLE:BOOL=ON \
-DENABLE_CYACAS_KERNEL:BOOL=OFF \
-DENABLE_CYACAS_GUI:BOOL=OFF \
- -DENABLE_JYACAS:BOOL=OFF
-DOCS_BUILD_DEPENDS= sphinx-autogen:textproc/py-sphinx
-
-PORTDOCS= *
+ -DENABLE_JYACAS:BOOL=OFF \
+ -DENABLE_CYACAS_UNIT_TESTS:BOOL=ON \
+ -DENABLE_CYACAS_BENCHMARKS:BOOL=OFF
TEST_TARGET= test
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++17-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= grzegorzmazur
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index 8f2ef0549628..9e4e09621c84 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478519781
-SHA256 (grzegorzmazur-yacas-v1.6.0_GH0.tar.gz) = a6a37b91fde6692e1de13199b764d97ca00a4ce020dc9a31f0e4c6bf4cdb5f0b
-SIZE (grzegorzmazur-yacas-v1.6.0_GH0.tar.gz) = 2498096
+TIMESTAMP = 1561628894
+SHA256 (grzegorzmazur-yacas-v1.7.0_GH0.tar.gz) = 3e56980ca34d527cf1e2d5394e2078313d1a5605559ded3f9997ed8b29325313
+SIZE (grzegorzmazur-yacas-v1.7.0_GH0.tar.gz) = 2610016
diff --git a/math/yacas/files/patch-docs_CMakeLists.txt b/math/yacas/files/patch-docs_CMakeLists.txt
deleted file mode 100644
index 6753623d4df9..000000000000
--- a/math/yacas/files/patch-docs_CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- docs/CMakeLists.txt.orig 2016-05-10 08:39:04 UTC
-+++ docs/CMakeLists.txt
-@@ -38,6 +38,6 @@ add_custom_target(yacas_docs ALL
- COMMENT "Building HTML documentation with Sphinx")
-
- install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}"
-- DESTINATION share/yacas/documentation
-+ DESTINATION ${DOCSDIR}
- COMPONENT doc
- PATTERN ".buildinfo" EXCLUDE)
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index 6bcb8da9bfd1..01b5dda74dff 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -23,10 +23,12 @@ include/yacas/lispobject.h
include/yacas/lispoperator.h
include/yacas/lispparser.h
include/yacas/lispstring.h
-include/yacas/lisptype.h
include/yacas/lispuserfunc.h
include/yacas/mathcommands.h
include/yacas/mathuserfunc.h
+include/yacas/mempool.h
+include/yacas/mp/nn.hpp
+include/yacas/mp/zz.hpp
include/yacas/noncopyable.h
include/yacas/numbers.h
include/yacas/patcher.h
@@ -39,7 +41,6 @@ include/yacas/standard.h
include/yacas/standard.inl
include/yacas/string_utils.h
include/yacas/stringio.h
-include/yacas/stubs.h
include/yacas/substitute.h
include/yacas/tokenizer.h
include/yacas/utf8.h
@@ -50,6 +51,7 @@ include/yacas/xmltokenizer.h
include/yacas/yacas.h
include/yacas/yacas_version.h
lib/libyacas.a
+lib/libyacas_mp.a
%%DATADIR%%/scripts/array.rep/code.ys
%%DATADIR%%/scripts/array.rep/code.ys.def
%%DATADIR%%/scripts/assoc.rep/code.ys
@@ -168,6 +170,8 @@ lib/libyacas.a
%%DATADIR%%/scripts/predicates.rep/code.ys.def
%%DATADIR%%/scripts/probability.rep/code.ys
%%DATADIR%%/scripts/probability.rep/code.ys.def
+%%DATADIR%%/scripts/products.rep/code.ys
+%%DATADIR%%/scripts/products.rep/code.ys.def
%%DATADIR%%/scripts/pslq.rep/code.ys
%%DATADIR%%/scripts/pslq.rep/code.ys.def
%%DATADIR%%/scripts/r_form.rep/code.ys