aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-22 13:32:52 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-22 13:32:52 +0000
commit551b0bd65103a9f2d8f8e161cb0a8442b2da1ab0 (patch)
tree085bc5ed14bdaa5fe74e6e524675e357a49261e8
parentd826d96e5146871be5ff007efc412d7b64c5e59f (diff)
downloadports-551b0bd65103a9f2d8f8e161cb0a8442b2da1ab0.tar.gz
ports-551b0bd65103a9f2d8f8e161cb0a8442b2da1ab0.zip
Notes
-rw-r--r--misc/gkrellweather2/Makefile18
-rw-r--r--misc/gkrellweather2/distinfo2
-rw-r--r--misc/gkrellweather2/files/patch-Makefile42
-rw-r--r--misc/gkrellweather2/files/patch-gkrellweather.c23
-rw-r--r--misc/gkrellweather2/pkg-plist1
5 files changed, 36 insertions, 50 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 319365908960..07094f6eca41 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -3,27 +3,31 @@
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
-# $Id: Makefile,v 1.1.1.1 2002/11/24 03:13:54 jylefort Exp $
#
PORTNAME= gkrellweather
-PORTVERSION= 2.0.5
+PORTVERSION= 2.0.6
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
-MAINTAINER= jylefort@brutele.be
+MAINTAINER= pav@oook.cz
COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
+USE_GMAKE= yes
USE_X_PREFIX= yes
+ALL_TARGET= gkrellweather.so
-MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- MKDIR="${MKDIR}" \
- INSTALL_DATA="${INSTALL_DATA}"
+MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
+ ${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
+ ${MKDIR} ${PREFIX}/share/locale/ru/
+ ${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
.include <bsd.port.mk>
diff --git a/misc/gkrellweather2/distinfo b/misc/gkrellweather2/distinfo
index a12244bbd716..f324ff7c9efc 100644
--- a/misc/gkrellweather2/distinfo
+++ b/misc/gkrellweather2/distinfo
@@ -1 +1 @@
-MD5 (gkrellweather-2.0.5.tgz) = 6b66c920d16b68bd9529f38f203495d3
+MD5 (gkrellweather-2.0.6.tgz) = 458125fe9276db3733a6c4b0e27eca86
diff --git a/misc/gkrellweather2/files/patch-Makefile b/misc/gkrellweather2/files/patch-Makefile
index 579691e8254e..d4212135385b 100644
--- a/misc/gkrellweather2/files/patch-Makefile
+++ b/misc/gkrellweather2/files/patch-Makefile
@@ -1,41 +1,23 @@
---- Makefile.orig Tue Nov 26 19:24:39 2002
-+++ Makefile Fri Dec 13 02:59:14 2002
-@@ -1,6 +1,6 @@
+--- Makefile.orig Mon Mar 31 13:12:57 2003
++++ Makefile Sun Jul 13 13:58:11 2003
+@@ -1,9 +1,9 @@
PKGNAME = gkrellweather
- VERSION = 2.0.5
+ VERSION = 2.0.6
-CFLAGS = -O2 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
+CFLAGS += -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
LIBS = `pkg-config gtk+-2.0 --libs`
LFLAGS = -shared
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
-@@ -8,24 +8,20 @@
+ LOCALEDIR := $(PREFIX)/share/locale
- OBJS = gkrellweather.o
+@@ -20,7 +20,7 @@
-+all: gkrellweather.so
-+
gkrellweather.so: $(OBJS)
-- $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) -lpthread
-+ ${CC} ${OBJS} ${PTHREAD_LIBS} -DVERSION=\"${VERSION}\" -o gkrellweather.so ${LFLAGS} ${LIBS}
+ (cd po && ${MAKE} all )
+- $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) -lpthread
++ $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) ${PTHREAD_LIBS}
clean:
- rm -f *.o core *.so* *.bak *~
-
- gkrellweather.o: gkrellweather.c
-- $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c gkrellweather.c
-+ ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} -DVERSION=\"$(VERSION)\" -c gkrellweather.c
-
- install:
-- if [ -d /usr/lib/gkrellm2/plugins/ ] ; then \
-- install -c -s -m 644 gkrellweather.so /usr/lib/gkrellm2/plugins/ ; \
-- elif [ -d /usr/local/lib/gkrellm2/plugins/ ] ; then \
-- install -c -s -m 644 gkrellweather.so /usr/local/lib/gkrellm2/plugins/ ; \
-- else \
-- install -D -c -s -m 644 gkrellweather.so /usr/local/lib/gkrellm2/plugins/gkrellweather.so ; \
-- fi
-- install -c -m 755 GrabWeather /usr/local/bin
-+ ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
-+ ${INSTALL_DATA} gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
-
- uninstall:
- rm -f /usr/lib/gkrellm2/plugins/gkrellweather.so
+ (cd po && ${MAKE} clean )
diff --git a/misc/gkrellweather2/files/patch-gkrellweather.c b/misc/gkrellweather2/files/patch-gkrellweather.c
index bc8f8d34adaa..78276801fa6d 100644
--- a/misc/gkrellweather2/files/patch-gkrellweather.c
+++ b/misc/gkrellweather2/files/patch-gkrellweather.c
@@ -1,15 +1,6 @@
---- gkrellweather.c.orig Sun Nov 24 04:49:42 2002
-+++ gkrellweather.c Sun Nov 24 04:50:58 2002
-@@ -720,7 +720,7 @@
- options.station[1] = c[1];
- options.station[2] = c[2];
- options.station[3] = c[3];
-- sprintf(options.command, "/usr/local/bin/GrabWeather %s", options.station);
-+ sprintf(options.command, "GrabWeather %s", options.station);
- sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
- getenv("HOME"), options.station);
- net_update = FALSE;
-@@ -981,7 +981,7 @@
+--- gkrellweather.c.orig Mon Mar 31 13:12:57 2003
++++ gkrellweather.c Sun Jul 13 14:30:14 2003
+@@ -983,7 +983,7 @@
options.windspeed_unit = 1;
options.pressure_unit = 1;
strcpy(options.station, DEFAULT_STATION_ID);
@@ -18,3 +9,11 @@
sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
getenv("HOME"), options.station);
}
+@@ -993,6 +993,7 @@
+ gkrellm_init_plugin(void)
+ {
+ #ifdef ENABLE_NLS
++ bindtextdomain(PACKAGE, LOCALEDIR);
+ bind_textdomain_codeset(PACKAGE, "UTF-8");
+ #endif /* ENABLE_NLS */
+ style_id = gkrellm_add_meter_style(&air_mon, STYLE_NAME);
diff --git a/misc/gkrellweather2/pkg-plist b/misc/gkrellweather2/pkg-plist
index de9c697321e6..e016ff2ed65a 100644
--- a/misc/gkrellweather2/pkg-plist
+++ b/misc/gkrellweather2/pkg-plist
@@ -1 +1,2 @@
libexec/gkrellm2/plugins/gkrellweather.so
+share/locale/ru/LC_MESSAGES/gkrellweather.mo