aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-07-06 17:27:41 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-07-06 17:27:41 +0000
commit55a524735cb5f9015e93d734003f9b64917686d7 (patch)
treed2047a81a3f38403bf0492097a8a80d4d1b384eb
parentcc6b9143f857a93a5705022f5adf5cb81dd95892 (diff)
downloadports-55a524735cb5f9015e93d734003f9b64917686d7.tar.gz
ports-55a524735cb5f9015e93d734003f9b64917686d7.zip
Notes
-rw-r--r--devel/adime/Makefile2
-rw-r--r--devel/creduce/Makefile3
-rw-r--r--devel/csmith/Makefile3
-rw-r--r--devel/delta/Makefile2
-rw-r--r--devel/smake/Makefile2
-rw-r--r--dns/adns/Makefile3
-rw-r--r--games/gtklife/Makefile2
-rw-r--r--misc/getopt/Makefile3
-rw-r--r--shells/dash/Makefile3
-rw-r--r--sysutils/x86info/Makefile3
-rw-r--r--x11/xclip/Makefile2
11 files changed, 15 insertions, 13 deletions
diff --git a/devel/adime/Makefile b/devel/adime/Makefile
index 824bb69929c9..19922c26b1cc 100644
--- a/devel/adime/Makefile
+++ b/devel/adime/Makefile
@@ -12,7 +12,7 @@ COMMENT= Generate Allegro dialogs in a very simple way
LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
-USE_GMAKE= yes
+USES= gmake
.include "Makefile.man"
diff --git a/devel/creduce/Makefile b/devel/creduce/Makefile
index 2bb740613863..70937249ab94 100644
--- a/devel/creduce/Makefile
+++ b/devel/creduce/Makefile
@@ -26,9 +26,10 @@ GH_TAGNAME= a2422d5
GH_COMMIT= a2422d5
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PERL5= yes
+USES= gmake
+
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
index c798b42dc1fb..4a82407c3046 100644
--- a/devel/csmith/Makefile
+++ b/devel/csmith/Makefile
@@ -11,13 +11,14 @@ COMMENT= Generates random C programs that conform to the C99 standard
LICENSE= BSD
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USES= gmake
+
MAKE_JOBS_SAFE= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/delta/Makefile b/devel/delta/Makefile
index a24cd1e5aad5..a5b88526fc7c 100644
--- a/devel/delta/Makefile
+++ b/devel/delta/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD
PLIST_FILES= bin/delta bin/multidelta bin/topformflat
-USE_GMAKE= yes
+USES= gmake
MAKE_JOBS_SAFE= yes
do-install:
diff --git a/devel/smake/Makefile b/devel/smake/Makefile
index 29e9cf00879f..288d61c9477e 100644
--- a/devel/smake/Makefile
+++ b/devel/smake/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE_CDDL= ${WRKSRC}/CDDL.Schily.txt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.a.*//g}
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= INS_BASE=${PREFIX} DEFMANBASE=.
MAKE_JOBS_SAFE= yes
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index 9251726e7456..fb444f6d952c 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -12,9 +12,10 @@ COMMENT= Easy to use asynchronous-capable DNS client library and utilities
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
+USES= gmake
+
LIBVERSION= 1
PLIST_SUB+= LIBVERSION="${LIBVERSION}"
diff --git a/games/gtklife/Makefile b/games/gtklife/Makefile
index c03d0bb6e7c1..522113b20069 100644
--- a/games/gtklife/Makefile
+++ b/games/gtklife/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
WANT_GNOME= yes
INSTALLS_ICONS= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" docdir="${DOCSDIR}"
PLIST= ${WRKDIR}/pkg-plist
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index 5d896c50e1ca..900a6dfb6966 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= http://software.frodo.looijaard.name/getopt/files/
MAINTAINER= eadler@FreeBSD.org
COMMENT= Replacement for getopt(1) that supports GNU-style long options
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
diff --git a/shells/dash/Makefile b/shells/dash/Makefile
index aff690fae104..f9bc7966dc3e 100644
--- a/shells/dash/Makefile
+++ b/shells/dash/Makefile
@@ -9,9 +9,10 @@ MAINTAINER= eadler@FreeBSD.org
COMMENT= POSIX-compliant implementation of /bin/sh
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CFLAGS+= -DUNUSABLE_RT_SIGNALS
+USES= gmake
+
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/dash
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 4e9c2725a12f..143152fa782a 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= pci:${PORTSDIR}/devel/libpci
ONLY_FOR_ARCHS= i386 amd64
USE_GCC= any
-USE_GMAKE= yes
+USES= gmake pkgconfig
ALL_TARGET= x86info lsmsr
-USES= pkgconfig
USE_PYTHON_BUILD=yes
MAKE_JOBS_SAFE= yes
diff --git a/x11/xclip/Makefile b/x11/xclip/Makefile
index 8b33c45fc773..7c79206557b6 100644
--- a/x11/xclip/Makefile
+++ b/x11/xclip/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env
USE_XORG= x11 xmu
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes