aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-22 01:28:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-22 01:28:50 +0000
commit566e4787fdba59fb4c1be87d0a028b21a06769e7 (patch)
tree6f8420cc9072276c157e483119b48845206fed78
parente7b04b37f0ba0f4c13ec526f7c791cc911aea78b (diff)
downloadports-566e4787fdba59fb4c1be87d0a028b21a06769e7.tar.gz
ports-566e4787fdba59fb4c1be87d0a028b21a06769e7.zip
MFH: r549539
audio/beatslash-lv2: Fix build on some systems Waf warning about duplicately-installed files somehow caused failure to find some files later. This commit adds the patch to prevent duplicate file installation. This fixes the warning and hopefully fixes poudriere build. I couldn't reproduce this failure in my poudriere. Also: * Strip binarires * Fix WWW Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549552
-rw-r--r--audio/beatslash-lv2/Makefile5
-rw-r--r--audio/beatslash-lv2/files/patch-wscript11
-rw-r--r--audio/beatslash-lv2/pkg-descr2
3 files changed, 15 insertions, 3 deletions
diff --git a/audio/beatslash-lv2/Makefile b/audio/beatslash-lv2/Makefile
index dedbc418ebd1..8e425798fce9 100644
--- a/audio/beatslash-lv2/Makefile
+++ b/audio/beatslash-lv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= beatslash
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -29,4 +29,7 @@ USE_GNOME= atkmm gdkpixbuf2 gtkmm24
post-patch:
@${REINPLACE_CMD} -e 's|#include <lvtk-1/lvtk|#include <lvtk-2/lvtk|' ${WRKSRC}/src/*.?pp
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/beatslash.lv2/*.so
+
.include <bsd.port.mk>
diff --git a/audio/beatslash-lv2/files/patch-wscript b/audio/beatslash-lv2/files/patch-wscript
index b1f94879fcce..49e6ebd1334f 100644
--- a/audio/beatslash-lv2/files/patch-wscript
+++ b/audio/beatslash-lv2/files/patch-wscript
@@ -1,4 +1,4 @@
---- wscript.orig 2016-11-06 20:24:40 UTC
+--- wscript.orig 2019-02-23 21:03:41 UTC
+++ wscript
@@ -31,9 +31,9 @@ def configure(conf):
autowaf.check_pkg(conf, 'gtk+-2.0', uselib_store='GTK2', atleast_version='2.24.0')
@@ -13,3 +13,12 @@
check = 'Extended Initializer Lists'
conf.check_cxx(msg = check,
+@@ -78,7 +78,7 @@ def build_plugin(bld, bundle, name, source, cxxflags=[
+
+ # Install data file
+ data_file = '%s.ttl' % name
+- bld.install_files('${LV2DIR}/' + bundle, os.path.join(bundle, data_file))
++ #bld.install_files('${LV2DIR}/' + bundle, os.path.join(bundle, data_file)) # see https://github.com/blablack/beatslash-lv2/issues/9
+
+
+ def build_plugin_gui(bld, bundle, name, source, cxxflags=[], libs=[], add_source=[]):
diff --git a/audio/beatslash-lv2/pkg-descr b/audio/beatslash-lv2/pkg-descr
index 52fddad49463..396fa36d78a9 100644
--- a/audio/beatslash-lv2/pkg-descr
+++ b/audio/beatslash-lv2/pkg-descr
@@ -4,4 +4,4 @@ Features:
* the beat repeater will repeat the current beat
* the beat slicer will randomly repeat parts of a live sample
-WWW: https://objectivewave.wordpress.com/beatslash-lv2/
+WWW: https://github.com/blablack/beatslash-lv2