aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2005-02-09 10:57:39 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2005-02-09 10:57:39 +0000
commit5ac5b0d5698b99a4ef201ae6cf9934eaef38ebea (patch)
tree170d8a42d864f1c30590f1dccbf8ec98f64907f0
parent41d3d54a7b0384037f3aa79700adb016b4416158 (diff)
downloadports-5ac5b0d5698b99a4ef201ae6cf9934eaef38ebea.tar.gz
ports-5ac5b0d5698b99a4ef201ae6cf9934eaef38ebea.zip
Notes
-rw-r--r--comms/Makefile1
-rw-r--r--comms/pyla/Makefile52
-rw-r--r--comms/pyla/distinfo2
-rw-r--r--comms/pyla/files/pyla.sh3
-rw-r--r--comms/pyla/pkg-descr14
5 files changed, 72 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index fe9a5cf6330f..df2a3b3bcf3e 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -68,6 +68,7 @@
SUBDIR += py-bulksms
SUBDIR += py-lirc
SUBDIR += py-serial
+ SUBDIR += pyla
SUBDIR += qico
SUBDIR += qicosi
SUBDIR += qpage
diff --git a/comms/pyla/Makefile b/comms/pyla/Makefile
new file mode 100644
index 000000000000..59fd8d1db29b
--- /dev/null
+++ b/comms/pyla/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: pylafax
+# Date created: 6 January 2005
+# Whom: Michael Reifenberger (mike@Reifenberger.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyla
+PORTVERSION= 1.1.4
+CATEGORIES= comms python
+MASTER_SITES= http://www.teamsw.it/pyla/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyla${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mike@Reifenberger.com
+COMMENT= Hylafax client written in Python
+
+#LIB_DEPENDS= lirc_client.0:${PORTSDIR}/comms/lirc
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+DATADIR= ${PREFIX}/lib/pyla
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ @(cd ${FILESDIR} && ${CP} pyla.sh ${WRKDIR})
+ @(cd ${WRKDIR} && ${REINPLACE_CMD} \
+ -e "s|%%PREFIX%%|${PREFIX}|g;" \
+ -e "s|%%PYTHON_CMD%%|${PYTHON_CMD}|g;" \
+ pyla.sh)
+ @(cd ${WRKSRC} && ${CP} language.en language.db)
+
+pre-install:
+ @${ECHO_CMD} '@exec ${MKDIR} %D/lib/pyla' > ${PLIST}
+ @${ECHO_CMD} 'bin/pyla' >> ${PLIST}
+ @${FIND} ${WRKSRC}/ -type f | \
+ ${SED} -e "s:^${WRKSRC}/:lib/pyla/:g" >> ${PLIST}
+ @${FIND} -d ${WRKSRC} -type d | \
+ ${SED} -e "s:^${WRKSRC}:@dirrm lib/pyla:g" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL} -m755 ${WRKDIR}/pyla.sh ${PREFIX}/bin/pyla
+ ${TAR} -C ${WRKSRC} --exclude CVS -cf - . | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
+
+.include <bsd.port.post.mk>
diff --git a/comms/pyla/distinfo b/comms/pyla/distinfo
new file mode 100644
index 000000000000..02affc822650
--- /dev/null
+++ b/comms/pyla/distinfo
@@ -0,0 +1,2 @@
+MD5 (pyla1.1.4.tgz) = 7a0743561ca8c274c69eba9c2bfdf3e7
+SIZE (pyla1.1.4.tgz) = 279531
diff --git a/comms/pyla/files/pyla.sh b/comms/pyla/files/pyla.sh
new file mode 100644
index 000000000000..d5610078c8b9
--- /dev/null
+++ b/comms/pyla/files/pyla.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%PYTHON_CMD%% %%PREFIX%%/lib/pyla/pyla.py
diff --git a/comms/pyla/pkg-descr b/comms/pyla/pkg-descr
new file mode 100644
index 000000000000..388829a02208
--- /dev/null
+++ b/comms/pyla/pkg-descr
@@ -0,0 +1,14 @@
+What's Pyla Project?
+ Pyla wants to be a new Hylafax client entirely
+ written using the Python interpreter.
+
+What can I do with Pyla?
+ With Pyla you can basically send and manage faxes.
+ It actually mimics WHFC in its interface so if you like WHFC,
+ you'll probably feel comfortable with Pyla too.
+
+Why should I use Pyla?
+ There're a lot of Hylafax clients out there,
+ Pyla's main advantage is probably its platform independence.
+
+WWW: http://www.teamsw.it/pyla/