aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-09-19 13:23:30 +0000
committerRene Ladan <rene@FreeBSD.org>2020-09-19 13:23:30 +0000
commit5dbcb34327b5c9df97f303ec4357c58d763ec640 (patch)
tree4d7412981c1f28b62edd7957e5c5a1a2ea5cf93f
parent810d8434b3274a5a9f1dc4f173c710f9f0cb83de (diff)
downloadports-5dbcb34327b5c9df97f303ec4357c58d763ec640.tar.gz
ports-5dbcb34327b5c9df97f303ec4357c58d763ec640.zip
MFH: r548951
net/aslookup: unexpire by updating to 0.13d - Various fixes are performed, by Chris, dinoex and myself. - MASTER_SITES and WWW changed to a new home. - AS queries are now ran against whois.epoch.net, the former server went offline. - Hand over maintainership to Chris PR: 246187 Submitted by: Chris Hutchinson Approved by: previous maintainer Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=548985
-rw-r--r--net/aslookup/Makefile18
-rw-r--r--net/aslookup/distinfo5
-rw-r--r--net/aslookup/files/patch-Makefile47
-rw-r--r--net/aslookup/files/patch-aslookup.c287
-rw-r--r--net/aslookup/pkg-descr14
5 files changed, 296 insertions, 75 deletions
diff --git a/net/aslookup/Makefile b/net/aslookup/Makefile
index 230483448b11..b8f45593788c 100644
--- a/net/aslookup/Makefile
+++ b/net/aslookup/Makefile
@@ -2,25 +2,19 @@
# $FreeBSD$
PORTNAME= aslookup
-PORTVERSION= 0.12
-PORTREVISION= 1
+PORTVERSION= 0.13d
CATEGORIES= net
-MASTER_SITES= http://www.bugest.net/software/aslookup/
-DISTNAME= ${PORTNAME}-alpha${PORTVERSION}
+MASTER_SITES= http://aslookup.bgpview.org/download/ \
+ https://BSDforce.com/source/net/aslookup/
+DISTNAME= ${PORTNAME}-beta${PORTVERSION}
-MAINTAINER= jmohacsi@bsd.hu
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Tool that searches the sequence of AS numbers
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
+CFLAGS+= -DARINDB -DJPNICDB -DAPNICDB
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -E -e "s|CFLAGS.*=|CFLAGS +=|" \
- -e "s|CC.*=|CC ?=|" ${WRKSRC}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/aslookup ${STAGEDIR}${PREFIX}/bin
@if [ ! -d ${STAGEDIR}${PREFIX}/share/doc/aslookup ]; then \
diff --git a/net/aslookup/distinfo b/net/aslookup/distinfo
index 7e7b8981bab2..7346618adeed 100644
--- a/net/aslookup/distinfo
+++ b/net/aslookup/distinfo
@@ -1,2 +1,3 @@
-SHA256 (aslookup-alpha0.12.tar.gz) = b5bbbf48dad6f2133078b060dae59afc12ee82ff326088458c5953f2a476c3d6
-SIZE (aslookup-alpha0.12.tar.gz) = 12979
+TIMESTAMP = 1590002488
+SHA256 (aslookup-beta0.13d.tar.gz) = bed372c27329cc87e2438c19015695ca16586e4083ae73f54fd92471fc506a35
+SIZE (aslookup-beta0.13d.tar.gz) = 12986
diff --git a/net/aslookup/files/patch-Makefile b/net/aslookup/files/patch-Makefile
index 26a1caf5365a..8d41786fbe85 100644
--- a/net/aslookup/files/patch-Makefile
+++ b/net/aslookup/files/patch-Makefile
@@ -1,11 +1,42 @@
---- ./Makefile.orig Wed Apr 5 05:36:20 2000
-+++ ./Makefile Wed Nov 9 22:52:32 2005
-@@ -34,7 +34,7 @@
- # CFLAGS = -DJPIXDB -DJPNICDB -DAPNICDB
- # CFLAGS = -DRALOCAL -DJPNICDB -DAPNICDB
- # CFLAGS = -DJPNICDB -DAPNICDB -DLOG -DSOLARIS
--CFLAGS = -DARINDB -DJPNICDB -DAPNICDB -DLOG -DDEBUG
-+CFLAGS = -DARINDB -DJPNICDB -DAPNICDB
+--- Makefile.orig 2009-09-20 11:00:57 UTC
++++ Makefile
+@@ -2,9 +2,9 @@
+ # Makefile,v 1.7 2005/12/07 02:57:18 kuniaki Exp
+
+ PROGS = aslookup
+-VERSION = beta0.13c
++VERSION = beta0.13d
+ DISTNAME = $(PROGS)-$(VERSION)
+-CVSTAG = b013c
++CVSTAG = b013d
+ CVS_COMMAND = cvs
+ INSTALLCMD = /usr/bin/install
+
+@@ -22,7 +22,7 @@ TARCMD =/usr/bin/tar
+ SHELL =/bin/sh
+ .SUFFIXES: .c .o
+
+-CC = gcc
++CC ?= gcc
+
+ BINDIR =/usr/local/bin
+
+@@ -34,12 +34,12 @@ MANDIR =/usr/local/man/man1
+ # if you have radb mirror server (trawhois), you specify RALOCAL flag.
+ # Because aslookup will use local radb server.
+ # AND, If you are using solaris, Please add option "-DSOLARIS".
+-# CFLAGS =
+-# CFLAGS = -DJPIXDB -DJPNICDB -DAPNICDB -g -O
+-CFLAGS = -DRALOCAL -DJPNICDB -DAPNICDB -g -O
+-# CFLAGS = -DJPNICDB -DAPNICDB -DLOG -DSOLARIS -g -O
+-# CFLAGS = -DARINDB -DJPNICDB -DAPNICDB -DLOG -DDEBUG -g -O
+-# CFLAGS = -DARINDB -DJPNICDB -DAPNICDB -g -O
++# CFLAGS +=
++# CFLAGS += -DJPIXDB -DJPNICDB -DAPNICDB -g -O
++# CFLAGS += -DRALOCAL -DJPNICDB -DAPNICDB -g -O
++# CFLAGS += -DJPNICDB -DAPNICDB -DLOG -DSOLARIS -g -O
++# CFLAGS += -DARINDB -DJPNICDB -DAPNICDB -DLOG -DDEBUG -g -O
++# CFLAGS += -DARINDB -DJPNICDB -DAPNICDB -g -O
INCDIR = -I./
# This line is for solaris.
diff --git a/net/aslookup/files/patch-aslookup.c b/net/aslookup/files/patch-aslookup.c
index b594d27a4ec8..6756a78290a4 100644
--- a/net/aslookup/files/patch-aslookup.c
+++ b/net/aslookup/files/patch-aslookup.c
@@ -1,56 +1,251 @@
---- ./aslookup.c.orig Wed Apr 5 05:35:56 2000
-+++ ./aslookup.c Wed Nov 9 22:53:13 2005
-@@ -249,7 +249,7 @@
- break;
- case 'C':
+--- aslookup.c.orig 2009-09-20 11:00:21 UTC
++++ aslookup.c
+@@ -48,12 +48,12 @@
+ #include <time.h>
+ #include <stdlib.h>
+
+-#define VERSION "ASLookup Beta Version 0.13"
++#define VERSION "ASLookup Beta Version 0.13d"
+ #define COPYRIGHT "Copyright (C) 1998 - 2000 K.Kondo, Internet Initiative Japan Inc.\r\nCopyright (c) 2005 K.Kondo, Bugest-Network"
+ #define REVISION "aslookup.c,v 1.7 2005/12/07 02:56:35 kuniaki Exp"
+
+ #ifdef RALOCAL
+-#define RADB "bvtest.bugest.net"
++#define RADB "whois.epoch.net"
+ #define WHOIS 43
+ #endif /* _ifedef RALOCAL */
+ #ifndef RALOCAL
+@@ -109,7 +109,7 @@ char *connecthost;
+ }
+ #endif /* _ifdef LOG */
+
+-int dbopen()
++void dbopen()
+ {
+ struct hostent *hp;
+ struct sockaddr_in sin;
+@@ -137,14 +137,14 @@ int dbopen()
+ #endif
+ }
+
+-int dbclose()
++void dbclose()
+ {
+ write(sc, "q\n", 2);
+ close(sc);
+
+ }
+
+-int batchmode()
++void batchmode()
+ {
+ write(sc, "!!\n", 3);
+ }
+@@ -198,7 +198,7 @@ char *type;
+ return(ret);
+ }
+
+-int sread(buf, len)
++void sread(buf, len)
+ char *buf;
+ int len;
+ {
+@@ -285,7 +285,7 @@ u_long asn;
+ char asstr[128];
+ char *data;
+
+- sprintf(asstr, "!man,AS%d\n", asn);
++ sprintf(asstr, "!man,AS%lu\n", asn);
+
#ifdef DEBUG
-- printf("Compleate\n");
-+ printf("Complete\n");
+ printf("Command : %s", asstr);
+@@ -512,7 +512,7 @@ char *retc;
+ connectlog(JPWHOIS);
+ #endif
+
+- sprintf(line, "AS%d\n", asn);
++ sprintf(line, "AS%lu\n", asn);
+ write(jpsoc,line,strlen(line));
+
+ jpfd = fdopen(jpsoc, "r");
+@@ -571,7 +571,7 @@ char *retc;
+ connectlog(APWHOIS);
+ #endif
+
+- sprintf(line, "AS%d\n", asn);
++ sprintf(line, "AS%lu\n", asn);
+ write(apsoc,line,strlen(line));
+
+ apfd = fdopen(apsoc, "r");
+@@ -686,7 +686,7 @@ char *retc;
+ connectlog(JIWHOIS);
#endif
- stop = 1;
- break;
-@@ -936,7 +936,7 @@
- if (strncmp(&line[3], " ", 7) == 0) {
+- sprintf(line, "AS%d\n", asn);
++ sprintf(line, "AS%lu\n", asn);
+ write(jisoc,line,strlen(line));
+
+ jifd = fdopen(jisoc, "r");
+@@ -710,7 +710,7 @@ char *retc;
+ }
+ #endif /* _JPIXDB */
+
+-int searchas(aslist)
++void searchas(aslist)
+ char *aslist;
+ {
+ char aslistbuf[1024];
+@@ -738,7 +738,7 @@ char *aslist;
#ifdef DEBUG
-- printf("Old Data Concatinate\n");
-+ printf("Old Data Concatenate\n");
- #endif
- bzero(buf,40);
- strncpy(buf, pathcache.data, 3);
-@@ -952,7 +952,7 @@
- printf("%s:\n",pathcache.data);
- searchas(pathcache.pathstr);
+ printf("DEBUG: descr field not found\n");
+ #endif
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ }
+ #ifdef DEBUG
+ printf("DB Type -> RPSL?\n");
+@@ -771,7 +771,7 @@ char *aslist;
+ if (desce != NULL) {
+ *desce = '\0';
+ }
+- printf(" AS%d:%s\n", asnum, descs);
++ printf(" AS%lu:%s\n", asnum, descs);
+ }
+ free(obj);
} else {
-- printf("%s: Dplicated AS Path\n",pathcache.data);
-+ printf("%s: Duplicated AS Path\n",pathcache.data);
- }
+@@ -779,7 +779,7 @@ char *aslist;
+
+ #ifdef JPIXDB
+ if (jpix(asnum, &asname) != NULL) {
+- printf(" AS%d:%s\n", asnum, asname);
++ printf(" AS%lu:%s\n", asnum, asname);
+ } else {
+ #endif
+ #ifdef ARINDB
+@@ -790,7 +790,7 @@ char *aslist;
+ #ifdef JPNICDB
+ if (strcmp(asname, JPNICTAG) == 0) {
+ if (jpnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (JPNIC)\n",
++ printf(" AS%lu:%s (JPNIC)\n",
+ asnum, asname);
+ fg = 1;
+ } else {
+@@ -801,7 +801,7 @@ char *aslist;
+ #ifdef APNICDB
+ if (strcmp(asname, APNICTAG) == 0) {
+ if (apnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (APNIC)\n",
++ printf(" AS%lu:%s (APNIC)\n",
+ asnum, asname);
+ fg = 1;
+ } else {
+@@ -811,11 +811,11 @@ char *aslist;
+ #endif
+ if (strlen(asname) != 0) {
+ if (fg == 0) {
+- printf(" AS%d:%s (ARIN)\n",
++ printf(" AS%lu:%s (ARIN)\n",
+ asnum, asname);
+ }
+ } else {
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ }
+ }
+ #endif /* ARINDB */
+@@ -823,11 +823,11 @@ char *aslist;
+ #ifdef JPNICDB
+ #ifdef APNICDB
+ if (jpnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (JPNIC)\n", asnum, asname);
++ printf(" AS%lu:%s (JPNIC)\n", asnum, asname);
+ } else if (apnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (APNIC)\n", asnum, asname);
++ printf(" AS%lu:%s (APNIC)\n", asnum, asname);
+ } else {
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ }
+ #endif
+ #endif
+@@ -835,9 +835,9 @@ char *aslist;
+ #ifdef JPNICDB
+ #ifndef APNICDB
+ if (jpnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (JPNIC)\n", asnum, asname);
++ printf(" AS%lu:%s (JPNIC)\n", asnum, asname);
+ } else {
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ }
+ #endif
+ #endif
+@@ -845,16 +845,16 @@ char *aslist;
+ #ifndef JPNICDB
+ #ifdef APNICDB
+ if (apnic(asnum, &asname) != NULL) {
+- printf(" AS%d:%s (APNIC)\n", asnum, asname);
++ printf(" AS%lu:%s (APNIC)\n", asnum, asname);
+ } else {
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ }
+ #endif
+ #endif
+
+ #ifndef JPNICDB
+ #ifndef APNICDB
+- printf(" AS%d:????????\n", asnum);
++ printf(" AS%lu:????????\n", asnum);
+ #endif
+ #endif
+
+@@ -906,7 +906,7 @@ ASPATHCACHE *data;
+ return(ret);
+ }
+
+-int freecache()
++void freecache()
+ {
+ ASPATHCACHE *ptr;
+
+@@ -918,7 +918,7 @@ int freecache()
}
- freecache();
-@@ -987,7 +987,7 @@
+ }
- if (strncmp(&line[3], " ", 7) == 0) {
- #ifdef DEBUG
-- printf("Old Data Concatinate: %s\n",olddata);
-+ printf("Old Data Concatenate: %s\n",olddata);
- #endif
- if (strlen(olddata) > 0) {
- bzero(buf,40);
-@@ -1007,7 +1007,7 @@
- printf("%s:\n",pathcache.data);
- searchas(pathcache.pathstr);
- } else {
-- printf("%s: Dplicated AS Path\n",pathcache.data);
-+ printf("%s: Duplicated AS Path\n",pathcache.data);
- }
+-int parsestdin()
++void parsestdin()
+ {
+
+ char line[2048];
+@@ -1020,6 +1020,7 @@ char *fname;
}
fclose(fp);
-@@ -1034,7 +1034,7 @@
- if (a == 0) {
- hp = gethostbyname(hn);
- if (hp == NULL) {
-- printf("Could not resolv : %s\n",hn);
-+ printf("Could not resolve : %s\n",hn);
- return(1);
+ freecache();
++ return(0);
+ }
+
+ int host2as(hn)
+@@ -1065,7 +1066,7 @@ char *hn;
+ #endif
+
+ if (getas(adstr, &getasnum) == 0) {
+- printf("% Search Fail\n");
++ printf("%% Search Fail\n");
+ } else {
+ #ifdef DEBUG
+ printf("Search AS : %s\n",getasnum);
+@@ -1088,10 +1089,11 @@ char *hn;
+ asptr++;
}
- bzero(&sin, sizeof(struct sockaddr_in));
+ }
++ return(0);
+ }
+
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {
diff --git a/net/aslookup/pkg-descr b/net/aslookup/pkg-descr
index 0fea1e428b1f..35a1978b2e8c 100644
--- a/net/aslookup/pkg-descr
+++ b/net/aslookup/pkg-descr
@@ -1,11 +1,11 @@
-ASLOOKUP is the tool which searches the sequence of AS number specified
+ASLOOKUP is the tool which searches the sequence of the AS number specified
with the parameter from IRR and indicates the first line of Description
-of AS Object.
+of the AS Object.
Advantages:
-You can search many AS Numbers at one time.
-You can use result of "show ip bgp" command with CISCO router.
-You can search to ARIN, JPNIC and APNIC whois dabase.
-You can srarch AS Number from IP Addresses.
+You can search many AS Numbers at once.
+You can use result of "show ip bgp" command with a CISCO router.
+You can search to ARIN, JPNIC and APNIC whois database.
+You can search AS Number from IP Addresses.
-WWW: http://www.bugest.net/software/aslookup/index-e.html
+WWW: http://aslookup.bgpview.org/index-e.html