aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-30 11:17:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-30 11:17:28 +0000
commit5fe9d07c3d5ee1a8bf3d9fe02a1557e3f6db37fc (patch)
tree5cbcfaf1a8858c2ea3a820bbe15b3eaed4cfd2a0
parenta9062613b4d51fb02d1d187327bfbc6791214e42 (diff)
downloadports-5fe9d07c3d5ee1a8bf3d9fe02a1557e3f6db37fc.tar.gz
ports-5fe9d07c3d5ee1a8bf3d9fe02a1557e3f6db37fc.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/jave6/Makefile40
-rw-r--r--graphics/jave6/distinfo3
-rw-r--r--graphics/jave6/pkg-descr4
-rw-r--r--graphics/jave6/pkg-plist311
5 files changed, 359 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 30db6296f404..d8efe7a2fe87 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -288,6 +288,7 @@
SUBDIR += ivtools
SUBDIR += jalbum
SUBDIR += jasper
+ SUBDIR += jave6
SUBDIR += jbigkit
SUBDIR += jdraw
SUBDIR += jgraph
diff --git a/graphics/jave6/Makefile b/graphics/jave6/Makefile
new file mode 100644
index 000000000000..4f7556713200
--- /dev/null
+++ b/graphics/jave6/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: Jave
+# Date created: 29 January 2006
+# Whom: Andreas Daehn <ad001@uni-rostock.de>
+#
+# $FreeBSD$
+
+PORTNAME= jave6
+PORTVERSION= 0.1
+CATEGORIES= graphics java
+MASTER_SITES= http://www.jave.de/developer/\
+ http://ikaria.inf.fsr.uni-rostock.de/freebsd_public/
+DISTNAME= jave_6.0_i20060105
+EXTRACT_SUFX= .zip
+
+MAINTAINER= ad001@uni-rostock.de
+COMMENT= Java ASCII-Art-Generator
+
+USE_JAVA= YES
+USE_ZIP= YES
+JAVA_VERSION= 1.3+
+NO_BUILD= YES
+JARTARGETDIR= ${TARGETDIR}/jave6
+LNKTARGET= ${TARGETDIR}/bin/jave6
+HLPSKRIPT= jave6
+
+do-install:
+ @${ECHO} "Installing JavE6 files in ${JARTARGETDIR}..."
+ @${MKDIR} ${JARTARGETDIR}
+ @${CP} -rv ${WRKDIR}/* ${JARTARGETDIR}
+ @${ECHO} "creating start script ${LNKTARGET}..."
+ @${ECHO} "#!/bin/sh" > ${JARTARGETDIR}/${HLPSKRIPT}
+ @${ECHO} ${JAVA_HOME}/bin/java -jar ${JARTARGETDIR}/jave.jar >> ${JARTARGETDIR}/${HLPSKRIPT}
+ @${CHMOD} a+x ${JARTARGETDIR}/${HLPSKRIPT}
+ @${LN} -sf ${JARTARGETDIR}/${HLPSKRIPT} ${LNKTARGET}
+ @${ECHO} "done."
+
+post-install:
+ @${ECHO} "Errors may occur while running the program, as it will try to access ${JARTARGETDIR}/tmp/ for output."
+
+.include <bsd.port.mk>
diff --git a/graphics/jave6/distinfo b/graphics/jave6/distinfo
new file mode 100644
index 000000000000..2e13af531bcc
--- /dev/null
+++ b/graphics/jave6/distinfo
@@ -0,0 +1,3 @@
+MD5 (jave_6.0_i20060105.zip) = 56fa3d88af315e35447f6b14352a0b9b
+SHA256 (jave_6.0_i20060105.zip) = bc2bc9a0d5aa5ad6666ca68622cc55b837093b1a280101274555ad70d0f5097f
+SIZE (jave_6.0_i20060105.zip) = 2377689
diff --git a/graphics/jave6/pkg-descr b/graphics/jave6/pkg-descr
new file mode 100644
index 000000000000..7a005a653ac7
--- /dev/null
+++ b/graphics/jave6/pkg-descr
@@ -0,0 +1,4 @@
+The Jave project is a Java based ASCII-Art-graphic editor. I allows drawing
+new images as well as converting JPG-Images to ASCII-Art.
+
+WWW: http://www.jave.de/
diff --git a/graphics/jave6/pkg-plist b/graphics/jave6/pkg-plist
new file mode 100644
index 000000000000..06c64b24b950
--- /dev/null
+++ b/graphics/jave6/pkg-plist
@@ -0,0 +1,311 @@
+bin/jave6
+jave6/changes.txt
+jave6/clipart/animals.jcf
+jave6/clipart/chemistry.jcf
+jave6/clipart/clouds.jcf
+jave6/clipart/electronic.jcf
+jave6/clipart/flags.jcf
+jave6/clipart/glasses.jcf
+jave6/clipart/hands.jcf
+jave6/clipart/holiday.jcf
+jave6/clipart/logos.jcf
+jave6/clipart/misc.jcf
+jave6/clipart/planes.jcf
+jave6/clipart/plants.jcf
+jave6/clipart/politic.jcf
+jave6/clipart/shapes.jcf
+jave6/clipart/signs.jcf
+jave6/config/charsets.txt
+jave6/config/convert.txt
+jave6/config/convert_thick.txt
+jave6/config/general.txt
+jave6/config/gradients.txt
+jave6/config/greyscaletables/_courier new.jgt
+jave6/config/greyscaletables/andale mono.jgt
+jave6/config/greyscaletables/courier german (daisywheel).jgt
+jave6/config/greyscaletables/crystal.jgt
+jave6/config/greyscaletables/elite german (daisywheel).jgt
+jave6/config/greyscaletables/elronet monospace.jgt
+jave6/config/greyscaletables/fixedsys.jgt
+jave6/config/greyscaletables/hyperfont.jgt
+jave6/config/greyscaletables/lucida console.jgt
+jave6/config/greyscaletables/monaco.jgt
+jave6/config/greyscaletables/monotype.jgt
+jave6/config/greyscaletables/ms gothic.jgt
+jave6/config/greyscaletables/netextmo.jgt
+jave6/config/greyscaletables/ocr a.jgt
+jave6/config/greyscaletables/ocr b.jgt
+jave6/config/greyscaletables/pica german (daisywheel).jgt
+jave6/config/greyscaletables/readme.txt
+jave6/config/greyscaletables/terminal.jgt
+jave6/config/greyscaletables/topaz new.jgt
+jave6/config/greyscaletables/vt8x13.jgt
+jave6/config/greyscaletables/web hebrew monospace.jgt
+jave6/config/mix.txt
+jave6/config/repair.txt
+jave6/config/replace_illegal.txt
+jave6/fonts/1row.flf
+jave6/fonts/3-d.flf
+jave6/fonts/3d_diagonal.flf
+jave6/fonts/3x5.flf
+jave6/fonts/4max.flf
+jave6/fonts/5lineoblique.flf
+jave6/fonts/B1FF.flf
+jave6/fonts/DANC4.flf
+jave6/fonts/Georgia11.flf
+jave6/fonts/acrobatic.flf
+jave6/fonts/alligator.flf
+jave6/fonts/alligator2.flf
+jave6/fonts/alligator3.flf
+jave6/fonts/alpha.flf
+jave6/fonts/alphabet.flf
+jave6/fonts/amc3line.flf
+jave6/fonts/amc3liv1.flf
+jave6/fonts/amcaaa01.flf
+jave6/fonts/amcneko.flf
+jave6/fonts/amcrazo2.flf
+jave6/fonts/amcrazor.flf
+jave6/fonts/amcslash.flf
+jave6/fonts/amcslder.flf
+jave6/fonts/amcthin.flf
+jave6/fonts/amctubes.flf
+jave6/fonts/amcun1.flf
+jave6/fonts/arrows.flf
+jave6/fonts/ascii_new_roman.flf
+jave6/fonts/avatar.flf
+jave6/fonts/banner.flf
+jave6/fonts/banner3-D.flf
+jave6/fonts/banner3.flf
+jave6/fonts/banner4.flf
+jave6/fonts/barbwire.flf
+jave6/fonts/basic.flf
+jave6/fonts/bell.flf
+jave6/fonts/benjamin.flf
+jave6/fonts/big.flf
+jave6/fonts/bigchief.flf
+jave6/fonts/bigfig.flf
+jave6/fonts/binary.flf
+jave6/fonts/block.flf
+jave6/fonts/blocks.flf
+jave6/fonts/bolger.flf
+jave6/fonts/braced.flf
+jave6/fonts/bright.flf
+jave6/fonts/broadway.flf
+jave6/fonts/bubble.flf
+jave6/fonts/bulbhead.flf
+jave6/fonts/calgphy2.flf
+jave6/fonts/caligraphy.flf
+jave6/fonts/cards.flf
+jave6/fonts/categories.txt
+jave6/fonts/categoriestree.txt
+jave6/fonts/catwalk.flf
+jave6/fonts/chiseled.flf
+jave6/fonts/chunky.flf
+jave6/fonts/coinstak.flf
+jave6/fonts/colossal.flf
+jave6/fonts/computer.flf
+jave6/fonts/contessa.flf
+jave6/fonts/contrast.flf
+jave6/fonts/cosmic.flf
+jave6/fonts/cosmike.flf
+jave6/fonts/crawford.flf
+jave6/fonts/crazy.flf
+jave6/fonts/cricket.flf
+jave6/fonts/cyberlarge.flf
+jave6/fonts/cybermedium.flf
+jave6/fonts/cybersmall.flf
+jave6/fonts/dancingfont.flf
+jave6/fonts/decimal.flf
+jave6/fonts/defleppard.flf
+jave6/fonts/diamond.flf
+jave6/fonts/digital.flf
+jave6/fonts/doh.flf
+jave6/fonts/doom.flf
+jave6/fonts/dosrebel.flf
+jave6/fonts/dotmatrix.flf
+jave6/fonts/double.flf
+jave6/fonts/doubleshorts.flf
+jave6/fonts/drpepper.flf
+jave6/fonts/dwhistled.flf
+jave6/fonts/eftichess.flf
+jave6/fonts/eftifont.flf
+jave6/fonts/eftipiti.flf
+jave6/fonts/eftirobot.flf
+jave6/fonts/eftitalic.flf
+jave6/fonts/eftiwall.flf
+jave6/fonts/eftiwater.flf
+jave6/fonts/epic.flf
+jave6/fonts/fender.flf
+jave6/fonts/files.txt
+jave6/fonts/fire_font-k.flf
+jave6/fonts/fire_font-s.flf
+jave6/fonts/flowerpower.flf
+jave6/fonts/fonts_readme.txt
+jave6/fonts/fourtops.flf
+jave6/fonts/fraktur.flf
+jave6/fonts/funface.flf
+jave6/fonts/funfaces.flf
+jave6/fonts/fuzzy.flf
+jave6/fonts/georgi16.flf
+jave6/fonts/ghost.flf
+jave6/fonts/ghoulish.flf
+jave6/fonts/glenyn.flf
+jave6/fonts/goofy.flf
+jave6/fonts/gothic.flf
+jave6/fonts/graceful.flf
+jave6/fonts/gradient.flf
+jave6/fonts/graffiti.flf
+jave6/fonts/greek.flf
+jave6/fonts/heart_left.flf
+jave6/fonts/heart_right.flf
+jave6/fonts/henry3d.flf
+jave6/fonts/hex.flf
+jave6/fonts/hieroglyphs.flf
+jave6/fonts/hollywood.flf
+jave6/fonts/impossible.flf
+jave6/fonts/invita.flf
+jave6/fonts/isometric1.flf
+jave6/fonts/isometric2.flf
+jave6/fonts/isometric3.flf
+jave6/fonts/isometric4.flf
+jave6/fonts/italic.flf
+jave6/fonts/ivrit.flf
+jave6/fonts/jacky.flf
+jave6/fonts/jazmine.flf
+jave6/fonts/jerusalem.flf
+jave6/fonts/katakana.flf
+jave6/fonts/kban.flf
+jave6/fonts/keyboard.flf
+jave6/fonts/konto.flf
+jave6/fonts/kontoslant.flf
+jave6/fonts/larry3d.flf
+jave6/fonts/lcd.flf
+jave6/fonts/lean.flf
+jave6/fonts/letters.flf
+jave6/fonts/lildevil.flf
+jave6/fonts/lineblocks.flf
+jave6/fonts/linux.flf
+jave6/fonts/lockergnome.flf
+jave6/fonts/lower.flc
+jave6/fonts/madrid.flf
+jave6/fonts/marquee.flf
+jave6/fonts/maxfour.flf
+jave6/fonts/mike.flf
+jave6/fonts/mini.flf
+jave6/fonts/mirror.flf
+jave6/fonts/mnemonic.flf
+jave6/fonts/morse.flf
+jave6/fonts/morse2.flf
+jave6/fonts/moscow.flf
+jave6/fonts/mshebrew210.flf
+jave6/fonts/nancyj-fancy.flf
+jave6/fonts/nancyj-improved.flf
+jave6/fonts/nancyj-underlined.flf
+jave6/fonts/nancyj.flf
+jave6/fonts/nipples.flf
+jave6/fonts/nscript.flf
+jave6/fonts/ntgreek.flf
+jave6/fonts/null.flc
+jave6/fonts/nvscript.flf
+jave6/fonts/o8.flf
+jave6/fonts/octal.flf
+jave6/fonts/ogre.flf
+jave6/fonts/oldbanner.flf
+jave6/fonts/os2.flf
+jave6/fonts/pawp.flf
+jave6/fonts/peaks.flf
+jave6/fonts/peaksslant.flf
+jave6/fonts/pebbles.flf
+jave6/fonts/pepper.flf
+jave6/fonts/poison.flf
+jave6/fonts/puffy.flf
+jave6/fonts/pyramid.flf
+jave6/fonts/rammstein.flf
+jave6/fonts/rectangles.flf
+jave6/fonts/red_phoenix.flf
+jave6/fonts/relief.flf
+jave6/fonts/relief2.flf
+jave6/fonts/reverse.flf
+jave6/fonts/roman.flf
+jave6/fonts/rot13.flc
+jave6/fonts/rot13.flf
+jave6/fonts/rounded.flf
+jave6/fonts/rowancap.flf
+jave6/fonts/rozzo.flf
+jave6/fonts/runic.flf
+jave6/fonts/runyc.flf
+jave6/fonts/s-relief.flf
+jave6/fonts/santaclara.flf
+jave6/fonts/sblood.flf
+jave6/fonts/script.flf
+jave6/fonts/serifcap.flf
+jave6/fonts/shadow.flf
+jave6/fonts/shimrod.flf
+jave6/fonts/short.flf
+jave6/fonts/slant.flf
+jave6/fonts/slide.flf
+jave6/fonts/slscript.flf
+jave6/fonts/small.flf
+jave6/fonts/smallcaps.flf
+jave6/fonts/smisome1.flf
+jave6/fonts/smkeyboard.flf
+jave6/fonts/smpoison.flf
+jave6/fonts/smscript.flf
+jave6/fonts/smshadow.flf
+jave6/fonts/smslant.flf
+jave6/fonts/smtengwar.flf
+jave6/fonts/soft.flf
+jave6/fonts/speed.flf
+jave6/fonts/stacey.flf
+jave6/fonts/stampate.flf
+jave6/fonts/stampatello.flf
+jave6/fonts/standard.flf
+jave6/fonts/starwars.flf
+jave6/fonts/stellar.flf
+jave6/fonts/stforek.flf
+jave6/fonts/stop.flf
+jave6/fonts/straight.flf
+jave6/fonts/sub-zero.flf
+jave6/fonts/swampland.flf
+jave6/fonts/tanja.flf
+jave6/fonts/tengwar.flf
+jave6/fonts/term.flf
+jave6/fonts/test1.flf
+jave6/fonts/thick.flf
+jave6/fonts/thin.flf
+jave6/fonts/threepoint.flf
+jave6/fonts/ticks.flf
+jave6/fonts/ticksslant.flf
+jave6/fonts/tiles.flf
+jave6/fonts/tinker-toy.flf
+jave6/fonts/tombstone.flf
+jave6/fonts/train.flf
+jave6/fonts/trek.flf
+jave6/fonts/tsalagi.flf
+jave6/fonts/tubular.flf
+jave6/fonts/twisted.flf
+jave6/fonts/twopoint.flf
+jave6/fonts/univers.flf
+jave6/fonts/upper.flc
+jave6/fonts/usaflag.flf
+jave6/fonts/varsity.flf
+jave6/fonts/weird.flf
+jave6/fonts/wetletter.flf
+jave6/fonts/whimsy.flf
+jave6/icons/folder_jave.png
+jave6/icons/icon.bmp
+jave6/icons/icon.gif
+jave6/icons/icon.ico
+jave6/icons/icon.xpm
+jave6/jave.jar
+jave6/jave6
+jave6/javeplayer.jar
+jave6/pattern/pattern.jcf
+jave6/readme.txt
+@dirrm jave6/pattern
+@dirrm jave6/icons
+@dirrm jave6/fonts
+@dirrm jave6/config/greyscaletables
+@dirrm jave6/config
+@dirrm jave6/clipart
+@dirrm jave6