aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-20 22:12:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-20 22:12:35 +0000
commit61a2f0729c05b3a3eac4f6e0f0a9b658705003ac (patch)
tree57ede7d64b683eb71b7edeaaa2d7be0525ad9805
parent86a48f20ca9091606c1cad8f11744b9aac989a37 (diff)
This package provides an object oriented interface to the API
of the W3 CSS Validator application (http://jigsaw.w3.org/css-validator/). With this package you can connect to a running instance of the validator and retrieve the validation results (true|false) as well as the errors and warnings for a a style sheet. WWW: http://pear.php.net/package/Services_W3C_CSSValidator/ PR: ports/119833 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Notes
Notes: svn path=/head/; revision=205932
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-Services_W3C_CSSValidator/Makefile30
-rw-r--r--www/pear-Services_W3C_CSSValidator/distinfo3
-rw-r--r--www/pear-Services_W3C_CSSValidator/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f508b6e45570..2bb27b4e731e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -978,6 +978,7 @@
SUBDIR += pear-Services_Compete
SUBDIR += pear-Services_Delicious
SUBDIR += pear-Services_Digg
+ SUBDIR += pear-Services_W3C_CSSValidator
SUBDIR += pear-Services_W3C_HTMLValidator
SUBDIR += pear-Services_urlTea
SUBDIR += pear-Text_Wiki
diff --git a/www/pear-Services_W3C_CSSValidator/Makefile b/www/pear-Services_W3C_CSSValidator/Makefile
new file mode 100644
index 000000000000..20d2fa29cc1f
--- /dev/null
+++ b/www/pear-Services_W3C_CSSValidator/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Services_W3C_CSSValidator:
+# Date created: 21 Jan 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_W3C_CSSValidator
+PORTVERSION= 0.1.0
+CATEGORIES= www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= PHP interface to W3C CSS Validator API
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+
+CATEGORY= Services
+
+FILES= CSSValidator.php CSSValidator/Error.php CSSValidator/Message.php \
+ CSSValidator/Response.php CSSValidator/Warning.php
+TESTS= AllTests.php fragment.css Services_W3C_CSSValidatorTest.php
+EXAMPLES= examples/foo.css examples/fragment.css examples/pear_manual.css \
+ examples/validate_atrules.php examples/validate_byfile.php \
+ examples/validate_byuri.php examples/validate_fragment.php
+_EXAMPLESDIR= docs
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_W3C_CSSValidator/distinfo b/www/pear-Services_W3C_CSSValidator/distinfo
new file mode 100644
index 000000000000..714db6501707
--- /dev/null
+++ b/www/pear-Services_W3C_CSSValidator/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_W3C_CSSValidator-0.1.0.tgz) = 7d4caa54880de5b94808db8cba85f665
+SHA256 (PEAR/Services_W3C_CSSValidator-0.1.0.tgz) = 1687f4cb65eccb382a9d1b99c0aa15a10a0cf27b5c25814af7ee4bdbe5a2cd5c
+SIZE (PEAR/Services_W3C_CSSValidator-0.1.0.tgz) = 8397
diff --git a/www/pear-Services_W3C_CSSValidator/pkg-descr b/www/pear-Services_W3C_CSSValidator/pkg-descr
new file mode 100644
index 000000000000..b77b8951c5eb
--- /dev/null
+++ b/www/pear-Services_W3C_CSSValidator/pkg-descr
@@ -0,0 +1,11 @@
+This package provides an object oriented interface to the API
+of the W3 CSS Validator application (http://jigsaw.w3.org/css-validator/).
+
+With this package you can connect to a running instance of the validator and
+retrieve the validation results (true|false) as well as the errors and warnings
+for a a style sheet.
+
+WWW: http://pear.php.net/package/Services_W3C_CSSValidator/
+
+- Ditesh Shashikant Gathani
+ditesh@gathani.org