aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-20 21:07:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-20 21:07:56 +0000
commit67921cf4254f627872038d47ed9b19c10fe8524a (patch)
tree4656d04e1ee31a2f784332cad96c23ae9c8ce895
parentba36d24c5287ab4b2e80250f40ed0b3dc496b69e (diff)
downloadports-67921cf4254f627872038d47ed9b19c10fe8524a.tar.gz
ports-67921cf4254f627872038d47ed9b19c10fe8524a.zip
MFH: r549125
misc/mnn: Fix build on 13 by unbundling Flatbuffers The bundled Flatbuffers was failing to build on 13 for some reason. Reported by: fallout Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q3/; revision=549394
-rw-r--r--misc/mnn/Makefile7
-rw-r--r--misc/mnn/files/patch-CMakeLists.txt10
-rw-r--r--misc/mnn/files/patch-schema_generate.sh20
3 files changed, 34 insertions, 3 deletions
diff --git a/misc/mnn/Makefile b/misc/mnn/Makefile
index 7b81b79d4f1d..db38a01917af 100644
--- a/misc/mnn/Makefile
+++ b/misc/mnn/Makefile
@@ -12,9 +12,10 @@ LICENSE= APACHE20
BROKEN_i386= always_inline function '_mm_set1_ps' requires target feature 'sse', but would be inlined into function 'Vec4' that is compiled without support for 'sse'
-BUILD_DEPENDS= bash:shells/bash
+BUILD_DEPENDS= bash:shells/bash \
+ flatc:devel/flatbuffers
-USES= cmake compiler:c++11-lang shebangfix
+USES= cmake compiler:c++11-lang localbase shebangfix
USE_GITHUB= yes
GH_ACCOUNT= alibaba
GH_PROJECT= MNN
@@ -49,7 +50,7 @@ CMAKE_ARGS+= -DMNN_USE_AVX:BOOL=OFF \
.endif
pre-build: # https://github.com/alibaba/MNN/issues/648
- @cd ${WRKSRC}/schema && ./generate.sh
+ @cd ${WRKSRC}/schema && FREEBSD_FLATC=${LOCALBASE}/bin/flatc ./generate.sh
do-install-APPS-on:
.for f in MNNConvert MNNV2Basic.out mobilenetTest.out backendTest.out testModel.out testModelWithDescrisbe.out getPerformance.out checkInvalidValue.out timeProfile.out quantized.out \
diff --git a/misc/mnn/files/patch-CMakeLists.txt b/misc/mnn/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d690a6beaf55
--- /dev/null
+++ b/misc/mnn/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2020-09-20 17:36:43 UTC
++++ CMakeLists.txt
+@@ -268,7 +268,6 @@ include_directories(${CMAKE_CURRENT_LIST_DIR}/include/
+ ${CMAKE_CURRENT_LIST_DIR}/source/
+ ${CMAKE_CURRENT_LIST_DIR}/schema/current/
+ ${CMAKE_CURRENT_LIST_DIR}/3rd_party/
+- ${CMAKE_CURRENT_LIST_DIR}/3rd_party/flatbuffers/include
+ ${CMAKE_CURRENT_LIST_DIR}/3rd_party/half
+ ${CMAKE_CURRENT_LIST_DIR}/3rd_party/imageHelper
+ ${CMAKE_CURRENT_LIST_DIR}/3rd_party/OpenCLHeaders/
diff --git a/misc/mnn/files/patch-schema_generate.sh b/misc/mnn/files/patch-schema_generate.sh
new file mode 100644
index 000000000000..b1cce451b952
--- /dev/null
+++ b/misc/mnn/files/patch-schema_generate.sh
@@ -0,0 +1,20 @@
+--- schema/generate.sh.orig 2020-09-20 17:43:01 UTC
++++ schema/generate.sh
+@@ -9,7 +9,7 @@ if [[ "$1" == "-lazy" ]] && [[ -d current ]]; then
+ fi
+
+ # check is flatbuffer installed or not
+-FLATC=../3rd_party/flatbuffers/tmp/flatc
++FLATC=${FREEBSD_FLATC}
+ if [ ! -e $FLATC ]; then
+ echo "*** building flatc ***"
+
+@@ -39,7 +39,7 @@ rm -f current/*.h
+ # flatc all fbs
+ pushd current > /dev/null
+ echo "*** generating fbs under $DIR ***"
+-find ../$DIR/*.fbs | xargs ../$FLATC -c -b --gen-object-api --reflect-names
++find ../$DIR/*.fbs | xargs $FLATC -c -b --gen-object-api --reflect-names
+ popd > /dev/null
+
+ # finish