aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-03 11:50:35 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-03 11:50:35 +0000
commit6823f4a0645bbb9c83bfabbfe2ec754ac6f3b2ce (patch)
treeff16a3cf65798449c571d321d8bdf5df36edb6d1
parentebe189c5a25acba4158fa675f3c3d578a560cc46 (diff)
downloadports-6823f4a0645bbb9c83bfabbfe2ec754ac6f3b2ce.tar.gz
ports-6823f4a0645bbb9c83bfabbfe2ec754ac6f3b2ce.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php5-pdo_cassandra/Makefile33
-rw-r--r--databases/php5-pdo_cassandra/distinfo2
-rw-r--r--databases/php5-pdo_cassandra/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9881c87086c9..685d9326b65b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -563,6 +563,7 @@
SUBDIR += php5-mysqli
SUBDIR += php5-odbc
SUBDIR += php5-pdo
+ SUBDIR += php5-pdo_cassandra
SUBDIR += php5-pdo_dblib
SUBDIR += php5-pdo_firebird
SUBDIR += php5-pdo_mysql
diff --git a/databases/php5-pdo_cassandra/Makefile b/databases/php5-pdo_cassandra/Makefile
new file mode 100644
index 000000000000..608bf82725a1
--- /dev/null
+++ b/databases/php5-pdo_cassandra/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: php5-pdo_cassandra
+# Date created: 2011-08-03
+# Whom: Gasol Wu <gasol.wu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdo_cassandra
+PORTVERSION= 0.2.1
+CATEGORIES= databases
+MASTER_SITES= https://github.com/${GITHUB_USER}/php-${PORTNAME}/tarball/${GITREVISION}/
+PKGNAMEPREFIX= php5-
+DISTNAME= ${GITHUB_USER}-php-${PORTNAME}-${GITTAG}-14-g${GITREVISION}
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PDO driver for Apache Cassandra
+
+LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
+ thrift:${PORTSDIR}/devel/thrift
+
+GITREVISION= 7debd5b
+GITTAG= 0.8-support
+GITHUB_USER= mkoppanen
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/${GITHUB_USER}-php-${PORTNAME}-${GITREVISION}
+
+USE_PHP_BUILD= yes
+USE_PHP= pdo
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+IGNORE_WITH_PHP=4 52
+
+.include <bsd.port.mk>
diff --git a/databases/php5-pdo_cassandra/distinfo b/databases/php5-pdo_cassandra/distinfo
new file mode 100644
index 000000000000..6c116cea70a5
--- /dev/null
+++ b/databases/php5-pdo_cassandra/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mkoppanen-php-pdo_cassandra-0.8-support-14-g7debd5b.tar.gz) = 22ed3a42c4525bfa9808533c5dd4675443ac7af8837ab5812a2a301b997538f2
+SIZE (mkoppanen-php-pdo_cassandra-0.8-support-14-g7debd5b.tar.gz) = 32970
diff --git a/databases/php5-pdo_cassandra/pkg-descr b/databases/php5-pdo_cassandra/pkg-descr
new file mode 100644
index 000000000000..f278d4f5d294
--- /dev/null
+++ b/databases/php5-pdo_cassandra/pkg-descr
@@ -0,0 +1,10 @@
+PDO driver for Apache Cassandra
+
+Cassandra is a highly scalable, eventually consistent, distributed,
+structured key-value store. Cassandra brings together the distributed
+systems technologies from Dynamo and the data model from Google's
+BigTable. Like Dynamo, Cassandra is eventually consistent. Like
+BigTable, Cassandra provides a ColumnFamily-based data model richer
+than typical key/value systems.
+
+WWW: http://code.google.com/a/apache-extras.org/p/cassandra-pdo/