aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-25 01:39:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-25 01:39:02 +0000
commit693f2c27637e968f210c135ebab3e85c3f407f17 (patch)
tree9bca8390db877e9c32e1f9437fc2002e4b0ea0bb
parentf3a6b7e8ca2b67295c4d93cc4119c4f5d13d8d41 (diff)
downloadports-693f2c27637e968f210c135ebab3e85c3f407f17.tar.gz
ports-693f2c27637e968f210c135ebab3e85c3f407f17.zip
MFH: r549974
biology/py-scikit-bio: Fix build on the i386 architecture Reported by: fallout Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549979
-rw-r--r--biology/py-scikit-bio/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/biology/py-scikit-bio/Makefile b/biology/py-scikit-bio/Makefile
index 7346474b5b46..602ebe75d3c3 100644
--- a/biology/py-scikit-bio/Makefile
+++ b/biology/py-scikit-bio/Makefile
@@ -28,4 +28,11 @@ RUN_DEPENDS= ${PYNUMPY} \
USES= python:3.5+
USE_PYTHON= autoplist distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+CFLAGS+= -msse2 # workaround for https://github.com/biocore/scikit-bio/issues/1727
+CXXFLAGS+= -msse2
+.endif
+
+.include <bsd.port.post.mk>