aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-21 20:27:38 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-21 20:27:38 +0000
commit69553e4f7c1f93fda6e17c7b931b3608ef73ecc6 (patch)
tree3b58c1656511b21ca6ab01acd69df8ed9d350d19
parentddfee5c9dd2b8ec2a36f1af9036a03be640d7907 (diff)
downloadports-69553e4f7c1f93fda6e17c7b931b3608ef73ecc6.tar.gz
ports-69553e4f7c1f93fda6e17c7b931b3608ef73ecc6.zip
Notes
-rw-r--r--misc/lxde-common/Makefile5
-rw-r--r--misc/xdg-menu/Makefile15
-rw-r--r--misc/xdg-menu/pkg-plist1
-rw-r--r--sysutils/lxinput/Makefile3
-rw-r--r--sysutils/lxinput/pkg-plist2
-rw-r--r--sysutils/lxtask/Makefile6
-rw-r--r--sysutils/lxterminal/Makefile4
-rw-r--r--sysutils/lxterminal/pkg-plist2
-rw-r--r--x11-fm/pcmanfm/Makefile6
-rw-r--r--x11-fm/pcmanfm/pkg-plist7
-rw-r--r--x11-themes/lxde-icon-theme/Makefile7
-rw-r--r--x11-themes/lxde-icon-theme/pkg-plist1
-rw-r--r--x11-wm/lxmed/Makefile4
-rw-r--r--x11-wm/lxsession/Makefile4
-rw-r--r--x11-wm/lxsession/pkg-plist2
-rw-r--r--x11-wm/obapps/Makefile9
-rw-r--r--x11-wm/obmenu/Makefile19
-rw-r--r--x11/florence/Makefile8
-rw-r--r--x11/libfm/Makefile6
-rw-r--r--x11/libfm/pkg-plist3
-rw-r--r--x11/lxde-meta/Makefile4
-rw-r--r--x11/lxmenu-data/Makefile4
-rw-r--r--x11/lxmenu-data/pkg-plist1
-rw-r--r--x11/lxpanel/Makefile11
-rw-r--r--x11/lxpanel/pkg-plist2
-rw-r--r--x11/menu-cache/Makefile10
26 files changed, 75 insertions, 71 deletions
diff --git a/misc/lxde-common/Makefile b/misc/lxde-common/Makefile
index fabf77e70d0e..a403421fda1c 100644
--- a/misc/lxde-common/Makefile
+++ b/misc/lxde-common/Makefile
@@ -3,11 +3,11 @@
PORTNAME= lxde-common
PORTVERSION= 0.5.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= SF/lxde/${PORTNAME}%20%28default%20config%29/LXDE%20Common%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= LXDE Common files
LICENSE= GPLv2
@@ -26,7 +26,6 @@ DATADIR= ${PREFIX}/share/lxde
INSTALLS_ICONS= YES
PORTDOCS= AUTHORS README
-
OPTIONS_DEFINE= DOCS
post-install:
diff --git a/misc/xdg-menu/Makefile b/misc/xdg-menu/Makefile
index 1c213597d4e0..d68f755d23a7 100644
--- a/misc/xdg-menu/Makefile
+++ b/misc/xdg-menu/Makefile
@@ -1,9 +1,9 @@
-# Created by: nemysis <nemysis@gmx.ch>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= xdg-menu
PORTVERSION= 1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -12,7 +12,7 @@ DISTFILES= XDG-Menu-${DISTVERSION}.tgz \
DIST_SUBDIR= python
EXTRACT_ONLY= XDG-Menu-${DISTVERSION}.tgz
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= ROX panel applet that displays an applications menu button
LICENSE= GPLv2
@@ -29,10 +29,10 @@ INSTALLS_ICONS= yes
PORTDOCS= *
-DESKTOP_ENTRIES="XDG-Menu" "${COMMENT}" ${PORTNAME} \
- "${PORTNAME}" "Application;System;" false
+DESKTOP_ENTRIES="XDG-Menu" "" ${PORTNAME} \
+ "${PORTNAME}" "Application;System;" ""
-OPTIONS_DEFINE= ROX
+OPTIONS_DEFINE= DOCS ROX
ROX_DESC= Enable ROX panel applet support
SUB_FILES= ${PORTNAME}
@@ -43,7 +43,8 @@ post-patch:
@${REINPLACE_CMD} -i '' 's|/usr/lib|../../lib|' ${WRKSRC}/findrox.py
.if ! ${PORT_OPTIONS:MROX}
- @${REINPLACE_CMD} -i '' '/if not rox.confirm/,/sys.exit/s/^/#/' ${WRKSRC}/AppRun
+ @${REINPLACE_CMD} -i '' '/if not rox.confirm/,/sys.exit/s/^/#/' \
+ ${WRKSRC}/AppRun
@${ECHO_MSG}
@${ECHO_MSG} "You have not enabled ROX panel applet support"
@${ECHO_MSG}
diff --git a/misc/xdg-menu/pkg-plist b/misc/xdg-menu/pkg-plist
index d821ee3ddd62..cc050f42ba15 100644
--- a/misc/xdg-menu/pkg-plist
+++ b/misc/xdg-menu/pkg-plist
@@ -45,4 +45,3 @@ share/pixmaps/xdg-menu.png
@dirrm apps/XDG-Menu/python
@dirrm apps/XDG-Menu/Messages
@dirrm apps/XDG-Menu
-@dirrmtry apps
diff --git a/sysutils/lxinput/Makefile b/sysutils/lxinput/Makefile
index 53cd1e602e2a..d492ab7c82c9 100644
--- a/sysutils/lxinput/Makefile
+++ b/sysutils/lxinput/Makefile
@@ -3,10 +3,11 @@
PORTNAME= lxinput
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/lxde/LXInput%20%28Kbd%20and%20amp_%20mouse%20config%29/LXInput%200.3.2/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Keyboard and mouse config tool from the LXDE project
USES= iconv gmake pkgconfig
diff --git a/sysutils/lxinput/pkg-plist b/sysutils/lxinput/pkg-plist
index 2090cfa8a882..d519b0963be2 100644
--- a/sysutils/lxinput/pkg-plist
+++ b/sysutils/lxinput/pkg-plist
@@ -67,6 +67,8 @@ share/applications/lxinput.desktop
%%DATADIR%%/input-mouse.png
%%DATADIR%%/lxinput.ui
@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
diff --git a/sysutils/lxtask/Makefile b/sysutils/lxtask/Makefile
index 2479e6e2f4ca..0ad35ae746b4 100644
--- a/sysutils/lxtask/Makefile
+++ b/sysutils/lxtask/Makefile
@@ -3,11 +3,11 @@
PORTNAME= lxtask
PORTVERSION= 0.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= SF/lxde/LXTask%20%28task%20manager%29/LXTask%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Lightweight desktop-independent task manager
LICENSE= GPLv2
@@ -17,7 +17,7 @@ USE_GNOME= gtk20 intlhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PORTDOCS= AUTHORS README TODO
+PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
diff --git a/sysutils/lxterminal/Makefile b/sysutils/lxterminal/Makefile
index 1e4061ea790b..0c2f5dfdba83 100644
--- a/sysutils/lxterminal/Makefile
+++ b/sysutils/lxterminal/Makefile
@@ -3,11 +3,11 @@
PORTNAME= lxterminal
PORTVERSION= 0.1.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF/lxde/LXTerminal%20%28terminal%20emulator%29/LXTerminal%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Lightweight terminal emulator from the LXDE project
LICENSE= GPLv2
diff --git a/sysutils/lxterminal/pkg-plist b/sysutils/lxterminal/pkg-plist
index 53ae0cb3a45f..cc971a1a24b0 100644
--- a/sysutils/lxterminal/pkg-plist
+++ b/sysutils/lxterminal/pkg-plist
@@ -62,6 +62,8 @@ share/applications/lxterminal.desktop
%%DATADIR%%/lxterminal.conf
share/pixmaps/lxterminal.png
@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
diff --git a/x11-fm/pcmanfm/Makefile b/x11-fm/pcmanfm/Makefile
index 218d6422bfa6..3c9ac6a63473 100644
--- a/x11-fm/pcmanfm/Makefile
+++ b/x11-fm/pcmanfm/Makefile
@@ -3,18 +3,18 @@
PORTNAME= pcmanfm
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= x11-fm
MASTER_SITES= SF/${PORTNAME}/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/PCManFM/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= PCMan File Manager
LICENSE= GPLv2
LIB_DEPENDS= libfm-gtk.so:${PORTSDIR}/x11/libfm
-USE_XZ= yes
-USES= desktop-file-utils fam gmake pathfix pkgconfig
+USES= desktop-file-utils fam gmake pathfix pkgconfig tar:xz
USE_GNOME= gtk20
USE_AUTOTOOLS= aclocal automake libtool
diff --git a/x11-fm/pcmanfm/pkg-plist b/x11-fm/pcmanfm/pkg-plist
index e2de4ada95e8..585a57784da2 100644
--- a/x11-fm/pcmanfm/pkg-plist
+++ b/x11-fm/pcmanfm/pkg-plist
@@ -67,11 +67,8 @@ share/applications/pcmanfm.desktop
%%DATADIR%%/ui/pref.ui
@dirrmtry %%DATADIR%%/ui
@dirrmtry %%DATADIR%%
-%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/tt_RU
-%%NLS%%@dirrmtry share/locale/lg/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/lg
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
@dirrmtry lib/pcmanfm
@dirrmtry etc/xdg/pcmanfm/default
@dirrmtry etc/xdg/pcmanfm
-@dirrmtry etc/xdg
diff --git a/x11-themes/lxde-icon-theme/Makefile b/x11-themes/lxde-icon-theme/Makefile
index 0d0df1248466..483c90551aa3 100644
--- a/x11-themes/lxde-icon-theme/Makefile
+++ b/x11-themes/lxde-icon-theme/Makefile
@@ -3,16 +3,16 @@
PORTNAME= lxde-icon-theme
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11-themes
MASTER_SITES= SF/lxde/LXDE%20Icon%20Theme/lxde-icon-theme-${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= LXDE Icon Theme
LICENSE= GPLv3
-USE_BZIP2= YES
-USES= gmake iconv
+USES= gmake iconv tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
@@ -20,7 +20,6 @@ DATADIR= ${PREFIX}/share/lxde
INSTALLS_ICONS= YES
PORTDOCS= AUTHORS
-
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/x11-themes/lxde-icon-theme/pkg-plist b/x11-themes/lxde-icon-theme/pkg-plist
index 53a9456b82b5..021181173228 100644
--- a/x11-themes/lxde-icon-theme/pkg-plist
+++ b/x11-themes/lxde-icon-theme/pkg-plist
@@ -6679,3 +6679,4 @@ share/icons/nuoveXT2/index.theme
@dirrm share/icons/nuoveXT2/128x128/actions
@dirrm share/icons/nuoveXT2/128x128
@dirrm share/icons/nuoveXT2
+@dirrmtry share/icons
diff --git a/x11-wm/lxmed/Makefile b/x11-wm/lxmed/Makefile
index 93e410fb775f..8e643cfa7627 100644
--- a/x11-wm/lxmed/Makefile
+++ b/x11-wm/lxmed/Makefile
@@ -3,12 +3,12 @@
PORTNAME= lxmed
PORTVERSION= 20120515
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm java
MASTER_SITES= SF/${PORTNAME}/
DIST_SUBDIR= java
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= LXDE Main Menu Editor
LICENSE= GPLv3
diff --git a/x11-wm/lxsession/Makefile b/x11-wm/lxsession/Makefile
index 501a21e1175b..a7bdaf1d8eb7 100644
--- a/x11-wm/lxsession/Makefile
+++ b/x11-wm/lxsession/Makefile
@@ -3,11 +3,11 @@
PORTNAME= lxsession
PORTVERSION= 0.4.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= SF/lxde/LXSession%20%28session%20manager%29/LXSession%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= LXDE Session Manager
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
diff --git a/x11-wm/lxsession/pkg-plist b/x11-wm/lxsession/pkg-plist
index 366636279356..e23472a06277 100644
--- a/x11-wm/lxsession/pkg-plist
+++ b/x11-wm/lxsession/pkg-plist
@@ -72,6 +72,8 @@ man/man1/lxsession.1.gz
%%DATADIR%%/images/system-shutdown.png
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
diff --git a/x11-wm/obapps/Makefile b/x11-wm/obapps/Makefile
index ef4c222aa764..e57780338fed 100644
--- a/x11-wm/obapps/Makefile
+++ b/x11-wm/obapps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= obapps
PORTVERSION= 0.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}/ \
SF/nemysisfreebsdp/:icons
@@ -11,7 +11,7 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Graphical editor for Openbox application settings
LICENSE= MIT
@@ -24,9 +24,10 @@ WX_COMPS= python:run
USE_PYDISTUTILS=yes
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
-DESKTOP_ENTRIES="OBApps" "${COMMENT}" ${PORTNAME} \
- "${PORTNAME}" "Settings;" false
+DESKTOP_ENTRIES="OBApps" "" ${PORTNAME} \
+ "${PORTNAME}" "Settings;" ""
post-install:
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
diff --git a/x11-wm/obmenu/Makefile b/x11-wm/obmenu/Makefile
index 315c40b898d4..f548fb2a010f 100644
--- a/x11-wm/obmenu/Makefile
+++ b/x11-wm/obmenu/Makefile
@@ -3,36 +3,33 @@
PORTNAME= obmenu
PORTVERSION= 1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm
MASTER_SITES= SF
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Menu manager for Openbox supporting both static and pipe menus
LICENSE= GPLv2
USE_GNOME= pygtk2
-USE_PYTHON= yes
+USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= obMenu
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
SUB_FILES= pkg-message
DESKTOP_ENTRIES="Obmenu" "Menu manager for Openbox" ${PORTNAME} \
- "${PORTNAME}" "Settings;" false
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
+ "${PORTNAME}" "Settings;" ""
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
- ${LN} -sf ${DATADIR}/mnu48.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ ${LN} -sf ${DATADIR}/mnu48.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
index 707bda8a61d0..be9fe80e2624 100644
--- a/x11/florence/Makefile
+++ b/x11/florence/Makefile
@@ -3,10 +3,11 @@
PORTNAME= florence
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/florence/florence/${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Extensible scalable virtual keyboard
LICENSE= GPLv2 GFDL
@@ -16,8 +17,7 @@ LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_BZIP2= yes
-USES= desktop-file-utils gmake iconv pathfix pkgconfig
+USES= gmake iconv pathfix pkgconfig tar:bzip2
USE_XORG= xtst xext
USE_GNOME= gtk30 cairo intlhack gnomedocutils librsvg2
USE_GSTREAMER= yes
@@ -27,8 +27,6 @@ USE_LDCONFIG= yes
INSTALLS_OMF= yes
GLIB_SCHEMAS= org.florence.gschema.xml
-MAN1= ${PORTNAME}.1 ${PORTNAME}_applet.1
-
PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS NLS
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index d8392cc67941..fbc87a21f26b 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -3,10 +3,11 @@
PORTNAME= libfm
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/libfm%20%28required%20by%20PCManFM%29/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= The libFM backend library to PCManFM
LICENSE= GPLv2
@@ -16,8 +17,7 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
LIB_DEPENDS= libmenu-cache.so:${PORTSDIR}/x11/menu-cache \
libexif.so:${PORTSDIR}/graphics/libexif
-USE_XZ= yes
-USES= desktop-file-utils fam gmake pkgconfig shared-mime-info
+USES= desktop-file-utils fam gmake pkgconfig shared-mime-info tar:xz
USE_GNOME= gtk20
USE_AUTOTOOLS= aclocal automake libtool
CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
diff --git a/x11/libfm/pkg-plist b/x11/libfm/pkg-plist
index 6706a8e4a959..f6ae35584113 100644
--- a/x11/libfm/pkg-plist
+++ b/x11/libfm/pkg-plist
@@ -169,8 +169,6 @@ share/applications/lxshortcut.desktop
%%NLS%%share/locale/zh_CN/LC_MESSAGES/libfm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/libfm.mo
share/mime/packages/libfm.xml
-@dirrmtry share/mime/packages
-@dirrmtry share/mime
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
@@ -184,4 +182,3 @@ share/mime/packages/libfm.xml
@dirrm lib/libfm
@dirrm include/libfm-%%MAJORVER%%
@dirrmtry etc/xdg/libfm
-@dirrmtry etc/xdg
diff --git a/x11/lxde-meta/Makefile b/x11/lxde-meta/Makefile
index ed9ad23f0a61..a5f1b155f00a 100644
--- a/x11/lxde-meta/Makefile
+++ b/x11/lxde-meta/Makefile
@@ -3,12 +3,12 @@
PORTNAME= lxde-meta
PORTVERSION= 1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11
MASTER_SITES= #none
DISTFILES= #none
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= "meta-port" of the LXDE desktop slimmed down for FreeBSD releases
RUN_DEPENDS= openbox:${PORTSDIR}/x11-wm/openbox \
diff --git a/x11/lxmenu-data/Makefile b/x11/lxmenu-data/Makefile
index 002a8670b225..5f53bd5d2587 100644
--- a/x11/lxmenu-data/Makefile
+++ b/x11/lxmenu-data/Makefile
@@ -3,10 +3,11 @@
PORTNAME= lxmenu-data
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/lxde/lxmenu-data%20%28desktop%20menu%29/lxmenu-data%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Menu data used by lxpanel
LICENSE= GPLv2
@@ -24,7 +25,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS README TODO
-
OPTIONS_DEFINE= DOCS
post-install:
diff --git a/x11/lxmenu-data/pkg-plist b/x11/lxmenu-data/pkg-plist
index c67c209d0425..7d76f40d7def 100644
--- a/x11/lxmenu-data/pkg-plist
+++ b/x11/lxmenu-data/pkg-plist
@@ -20,5 +20,4 @@ share/desktop-directories/lxde-system.directory
share/desktop-directories/lxde-utility-accessibility.directory
share/desktop-directories/lxde-utility.directory
@dirrmtry etc/xdg/menus
-@dirrmtry etc/xdg
@dirrmtry share/desktop-directories
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index df2c28fa5abd..085a381e2972 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -3,11 +3,11 @@
PORTNAME= lxpanel
PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= Lightweight X11 desktop panel
LICENSE= GPLv2 MIT
@@ -16,6 +16,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libmenu-cache.so:${PORTSDIR}/x11/menu-cache
RUN_DEPENDS= ${LOCALBASE}/share/desktop-directories/lxde-audio-video.directory:${PORTSDIR}/x11/lxmenu-data
+PORTDOCS= AUTHORS README
OPTIONS_DEFINE= ALSA DOCS NLS
OPTIONS_SUB= yes
@@ -37,8 +38,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
CFLAGS+= -I${WRKSRC} -Wno-return-type
USE_CSTD= gnu89
-PORTDOCS= AUTHORS README
-
.include <bsd.port.options.mk>
post-patch:
@@ -53,6 +52,10 @@ post-patch:
.endif
post-install:
+.for l in volume xkb deskno batt kbled
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lxpanel/plugins/${l}.so
+.endfor
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index 78d8e814ac73..510ccdcff272 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -245,6 +245,8 @@ man/man1/lxpanelctl.1.gz
@dirrm %%DATADIR%%/images/xkb-flags
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
diff --git a/x11/menu-cache/Makefile b/x11/menu-cache/Makefile
index 42bb02ee9b27..3ebfb1100e5d 100644
--- a/x11/menu-cache/Makefile
+++ b/x11/menu-cache/Makefile
@@ -3,18 +3,22 @@
PORTNAME= menu-cache
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/lxde/menu-cache/menu-cache%20$${PORTVERSION:R}.x/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= horia@racoviceanu.com
COMMENT= The menu-cache portion of LXDE
-USES= fam gmake pkgconfig
-USE_GNOME= gnomehack glib20
+USES= fam gmake pathfix pkgconfig
+USE_GNOME= glib20
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmenu-cache.so.3
+
.include <bsd.port.mk>