aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-10 03:20:10 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-10 03:20:10 +0000
commit6be79b4d463befbb085e105a6004622f0be49597 (patch)
tree110a8edfd60741110d422c12a1a19cb29475d3d6
parentb73b27a91ac6bd58def400185ed51287fb7eab61 (diff)
downloadports-6be79b4d463befbb085e105a6004622f0be49597.tar.gz
ports-6be79b4d463befbb085e105a6004622f0be49597.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/nelly/Makefile65
-rw-r--r--games/nelly/distinfo2
-rw-r--r--games/nelly/files/nelly.in5
-rw-r--r--games/nelly/pkg-descr5
5 files changed, 78 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c8bd55f93f51..b4318f08a440 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -575,6 +575,7 @@
SUBDIR += naev-data
SUBDIR += nazghul
SUBDIR += nehquake
+ SUBDIR += nelly
SUBDIR += nethack32
SUBDIR += nethack33
SUBDIR += nethack33-gnome
diff --git a/games/nelly/Makefile b/games/nelly/Makefile
new file mode 100644
index 000000000000..a7723e899ec5
--- /dev/null
+++ b/games/nelly/Makefile
@@ -0,0 +1,65 @@
+# New Ports collection makefile for: nelly
+# Date created: 16 July 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= nelly
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= http://www.partiallydisassembled.net/nelly/ \
+ http://media.pyweek.org/dl/2/rushed/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Nelly's Rooftop Garden, physics-based puzzle game
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:${PORTSDIR}/devel/py-game \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl
+
+OPTIONS_DEFINE= DATA
+OPTIONS_DEFAULT= DATA
+
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= README
+
+SUB_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/*.py
+ @(cd ${WRKSRC} && ${RM} *.py.bak)
+
+do-install:
+# Scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+
+# Data
+.if ${PORT_OPTIONS:MDATA}
+. for d in fonts levels textures
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+. endfor
+.endif
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/textures/menu.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/nelly/distinfo b/games/nelly/distinfo
new file mode 100644
index 000000000000..ef8be32096ef
--- /dev/null
+++ b/games/nelly/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nelly-1.0.tar.gz) = a62a959259645cf849275498d19e71348f08ec92f490f2f902697dbefff04620
+SIZE (nelly-1.0.tar.gz) = 516647
diff --git a/games/nelly/files/nelly.in b/games/nelly/files/nelly.in
new file mode 100644
index 000000000000..70ae64b3dc80
--- /dev/null
+++ b/games/nelly/files/nelly.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+echo "Nelly's Rooftop Garden: Starting up..."
+cd "%%DATADIR%%"
+./nelly.py
diff --git a/games/nelly/pkg-descr b/games/nelly/pkg-descr
new file mode 100644
index 000000000000..c607ab64a142
--- /dev/null
+++ b/games/nelly/pkg-descr
@@ -0,0 +1,5 @@
+A physics-based puzzle game written in Python for PyWeek 2.
+Features over 15 levels, a free-play mode and an integrated level editor.
+
+WWW: http://www.partiallydisassembled.net/nelly/
+WWW: http://pyweek.org/e/rushed/