aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-09-23 14:44:09 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-09-23 14:44:09 +0000
commit6de023c4e884e6ad513f4ac3ca785289f96ca392 (patch)
tree732a7db68539b2dd40a33ec9e487f9f4d67febd0
parent400dd65d7a6aec11ee76859e69934210bd007ecd (diff)
downloadports-6de023c4e884e6ad513f4ac3ca785289f96ca392.tar.gz
ports-6de023c4e884e6ad513f4ac3ca785289f96ca392.zip
MFH: r549731 r549732
Notes
Notes: svn path=/branches/2020Q3/; revision=549733
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind916/files/extrapatch-bind-tools8
-rw-r--r--dns/bind916/files/patch-configure8
7 files changed, 23 insertions, 23 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index f3d0f7a19883..bb22406e2c72 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= cpe libedit pkgconfig
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.22
+ISCVERSION= 9.11.23
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index e51775d9a093..74b21e525e80 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1597735112
-SHA256 (bind-9.11.22.tar.gz) = afc6d8015006f1cabf699ff19f517bb8fd9c1811e5231f26baf51c3550262ac9
-SIZE (bind-9.11.22.tar.gz) = 8248081
+TIMESTAMP = 1600870608
+SHA256 (bind-9.11.23.tar.gz) = 6e194d2f2a4c9fc18f5989b7a28b71161d1703c0d9b2c0fb8c0a545cc05ad2e1
+SIZE (bind-9.11.23.tar.gz) = 8257821
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 4ec9e0ec12ba..9469a05ca626 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.6
+ISCVERSION= 9.16.7
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 2a5b225abec4..42d1e32825b0 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1597735379
-SHA256 (bind-9.16.6.tar.xz) = b567b0f3b47dd03b345a4848af7f2acdd3f5cea2bd804edd85d9ef50743571cb
-SIZE (bind-9.16.6.tar.xz) = 3228368
+TIMESTAMP = 1600870670
+SHA256 (bind-9.16.7.tar.xz) = 9f7d1812ebbd26a699f62b6fa8522d5dec57e4bf43af0042a0d60d39ed8314d1
+SIZE (bind-9.16.7.tar.xz) = 3241476
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 0d5be6d5fe1f..2c91bb513beb 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-08-10 09:31:13 UTC
+--- bin/named/config.c.orig 2020-09-04 10:44:49 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-08-10 09:31:13 UTC
+--- bin/named/server.c.orig 2020-09-04 10:44:49 UTC
+++ bin/named/server.c
-@@ -4330,6 +4330,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4340,6 +4340,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-08-10 09:31:13 UTC
+--- lib/dns/include/dns/view.h.orig 2020-09-04 10:44:49 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-08-10 09:31:13 UTC
+--- lib/dns/resolver.c.orig 2020-09-04 10:44:49 UTC
+++ lib/dns/resolver.c
-@@ -6268,6 +6268,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6275,6 +6275,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-08-10 09:31:13 UTC
+--- lib/isccfg/namedconf.c.orig 2020-09-04 10:44:49 UTC
+++ lib/isccfg/namedconf.c
@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind916/files/extrapatch-bind-tools b/dns/bind916/files/extrapatch-bind-tools
index 33ec579a0b93..da9da5dfd8da 100644
--- a/dns/bind916/files/extrapatch-bind-tools
+++ b/dns/bind916/files/extrapatch-bind-tools
@@ -1,8 +1,8 @@
Only select the "tools" part of bind for building.
---- Makefile.in.orig 2020-06-10 21:01:43 UTC
+--- Makefile.in.orig 2020-09-04 10:44:49 UTC
+++ Makefile.in
-@@ -14,7 +14,7 @@ top_builddir = @top_builddir@
+@@ -17,7 +17,7 @@ W3M = @W3M@
VERSION=@BIND9_VERSION@
@@ -11,7 +11,7 @@ Only select the "tools" part of bind for building.
TARGETS =
PREREQS = bind.keys.h
-@@ -50,7 +50,6 @@ installdirs:
+@@ -53,7 +53,6 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man1
install:: installdirs
@@ -19,7 +19,7 @@ Only select the "tools" part of bind for building.
uninstall::
rm -f ${DESTDIR}${sysconfdir}/bind.keys
---- bin/Makefile.in.orig 2020-06-10 21:01:43 UTC
+--- bin/Makefile.in.orig 2020-09-04 10:44:49 UTC
+++ bin/Makefile.in
@@ -11,8 +11,8 @@ srcdir = @srcdir@
VPATH = @srcdir@
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index 530869b3f50e..0f7ca91b0b0f 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-08-10 09:31:13 UTC
+--- configure.orig 2020-09-04 10:44:49 UTC
+++ configure
-@@ -17574,27 +17574,9 @@ done
+@@ -17673,27 +17673,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17637,47 +17619,7 @@ $as_echo "no" >&6; } ;;
+@@ -17736,47 +17718,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23183,7 +23125,7 @@ $as_echo "" >&6; }
+@@ -23282,7 +23224,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).