aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-26 20:05:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-26 20:05:22 +0000
commit6fba8aba61e8cf9ea05a47dce87fb7ce0ca23eb9 (patch)
tree4e74fa5024aad81d4f184a3c3d3c1067353dd009
parent68590ecb3f4c63499092e29a3d97f9cb1ae4cbce (diff)
downloadports-6fba8aba61e8cf9ea05a47dce87fb7ce0ca23eb9.tar.gz
ports-6fba8aba61e8cf9ea05a47dce87fb7ce0ca23eb9.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/wcalc/Makefile30
-rw-r--r--math/wcalc/distinfo3
-rw-r--r--math/wcalc/pkg-descr9
4 files changed, 43 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0c148307d9bd..751392a480ea 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -370,6 +370,7 @@
SUBDIR += vtk-java
SUBDIR += vtk-python
SUBDIR += vtk-tcl
+ SUBDIR += wcalc
SUBDIR += wfmath
SUBDIR += wingz
SUBDIR += wingz3
diff --git a/math/wcalc/Makefile b/math/wcalc/Makefile
new file mode 100644
index 000000000000..caa5ff687c76
--- /dev/null
+++ b/math/wcalc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Wcalc
+# Date created: 25-Apr-2007
+# Whom: Amarendra Godbole <amarendra.godbole@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Wcalc
+PORTVERSION= 2.2.2
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= w-calc
+
+MAINTAINER= amarendra.godbole@gmail.com
+COMMENT= A natural-expression command-line calculator
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+ mpfr.1:${PORTSDIR}/math/mpfr
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= wcalc.1
+
+PLIST_FILES= bin/wcalc
+
+.include <bsd.port.mk>
diff --git a/math/wcalc/distinfo b/math/wcalc/distinfo
new file mode 100644
index 000000000000..1d67821ea03a
--- /dev/null
+++ b/math/wcalc/distinfo
@@ -0,0 +1,3 @@
+MD5 (Wcalc-2.2.2.tar.gz) = 6fc73c15f2b5fe5576f4d2ee70e6c13b
+SHA256 (Wcalc-2.2.2.tar.gz) = 77f231efa6831f1229e0a6dc48e02c781060837b4d0caf8cd7eb6c5a6683b8f4
+SIZE (Wcalc-2.2.2.tar.gz) = 285313
diff --git a/math/wcalc/pkg-descr b/math/wcalc/pkg-descr
new file mode 100644
index 000000000000..31afb002e0d1
--- /dev/null
+++ b/math/wcalc/pkg-descr
@@ -0,0 +1,9 @@
+Wcalc is a powerful arbitrary-precision calculator. It has standard functions
+(sin, asinh, logtwo, floor, etc), many pre-defined constants (pi, e, c, etc.),
+variables, "active" variables, command history, and hex/octal/binary i/o,
+conversions, and more.
+
+WWW: http://w-calc.sourceforge.net/
+
+-Amarendra Godbole
+amarendra.godbole@gmail.com