aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-06-03 11:49:08 +0000
committerSteve Wills <swills@FreeBSD.org>2013-06-03 11:49:08 +0000
commit78d8eec952ded9d9a45a97417d36c94635ecb578 (patch)
tree957cd7a2e57177bc334ca9cdffb36224e4e98af2
parent0d7b596442326838765f695e3b8a7e33b51ac869 (diff)
downloadports-78d8eec952ded9d9a45a97417d36c94635ecb578.tar.gz
ports-78d8eec952ded9d9a45a97417d36c94635ecb578.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-http-cookie/Makefile18
-rw-r--r--www/rubygem-http-cookie/distinfo2
-rw-r--r--www/rubygem-http-cookie/pkg-descr7
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e78716e35cf6..24cc71a31336 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1746,6 +1746,7 @@
SUBDIR += rubygem-feedzirra
SUBDIR += rubygem-haml
SUBDIR += rubygem-hpricot
+ SUBDIR += rubygem-http-cookie
SUBDIR += rubygem-httparty
SUBDIR += rubygem-httpclient
SUBDIR += rubygem-innate
diff --git a/www/rubygem-http-cookie/Makefile b/www/rubygem-http-cookie/Makefile
new file mode 100644
index 000000000000..0887d336ead9
--- /dev/null
+++ b/www/rubygem-http-cookie/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http-cookie
+PORTVERSION= 1.0.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library to handle HTTP Cookies
+
+RUN_DEPENDS= rubygem-domain_name>=0.5.1:${PORTSDIR}/net/rubygem-domain_name
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-http-cookie/distinfo b/www/rubygem-http-cookie/distinfo
new file mode 100644
index 000000000000..86e79d1e7d9c
--- /dev/null
+++ b/www/rubygem-http-cookie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/http-cookie-1.0.1.gem) = a91daf2f18d3fe9d38f8aca291c578eea1ad621f3807f7ce3b41d4587384ef3f
+SIZE (rubygem/http-cookie-1.0.1.gem) = 37888
diff --git a/www/rubygem-http-cookie/pkg-descr b/www/rubygem-http-cookie/pkg-descr
new file mode 100644
index 000000000000..60e4ca279a42
--- /dev/null
+++ b/www/rubygem-http-cookie/pkg-descr
@@ -0,0 +1,7 @@
+HTTP::Cookie is a Ruby library to handle HTTP Cookies based on RFC 6265. It has
+with security, standards compliance and compatibility in mind, to behave just
+the same as today's major web browsers. It has builtin support for the legacy
+cookies.txt and the latest cookies.sqlite formats of Mozilla Firefox, and its
+modular API makes it easy to add support for a new backend store.
+
+WWW: https://github.com/sparklemotion/http-cookie