aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-10 20:05:09 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-10 20:05:09 +0000
commit7b27d09705c2d09a78a107a04ce8d384d51536ab (patch)
treec99466fa075237cca3bdc7ed3759bcbbb7240fc7
parentd59bde8d34c8974fb636ac0acec74a43b5b824eb (diff)
downloadports-7b27d09705c2d09a78a107a04ce8d384d51536ab.tar.gz
ports-7b27d09705c2d09a78a107a04ce8d384d51536ab.zip
Notes
-rw-r--r--shells/Makefile1
-rw-r--r--shells/wapsh/Makefile93
-rw-r--r--shells/wapsh/distinfo1
-rw-r--r--shells/wapsh/files/htshd.sh20
-rw-r--r--shells/wapsh/files/patch-htshd::htshd.c15
-rw-r--r--shells/wapsh/pkg-comment1
-rw-r--r--shells/wapsh/pkg-descr17
-rw-r--r--shells/wapsh/pkg-message13
-rw-r--r--shells/wapsh/pkg-plist91
9 files changed, 252 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 218075b67a98..a9eeb1f2fd97 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -18,6 +18,7 @@
SUBDIR += scsh
SUBDIR += tcsh
SUBDIR += vshnu
+ SUBDIR += wapsh
SUBDIR += zsh
SUBDIR += zsh-devel
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
new file mode 100644
index 000000000000..dcee040ca770
--- /dev/null
+++ b/shells/wapsh/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: wapsh
+# Date created: 13 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wapsh
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= http://www.exolution.de/wapsh/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+#RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13 \
+# ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+
+USERGUIDEDOCS= Image10.jpg Image11.jpg Image12.jpg Image13.jpg \
+ Image14.jpg Image15.jpg Image16.jpg Image17.jpg \
+ Image18.jpg Image19.jpg Image20.jpg Image21.jpg \
+ Image22.jpg Image23.jpg Image24.jpg Image25.gif \
+ Image26.jpg Image27.jpg Image28.jpg Image29.jpg \
+ Image30.jpg Image31.jpg Image32.jpg Image33.jpg \
+ Image34.jpg Image35.jpg Image36.jpg Image37.jpg \
+ Image38.jpg Image39.jpg Image4.gif Image40.jpg \
+ Image41.jpg Image42.jpg Image43.jpg Image44.jpg \
+ Image45.jpg Image46.jpg Image47.jpg Image48.jpg \
+ Image49.jpg Image5.gif Image50.gif Image51.jpg \
+ Image52.jpg Image53.gif Image54.jpg Image55.jpg \
+ Image56.jpg Image6.jpg Image7.jpg Image8.jpg \
+ Image9.jpg index.html
+
+HTDOCS= command.php command_html.inc command_wml.inc \
+ common.inc common_html.inc common_wml.inc \
+ controls_wml.php displayfuncs.inc getloginhosts.inc \
+ history_edit_wml.php history_html.php history_wml.php \
+ login_html.php login_wml.php scroll_wml.php \
+ shortcuts_wml.php
+
+post-patch:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > foo && \
+ ${MV} foo ${WRKSRC}/htshd/htshd.c
+
+do-build:
+ (cd ${WRKSRC}/htshd && ${CC} ${CFLAGS} -o htshd htshd.c -lcrypt \
+ -lutil -DUSE_DEV_RANDOM=1)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/htshd/htshd ${PREFIX}/sbin
+
+ ${MKDIR} ${PREFIX}/etc/wapsh
+.for C in htsh_profile htshd.conf loginhosts
+ ${INSTALL_DATA} ${WRKSRC}/sample/$C ${PREFIX}/etc/wapsh
+.endfor
+
+ ${MKDIR} ${PREFIX}/share/wapsh/htdocs
+.for H in ${HTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/$H ${PREFIX}/share/wapsh/htdocs
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/wapsh/admin_guide
+ ${MKDIR} ${PREFIX}/share/doc/wapsh/implementation_notes
+ ${MKDIR} ${PREFIX}/share/doc/wapsh/user_guide
+.for B in Image1.jpg Image2.jpg Image3.jpg index.html qpl.html
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/$B ${PREFIX}/share/doc/wapsh
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/admin_guide/index.html \
+ ${PREFIX}/share/doc/wapsh/admin_guide
+.for I in index.html image57.gif
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/implementation_notes/$I \
+ ${PREFIX}/share/doc/wapsh/implementation_notes
+.endfor
+.for U in ${USERGUIDEDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/user_guide/$U \
+ ${PREFIX}/share/doc/wapsh/user_guide
+.endfor
+.endif #if !defined(NOPORTDOCS)
+
+post-install:
+ @${ECHO} "updating /etc/services"
+ @${CP} /etc/services /etc/services.bak
+ @(${GREP} -v ^htsh /etc/services.bak; ${ECHO} "htsh 3001/tcp # htsh/wapsh server") > /etc/services
+ @if [ ! -f ${PREFIX}/etc/rc.d/htshd.sh ]; then \
+ ${ECHO} "===> Installing ${PREFIX}/etc/rc.d/htshd.sh startup file."; \
+ ${INSTALL_SCRIPT} ${FILESDIR}/htshd.sh ${PREFIX}/etc/rc.d/htshd.sh; \
+ fi
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/shells/wapsh/distinfo b/shells/wapsh/distinfo
new file mode 100644
index 000000000000..d6e44be5e968
--- /dev/null
+++ b/shells/wapsh/distinfo
@@ -0,0 +1 @@
+MD5 (wapsh_1.0.tar.gz) = 4e836a2edd189d3301ca6fa7ba52cafb
diff --git a/shells/wapsh/files/htshd.sh b/shells/wapsh/files/htshd.sh
new file mode 100644
index 000000000000..8013945fd7a9
--- /dev/null
+++ b/shells/wapsh/files/htshd.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x "${PREFIX}/sbin/htshd" -a -f "${PREFIX}/etc/wapsh/htshd.conf" ] && ${PREFIX}/sbin/htshd -f ${PREFIX}/etc/wapsh/htshd.conf > /dev/null && echo -n ' htshd'
+ ;;
+stop)
+ killall htshd && echo -n ' htshd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/shells/wapsh/files/patch-htshd::htshd.c b/shells/wapsh/files/patch-htshd::htshd.c
new file mode 100644
index 000000000000..712c7dc7821e
--- /dev/null
+++ b/shells/wapsh/files/patch-htshd::htshd.c
@@ -0,0 +1,15 @@
+--- htshd/htshd.c.orig Sat Jan 13 17:35:54 2001
++++ htshd/htshd.c Sat Jan 13 17:36:18 2001
+@@ -97,10 +97,10 @@
+ #define SERVICE_NAME "htsh" /* Should be in /etc/services
+ on login and http server hosts */
+
+-#define CONFIG_FILE "/etc/htshd.conf"
++#define CONFIG_FILE "%%PREFIX%%/etc/wapsh/htshd.conf"
+ /* Default name of startup config file */
+
+-#define GLOBAL_RC_FILE "/etc/htsh_profile"
++#define GLOBAL_RC_FILE "%%PREFIX%%/etc/wapsh/htsh_profile"
+ /* Default name of global user
+ initialisation file */
+ #define RCFILE ".htshrc" /* Name of user-specific initialisation file
diff --git a/shells/wapsh/pkg-comment b/shells/wapsh/pkg-comment
new file mode 100644
index 000000000000..7f873392cb87
--- /dev/null
+++ b/shells/wapsh/pkg-comment
@@ -0,0 +1 @@
+A system to allow remote shell logins via a WAP phone or web browser
diff --git a/shells/wapsh/pkg-descr b/shells/wapsh/pkg-descr
new file mode 100644
index 000000000000..7d2046a5caee
--- /dev/null
+++ b/shells/wapsh/pkg-descr
@@ -0,0 +1,17 @@
+htsh/wapsh is a system implemented by exolution GmbH which allows
+users to login to a Unix shell on a remote host using a web browser
+or WAP phone (in the latter incarnation, htsh is also called wapsh).
+
+The following phones and emulators have been successfully tested with
+htsh:
+ * Nokia 6210
+ * Nokia 7110
+ * Siemens C35 and S35
+ * Nokia WAP Toolkit 2.0 "Blueprint" phone emulator
+ * UP.Simulator 4.0 from Phone.com
+
+We welcome feedback (at wapsh@exolution.de) from users about their
+experiences using other phone types.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/shells/wapsh/pkg-message b/shells/wapsh/pkg-message
new file mode 100644
index 000000000000..1e9d938baca1
--- /dev/null
+++ b/shells/wapsh/pkg-message
@@ -0,0 +1,13 @@
+
+wapsh/htsh is now installed.
+
+Sample configuration files can be found in %%PREFIX%%/etc/wapsh
+
+HTML documentation has been installed in %%PREFIX%%/share/doc/wapsh
+
+PHP scripts for both HTTP and WAP access have been installed in
+%%PREFIX%%/share/wapsh/htdocs
+
+Please read the installed documentation for information on how to create
+the configuration files.
+
diff --git a/shells/wapsh/pkg-plist b/shells/wapsh/pkg-plist
new file mode 100644
index 000000000000..69bb7b844102
--- /dev/null
+++ b/shells/wapsh/pkg-plist
@@ -0,0 +1,91 @@
+sbin/htshd
+etc/rc.d/htshd.sh
+etc/wapsh/htsh_profile
+etc/wapsh/htshd.conf
+etc/wapsh/loginhosts
+share/wapsh/htdocs/command.php
+share/wapsh/htdocs/command_html.inc
+share/wapsh/htdocs/command_wml.inc
+share/wapsh/htdocs/common.inc
+share/wapsh/htdocs/common_html.inc
+share/wapsh/htdocs/common_wml.inc
+share/wapsh/htdocs/controls_wml.php
+share/wapsh/htdocs/displayfuncs.inc
+share/wapsh/htdocs/getloginhosts.inc
+share/wapsh/htdocs/history_edit_wml.php
+share/wapsh/htdocs/history_html.php
+share/wapsh/htdocs/history_wml.php
+share/wapsh/htdocs/login_html.php
+share/wapsh/htdocs/login_wml.php
+share/wapsh/htdocs/scroll_wml.php
+share/wapsh/htdocs/shortcuts_wml.php
+share/doc/wapsh/Image1.jpg
+share/doc/wapsh/Image2.jpg
+share/doc/wapsh/Image3.jpg
+share/doc/wapsh/admin_guide/index.html
+share/doc/wapsh/implementation_notes/image57.gif
+share/doc/wapsh/implementation_notes/index.html
+share/doc/wapsh/index.html
+share/doc/wapsh/qpl.html
+share/doc/wapsh/user_guide/Image10.jpg
+share/doc/wapsh/user_guide/Image11.jpg
+share/doc/wapsh/user_guide/Image12.jpg
+share/doc/wapsh/user_guide/Image13.jpg
+share/doc/wapsh/user_guide/Image14.jpg
+share/doc/wapsh/user_guide/Image15.jpg
+share/doc/wapsh/user_guide/Image16.jpg
+share/doc/wapsh/user_guide/Image17.jpg
+share/doc/wapsh/user_guide/Image18.jpg
+share/doc/wapsh/user_guide/Image19.jpg
+share/doc/wapsh/user_guide/Image20.jpg
+share/doc/wapsh/user_guide/Image21.jpg
+share/doc/wapsh/user_guide/Image22.jpg
+share/doc/wapsh/user_guide/Image23.jpg
+share/doc/wapsh/user_guide/Image24.jpg
+share/doc/wapsh/user_guide/Image25.gif
+share/doc/wapsh/user_guide/Image26.jpg
+share/doc/wapsh/user_guide/Image27.jpg
+share/doc/wapsh/user_guide/Image28.jpg
+share/doc/wapsh/user_guide/Image29.jpg
+share/doc/wapsh/user_guide/Image30.jpg
+share/doc/wapsh/user_guide/Image31.jpg
+share/doc/wapsh/user_guide/Image32.jpg
+share/doc/wapsh/user_guide/Image33.jpg
+share/doc/wapsh/user_guide/Image34.jpg
+share/doc/wapsh/user_guide/Image35.jpg
+share/doc/wapsh/user_guide/Image36.jpg
+share/doc/wapsh/user_guide/Image37.jpg
+share/doc/wapsh/user_guide/Image38.jpg
+share/doc/wapsh/user_guide/Image39.jpg
+share/doc/wapsh/user_guide/Image4.gif
+share/doc/wapsh/user_guide/Image40.jpg
+share/doc/wapsh/user_guide/Image41.jpg
+share/doc/wapsh/user_guide/Image42.jpg
+share/doc/wapsh/user_guide/Image43.jpg
+share/doc/wapsh/user_guide/Image44.jpg
+share/doc/wapsh/user_guide/Image45.jpg
+share/doc/wapsh/user_guide/Image46.jpg
+share/doc/wapsh/user_guide/Image47.jpg
+share/doc/wapsh/user_guide/Image48.jpg
+share/doc/wapsh/user_guide/Image49.jpg
+share/doc/wapsh/user_guide/Image5.gif
+share/doc/wapsh/user_guide/Image50.gif
+share/doc/wapsh/user_guide/Image51.jpg
+share/doc/wapsh/user_guide/Image52.jpg
+share/doc/wapsh/user_guide/Image53.gif
+share/doc/wapsh/user_guide/Image54.jpg
+share/doc/wapsh/user_guide/Image55.jpg
+share/doc/wapsh/user_guide/Image56.jpg
+share/doc/wapsh/user_guide/Image6.jpg
+share/doc/wapsh/user_guide/Image7.jpg
+share/doc/wapsh/user_guide/Image8.jpg
+share/doc/wapsh/user_guide/Image9.jpg
+share/doc/wapsh/user_guide/index.html
+@exec echo "updating /etc/services"; cp /etc/services /etc/services.bak; (grep -v ^htsh /etc/services.bak ; echo "htsh 3001/tcp # htsh/wapsh server") > /etc/services
+@unexec echo "updating /etc/services"; cp /etc/services /etc/services.bak; (grep -v ^htsh /etc/services.bak ) > /etc/services
+@dirrm etc/wapsh
+@dirrm share/doc/wapsh/admin_guide
+@dirrm share/doc/wapsh/implementation_notes
+@dirrm share/doc/wapsh/user_guide
+@dirrm share/doc/wapsh
+@dirrm share/wapsh/htdocs