aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-06-07 15:23:55 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-06-07 15:23:55 +0000
commit7e814a58ecd2fca47724127dab1c45dfc7168f3b (patch)
treeadd7741881ab42df33ff609f9cd95162e06f6448
parent7368ea4606151d64675c243693f21489e0818648 (diff)
downloadports-7e814a58ecd2fca47724127dab1c45dfc7168f3b.tar.gz
ports-7e814a58ecd2fca47724127dab1c45dfc7168f3b.zip
Notes
-rw-r--r--emulators/linux-pete-mesagpu/Makefile2
-rw-r--r--emulators/linux-pete-xgl2gpu/Makefile2
-rw-r--r--games/atitd/Makefile2
-rw-r--r--games/linux-coldwar-demo/Makefile2
-rw-r--r--games/linux-darwinia-demo/Makefile2
-rw-r--r--games/linux-defcon/Makefile2
-rw-r--r--games/linux-doom3-demo/Makefile2
-rw-r--r--games/linux-gorky17-demo/Makefile2
-rw-r--r--games/linux-nerogame/Makefile4
-rw-r--r--games/linux-nwnclient/Makefile2
-rw-r--r--games/linux-savage-samuraiwars/Makefile4
-rw-r--r--games/linux-savage/Makefile4
-rw-r--r--games/linux-uplink-demo/Makefile2
-rw-r--r--games/linux-ut2003-demo/Makefile2
-rw-r--r--games/linux-ut2004-demo/Makefile2
-rw-r--r--games/linux-virtual-jay-peak/Makefile2
-rw-r--r--games/linux-warsow/Makefile4
-rw-r--r--graphics/linux-ac3d/Makefile2
-rw-r--r--math/mupad/Makefile2
-rw-r--r--net-im/skype12/Makefile2
-rw-r--r--net/skype12/Makefile2
21 files changed, 21 insertions, 29 deletions
diff --git a/emulators/linux-pete-mesagpu/Makefile b/emulators/linux-pete-mesagpu/Makefile
index 0c092262ea0d..4d8baae4ece4 100644
--- a/emulators/linux-pete-mesagpu/Makefile
+++ b/emulators/linux-pete-mesagpu/Makefile
@@ -19,7 +19,7 @@ COMMENT= A PSEmu Pro GPU plugin using an OpenGL renderer (Linux version)
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
NO_WRKSUBDIR= yes
diff --git a/emulators/linux-pete-xgl2gpu/Makefile b/emulators/linux-pete-xgl2gpu/Makefile
index c25f328e8e46..a8d5aec27ede 100644
--- a/emulators/linux-pete-xgl2gpu/Makefile
+++ b/emulators/linux-pete-xgl2gpu/Makefile
@@ -17,7 +17,7 @@ COMMENT= A PSEmu Pro GPU plugin using a modern OpenGL renderer (Linux version)
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
NO_WRKSUBDIR= yes
diff --git a/games/atitd/Makefile b/games/atitd/Makefile
index 1a181c5f2242..f6dab840a91d 100644
--- a/games/atitd/Makefile
+++ b/games/atitd/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/xhost:${PORTSDIR}/x11/xhost
.ifdef(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
PLIST_FILES= bin/atitd
diff --git a/games/linux-coldwar-demo/Makefile b/games/linux-coldwar-demo/Makefile
index 822449c4a63f..7c206c62c31b 100644
--- a/games/linux-coldwar-demo/Makefile
+++ b/games/linux-coldwar-demo/Makefile
@@ -34,7 +34,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-darwinia-demo/Makefile b/games/linux-darwinia-demo/Makefile
index b67689897917..5f665fd094ba 100644
--- a/games/linux-darwinia-demo/Makefile
+++ b/games/linux-darwinia-demo/Makefile
@@ -34,7 +34,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-defcon/Makefile b/games/linux-defcon/Makefile
index 4e1ec563318b..dd7e51e735cf 100644
--- a/games/linux-defcon/Makefile
+++ b/games/linux-defcon/Makefile
@@ -32,7 +32,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-build:
diff --git a/games/linux-doom3-demo/Makefile b/games/linux-doom3-demo/Makefile
index dd7cf71f34a5..1eabf7d3484d 100644
--- a/games/linux-doom3-demo/Makefile
+++ b/games/linux-doom3-demo/Makefile
@@ -38,7 +38,7 @@ SUB_LIST= DOOMDIR="${DOOMDIR}"
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-gorky17-demo/Makefile b/games/linux-gorky17-demo/Makefile
index 266418c8628c..dc6edd0f8003 100644
--- a/games/linux-gorky17-demo/Makefile
+++ b/games/linux-gorky17-demo/Makefile
@@ -35,7 +35,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-nerogame/Makefile b/games/linux-nerogame/Makefile
index aac80146a7ac..0a54893bc017 100644
--- a/games/linux-nerogame/Makefile
+++ b/games/linux-nerogame/Makefile
@@ -33,9 +33,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
. endif
.else
-. if !exists(${LINUXBASE}/usr/X11R6/lib/libGL.so.1)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
-. endif
+USE_LINUX_APPS+=dri
.endif
do-install:
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index bac03bbbce1d..720250126362 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
NO_BUILD= yes
diff --git a/games/linux-savage-samuraiwars/Makefile b/games/linux-savage-samuraiwars/Makefile
index c198db8bc34e..9788d04b206e 100644
--- a/games/linux-savage-samuraiwars/Makefile
+++ b/games/linux-savage-samuraiwars/Makefile
@@ -43,9 +43,7 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
. endif
.else
-. if !exists(${LINUXBASE}/usr/lib/libGL.so.1)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
-. endif
+USE_LINUX_APPS+=dri
.endif
do-install:
diff --git a/games/linux-savage/Makefile b/games/linux-savage/Makefile
index 44e5c04f43d1..a643a2458958 100644
--- a/games/linux-savage/Makefile
+++ b/games/linux-savage/Makefile
@@ -44,9 +44,7 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
. endif
.else
-. if !exists(${LINUXBASE}/usr/lib/libGL.so.1)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
-. endif
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-uplink-demo/Makefile b/games/linux-uplink-demo/Makefile
index a241bada1798..71f5a2a5781c 100644
--- a/games/linux-uplink-demo/Makefile
+++ b/games/linux-uplink-demo/Makefile
@@ -37,7 +37,7 @@ OPTIONS= NVIDIA "Install support for nvidia" off
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-ut2003-demo/Makefile b/games/linux-ut2003-demo/Makefile
index 0fe569c2262d..c937cca11cf1 100644
--- a/games/linux-ut2003-demo/Makefile
+++ b/games/linux-ut2003-demo/Makefile
@@ -45,7 +45,7 @@ LIBDIRS= Animations Benchmark ForceFeedback KarmaData Maps Music \
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-ut2004-demo/Makefile b/games/linux-ut2004-demo/Makefile
index 9c220192c4d1..4cc8cda5c883 100644
--- a/games/linux-ut2004-demo/Makefile
+++ b/games/linux-ut2004-demo/Makefile
@@ -47,7 +47,7 @@ LIBDIRS= Animations Benchmark ForceFeedback KarmaData Maps Music \
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
do-extract:
diff --git a/games/linux-virtual-jay-peak/Makefile b/games/linux-virtual-jay-peak/Makefile
index e3e02d7a91b9..7b5e39bb1171 100644
--- a/games/linux-virtual-jay-peak/Makefile
+++ b/games/linux-virtual-jay-peak/Makefile
@@ -47,7 +47,7 @@ do-install:
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
.include <bsd.port.post.mk>
diff --git a/games/linux-warsow/Makefile b/games/linux-warsow/Makefile
index 79ec4a4ae1a7..c0f8e77e4358 100644
--- a/games/linux-warsow/Makefile
+++ b/games/linux-warsow/Makefile
@@ -61,9 +61,7 @@ IGNORE= requires at least one of CLIENT and SERVER options
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
. endif
.else
-. if !exists(${LINUXBASE}/usr/X11R6/lib/libGL.so.1)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
-. endif
+USE_LINUX_APPS+=dri
.endif
.if ${ARCH} == "i386"
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index 6b3afd7af781..0363f93df954 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -22,7 +22,7 @@ COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
RESTRICTED= no distribution permitted
diff --git a/math/mupad/Makefile b/math/mupad/Makefile
index dee5b15d7cf3..360e50943bcc 100644
--- a/math/mupad/Makefile
+++ b/math/mupad/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A sophisticated computer algebra system
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
NO_CDROM= unsure to sell for profit
diff --git a/net-im/skype12/Makefile b/net-im/skype12/Makefile
index 70ff3caea62b..4527a947e23b 100644
--- a/net-im/skype12/Makefile
+++ b/net-im/skype12/Makefile
@@ -34,7 +34,7 @@ IGNORE= Legacy version, Use net/skype
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
WRKSRC= ${WRKDIR}/skype-${PORTVERSION}
diff --git a/net/skype12/Makefile b/net/skype12/Makefile
index 70ff3caea62b..4527a947e23b 100644
--- a/net/skype12/Makefile
+++ b/net/skype12/Makefile
@@ -34,7 +34,7 @@ IGNORE= Legacy version, Use net/skype
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_LINUX_APPS+=dri
.endif
WRKSRC= ${WRKDIR}/skype-${PORTVERSION}