aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:58:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:58:44 +0000
commit7eada2e2f99eaf32fa27561929464051f60bfbe6 (patch)
tree3183ac0850f9ea51b2acdd61cd12bfe14dd4b311
parent2f727d06148e9eae296ec149919dd011e89d08b8 (diff)
downloadports-7eada2e2f99eaf32fa27561929464051f60bfbe6.tar.gz
ports-7eada2e2f99eaf32fa27561929464051f60bfbe6.zip
Notes
-rw-r--r--www/ziproxy/Makefile13
-rw-r--r--www/ziproxy/distinfo6
-rw-r--r--www/ziproxy/files/patch-ziproxy.conf34
-rw-r--r--www/ziproxy/pkg-plist6
4 files changed, 46 insertions, 13 deletions
diff --git a/www/ziproxy/Makefile b/www/ziproxy/Makefile
index e47a1c8c4ad9..997e67a00b6b 100644
--- a/www/ziproxy/Makefile
+++ b/www/ziproxy/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ziproxy
-PORTVERSION= 2.5.2
+PORTVERSION= 2.6.0
CATEGORIES= www
MASTER_SITES= SF
@@ -20,18 +20,17 @@ USE_BZIP2= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-ERRORFILES= 400.html 404.html 408.html 500.html 503.html
+ERRORFILES= 400.html 404.html 407.html 408.html 409.html 500.html 503.html
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cfgfile="${PREFIX}/etc/ziproxy/ziproxy.conf"
-.if !defined(NOPORTDOCS)
-PORTDOCS= README
-.endif
+PORTDOCS= README README.ru README.tools README.tools.ru JPEG2000.txt JPEG2000.ru.txt
MAN1= ziproxy.1 ziproxylogtool.1
+MANLANG= "" ru
MANCOMPRESSED= no
USE_RC_SUBR= ziproxy
@@ -47,6 +46,10 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/ziproxy
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/bo_exception.list ${PREFIX}/etc/ziproxy/bo_exception.list
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/http.passwd ${PREFIX}/etc/ziproxy/http.passwd
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/noprocess.list ${PREFIX}/etc/ziproxy/noprocess.list
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/replace.list ${PREFIX}/etc/ziproxy/replace.list
@${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf.sample
@if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
${CP} -p ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf ; \
diff --git a/www/ziproxy/distinfo b/www/ziproxy/distinfo
index 936d923f6999..6a80ff95a2c6 100644
--- a/www/ziproxy/distinfo
+++ b/www/ziproxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (ziproxy-2.5.2.tar.bz2) = 7b80964ab481ad729bd1a7ccadb6f751
-SHA256 (ziproxy-2.5.2.tar.bz2) = 6651c41713ea7044804d4c8cccdbf22a5b0eda79d499938be4b67a335f606853
-SIZE (ziproxy-2.5.2.tar.bz2) = 243994
+MD5 (ziproxy-2.6.0.tar.bz2) = b7d57ace56a3be34446ef1b68ac85205
+SHA256 (ziproxy-2.6.0.tar.bz2) = 9f0c1f0cd5f424631c55e1e51a49562c50ca8d79ae108e337cd3ef5d32260289
+SIZE (ziproxy-2.6.0.tar.bz2) = 262943
diff --git a/www/ziproxy/files/patch-ziproxy.conf b/www/ziproxy/files/patch-ziproxy.conf
index c6ca24b16e95..1d03cbc7b2c3 100644
--- a/www/ziproxy/files/patch-ziproxy.conf
+++ b/www/ziproxy/files/patch-ziproxy.conf
@@ -1,5 +1,5 @@
---- etc/ziproxy/ziproxy.conf.orig Thu Jan 24 20:41:01 2008
-+++ etc/ziproxy/ziproxy.conf Fri Feb 1 00:34:04 2008
+--- etc/ziproxy/ziproxy.conf.orig 2008-11-18 00:28:03.000000000 +0300
++++ etc/ziproxy/ziproxy.conf 2008-11-18 00:29:22.000000000 +0300
@@ -12,12 +12,12 @@
## If you have more than one network interface,
## it's useful for restricting to which interface you want to bind to.
@@ -24,16 +24,34 @@
## Forward everything to another proxy server.
## Modifications/compression is still applied.
-@@ -371,7 +371,7 @@
+@@ -105,7 +105,7 @@
+ ## This option has no effect if BindOutgoing is not used.
+ ## Default: empty, no hosts are exempted.
+ ## See also: BindOutgoingExAddr
+-# BindOutgoingExList="/etc/ziproxy/bo_exception.list"
++# BindOutgoingExList="%%PREFIX%%/etc/ziproxy/bo_exception.list"
+
+ ## Defines a specific IP to be bound to for hosts specified in BindOutgoingExList.
+ ## As with BindOutgoing, this IP must be a local IP from the server running Ziproxy.
+@@ -391,7 +391,7 @@
## *** THIS IS NOT SUPPOSED TO BE A DEFINITIVE SOLUTION TO INCOMPATIBILITIES ***
##
- ## Defauly: empty (no file specified, inactive)
+ ## Default: empty (no file specified, inactive)
-# URLNoProcessing = "/etc/ziproxy/noprocess.list"
+# URLNoProcessing = "%%PREFIX%%/etc/ziproxy/noprocess.list"
+ ## This option specifies a file containing a list of URLs which its
+ ## data should be intercepted and replaced by another.
+@@ -409,7 +409,7 @@
+ ## and cookies are transported) -- a stealthy ad-blocker, if you like.
+ ##
+ ## Default: empty (no file specified, inactive)
+-# URLReplaceData = "/etc/ziproxy/replace.list"
++# URLReplaceData = "%%PREFIX%%/etc/ziproxy/replace.list"
+
## Custom HTTP Error Messages
## Define here the full path to the HTML file which should be
-@@ -379,15 +379,15 @@
+@@ -417,19 +417,19 @@
## Note: The internal defaults give more precise error messages.
##
## 400 - Bad request (malformed URL, or unknown URL type)
@@ -42,9 +60,15 @@
## 404 - Unknown host (Ziproxy will not issue 'page not found' errors itself)
-# CustomError404="/var/ziproxy/error/404.html"
+# CustomError404="%%DATADIR%%/error/404.html"
+ ## 407 - Proxy Authentication Required
+-# CustomError407="/var/ziproxy/error/407.html"
++# CustomError407="%%DATADIR%%/error/407.html"
## 408 - Request timed out
-# CustomError408="/var/ziproxy/error/408.html"
+# CustomError408="%%DATADIR%%/error/408.html"
+ ## 409 - Conflict
+-# CustomError409="/var/ziproxy/error/409.html"
++# CustomError409="%%DATADIR%%/error/409.html"
## 500 - Internal error (or empty response from server)
-# CustomError500="/var/ziproxy/error/500.html"
+# CustomError500="%%DATADIR%%/error/500.html"
diff --git a/www/ziproxy/pkg-plist b/www/ziproxy/pkg-plist
index f74032e9c71b..ef5cf885af1e 100644
--- a/www/ziproxy/pkg-plist
+++ b/www/ziproxy/pkg-plist
@@ -2,13 +2,19 @@ bin/ziproxy
bin/ziproxylogtool
bin/ziproxy_genhtml_stats.sh
@exec mkdir -p %D/etc/ziproxy
+etc/ziproxy/bo_exception.list
+etc/ziproxy/http.passwd
+etc/ziproxy/noprocess.list
+etc/ziproxy/replace.list
@unexec if cmp -s %D/etc/ziproxy/ziproxy.conf.sample %D/etc/ziproxy/ziproxy.conf; then rm -f %D/etc/ziproxy/ziproxy.conf; fi
@exec if [ ! -f %D/etc/ziproxy/ziproxy.conf ] ; then cp -p %D/%F %B/ziproxy.conf; fi
etc/ziproxy/ziproxy.conf.sample
@dirrmtry etc/ziproxy
%%DATADIR%%/error/400.html
%%DATADIR%%/error/404.html
+%%DATADIR%%/error/407.html
%%DATADIR%%/error/408.html
+%%DATADIR%%/error/409.html
%%DATADIR%%/error/500.html
%%DATADIR%%/error/503.html
@dirrm %%DATADIR%%/error